Subject: Re: [Iptel] Re: Finishing work on trunk-group

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 10 May 2005 13:49:15 -0500

Shan Lu wrote:
> Vijay,
> 
> I support adding "trunk-context". But I would prefer to allow 
> "tel:411;phone-context=foo.com;tgrp=abc123" as a valid format. If
> "trunk-context" is present, it defines context for the trunk group. If not,
> "phone-context" serves that purpose. 

Shan Lu, folks:

    (For a context, here is the previous discussion on this thread:
     http://www1.ietf.org/mail-archive/web/iptel/current/msg00875.html)

Continuing this discussion forward...

I think we should leave phone-context as is; i.e., not overload
it for trunk group semantics.  Otherwise, some precedence rules
become neccessary when interpreting trunk groups in the
presence of the phone-context parameter; precedence rules that
may only cause confusion.

> Often times, tel uri is carried in sip uri. The userinfo portion already
> looks ugly w/o "trunk-context" :-)

I agree; but such is the nature of the beast.

> Would you be able to post your text/example to list before submitting new
> rev? It may save another round of commenting.

Absolutely.  Here goes:

1) Trunk group in a local number (with phone-context parameter):
   tel:5551212;phone-context=+1-630;tgrp=TG-1;trunk-context=example.com

2) Trunk group in a global number:
    tel:+16305551212;tgrp=TG-1;trunk-context=example.com

3) Trunk group in a global number:
    tel:+16305551212;tgrp=TG-1;trunk-context=+1-630

If okay, I will rev the I-D and send it out right away.

Thanks,

- vijay

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 17 May 2005 15:25:43 -0700

On 5/10/05 11:49 AM, "Vijay K. Gurbani" <[email-masked]> wrote:

> Here goes:

Look forward to getting the rev and calling this done.