Subject: [Iptel] RE: [Enum] Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs incommonpolicy

From: "Stastny Richard" <[email-masked]>
Date: Thu, 18 Aug 2005 16:19:48 +0200

I strongly support this, because this would
finally end the confusion with dialled digits and 
phone numbers

BTW, Brian, please update 
draft-rosen-iptel-dialstring-02.txt

becauseit is obsolete already.
In addition, I would propose then a WGLC
So I copy this to the iptel list also

Richard Stastny
OeFEG
tel:+43 664 420 4100
enum:+43 780 203 211
callto://fordprefect
http://voipandenum.blogspot.com

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Brian Rosen
> Sent: Thursday, August 18, 2005 3:36 PM
> To: 'Otmar Lendl'; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [Enum] Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs
> incommonpolicy
> 
> In step 1, if the phone does not do dialplan interpretation, then what
the
> user entered is a dialstring, and not a telephone number.  This could
be
> encoded, as you show, as a SIP uri, but might be better encoded as a
> dialstring, per draft-rosen-iptel-dialstring-02.txt.  A tel uri is
> explicitly NOT used to carry a dialstring.
> 
> I think it would be better labeled as a dialstring, and not something
that
> could be confused as a telephone number.  It remains true that the
user-
> part
> of sip:[email-masked] can only be interpreted by the
> my-voip-provider.at domain, so your flow definitely can work.
> 
> Brian
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Otmar Lendl
> Sent: Thursday, August 18, 2005 6:33 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: [Enum] Re: [voipeer] Re: [Geopriv] Re: [Simple] tel URIs in
> commonpolicy
> 
> On 2005/08/18 05:08, Jonathan Rosenberg <[email-masked]> wrote:
> >
> > My point is that I think it makes sense to consider the tel URI a
URN,
> > and that it is merely an accident of history that it wasn't a URN
more
> > properly. Now, as you and I both know phone numbers in the PSTN are
> > abused to represent lots of things, but there is no reason to carry
> > forward this confusion into voip. This is why I am proposing that
when a
> > phone number is in a tel URI, it represents a name. We don't know
where
> > it is on the network (indeed even if its on an IP network). To know
> > that, we translate to an address. That address is a SIP URI. That
SIP
> > URI can contain a phone number, i.e.
> > sip:[email-masked];user=phone, however in this format the
> > phone number has been resolved to an address. The act of porting a
> > number is a change in the translation of the phone number as a name
(the
> > tel URI) to the phone number as an address (the SIP URI).
> >
> 
> This is a very sensible notion.
> 
> Based on this thinking the dialing of a number on a VoIP-phone
> goes through the following conceptual stages:
> 
> 1) User enters a (potentially partial) number on his phone.
>    The phone appends its default domain and sends the invite to its
proxy:
>    e.g. 	sip:[email-masked]
> 
> 2) The SIP proxy applies the local dialplan to translate the
>    SIP address to an E.164 number:
> 
>    e.g. customer is in vienna, thus 5056416 maps to +43 1 5056416
>    -> We now have a URN: tel:+4315056416
> 
> 3) The SIP proxy now tries to route the call. In this example,
>    user ENUM finds:
>    "E2U+sip" "!^.*$!sip:[email-masked]!"
> 
>    or it could map to the local PSTN gateway with an URI like
>    sip:[email-masked]
> 
> /ol
> --
> < Otmar Lendl ([email-masked]) | nic.at Systems Engineer >
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum
> 
> 
> 
> _______________________________________________
> enum mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/enum

_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: lconroy <[email-masked]>
Date: Thu, 18 Aug 2005 15:41:11 +0100

Hi Brian, folks,
[Note - trimmed CC to remove just iptel - I thought that this was "of  
interest to" iptel]

Herewith a "me too".
I take it that Richard has reviewed the draft and thinks it is "ready  
to go".

I like this draft - it's short and to the point, and resolves a LOT  
of confusion.
- it even has a non-empty security section with an issue that is well  
put.

More formally, I have reviewed draft-rosen-iptel-dialstring-02.txt,  
and believe
that it is ready for WGLC/IETF LC.

Brian::

My only comment is that it could do with an example SIP URI, to make  
sure that
implementers who only look at the examples DO insert a context  
parameter into
the SIP URI.
[The MUST strength statement IS in the text, but from experience ... ]

Jonathon::

I note that this is an individual draft, and has just expired.

Given the status of the IPTEL WG, should this be adopted as an
IPTEL draft and up-issued as "draft-iptel-dialstring-00.txt"?

Either way, it's ready to roll, IMHO.

all the best,
   Lawrence

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 18 Aug 2005 11:37:34 -0400

I asked the IESG to publish -02 as an individual submission.
Jon Peterson is shepherding.

Brian

-----Original Message-----
From: lconroy [mailto:[email-masked]] 
Sent: Thursday, August 18, 2005 10:41 AM
To: Brian Rosen
Cc: Stastny Richard; Otmar Lendl; [email-masked]; Jonathan Rosenberg
Subject: Re: [Iptel] RE: [Enum] Re: [voipeer] Re: [Geopriv] Re: [Simple] tel
URIs incommonpolicy

Hi Brian, folks,

Herewith a "me too".

Brian::

Jonathon::

all the best,
   Lawrence