Subject: [Iptel] Suggestion for draft-munakata-iptel-isub-type-01.txt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 5 May 2006 12:05:56 -0400

I was thinking that adding a binary example might make this much easier
to comprehend.  Below is some suggested text that could be added into
the document somewhere.
 
begin/
 
NSAP=20 octets
 
Octet    Example 1    Example 2    Example 3
 1   AFI 0101 0000 or 0100 1000 or 1111 1111
 2    ?  0011 0001     (same)       (same)
 3   DSP 0011 0010        |            |
 4    |  0011 0011        v            v
 5    v  0011 0100
 6       0011 0101
 7       0011 0110
 8       0011 0111
 9       0011 1000
10       0100 1001
11       0100 0001
12       0100 0010
13       0100 0011
14       0100 0100
15       0100 0101
16       0100 0110
17       0100 0111
18       0100 1000
19       0100 1001
20       0100 1010
 
Example 1:  isub=123456789ABCDEFGHIJ;isub-type="nsap-ia5"
            Note that:
               AFI (50) is not included,
               IDI is null (octet 2 is part of DSP), and 
               isub is 19 characters long
 
Example 2:
isub=3132333435363738394142434445464748494A;isub-type="nsap-bcd"
            Note that:
               AFI (48) is not included,
               IDI is null (octet 2 is part of DSP), and 
               isub is 38 characters long
 
Example 3:
isub=FF3132333435363738394142434445464748494A;isub-type="nsap"
            Note that:
               AFI (FF) is included,
               IDI may or may not be octet 2 value "31" or further
values, and 
               isub is 40 characters long
 
/end
 
Comment:  I selected FF arbitrarily and did not check to see whether it
was assigned or not.  It is 
intended to represent a value for which we don't know and don't care so
long as it is transmitted.

Note that the trade-off between adding "-bcd" and not including "48" is
minimal.
 
Thanks,
Mike
 
_______________________________________________
Iptel mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iptel

---

From: Shida Schubert <[email-masked]>
Date: Sat, 06 May 2006 22:14:28 -0700

Few other reviewers did indeed suggest to add a
table to make it easier for people to comprehend. And
we really should have done that. Thanks for detailed
suggestion, we will add this to appendix in the next revision.

Regards
Shida Schubert

Michael Hammer (mhammer) wrote:
> I was thinking that adding a binary example might make this much
> easier to comprehend. Below is some suggested text that could be added
> into the document somewhere.
> begin/
> NSAP=20 octets
> Example 3: isub=FF3132333435363738394142434445464748494A;isub-type="nsap"
> Note that:
> AFI (FF) is included,
> IDI may or may not be octet 2 value "31" or further values, and
> intended to represent a value for which we don't know and don't care
> so long as it is transmitted.
> Note that the trade-off between adding "-bcd" and not including "48"
> is minimal.
> Thanks,
> Mike
> ------------------------------------------------------------------------
>