Subject: RE: WG Request: Adopt draft-haberman-ipv6-ra-flags-option-00.txt

From: Tim Enos <[email-masked]>
Date: Mon, 05 Feb 2007 12:37:27 -0600 (CST)

Good afternoon all,

>From: "Durand, Alain" <[email-masked]>
>Date: 2007/02/05 Mon AM 11:14:10 CST
>To: Brian Haberman <[email-masked]>, [email-masked]
>Subject: RE: WG Request: Adopt draft-haberman-ipv6-ra-flags-option-00.txt

>I would like to ask what is the transition plan for "legacy" IPv6 hosts
>that do not implement this extension before I could consider this draft
>a viable approach.

This is a good question. FWIW, at the moment I would expect that the "legacy" IPv6 hosts would ignore the extension and continue processing the RA.

Another question seems to be what would happen to hosts which implement/rely upon flags that were un-defined as a result of the "clean-up" process mentioned elsewhere in this e-mail.

>
>We have a number of bits that are currently defined that may be
>questionable,
>(the best example: O & M), so I would like to see some more
>justification
>why more bits are needed for the general RA case and maybe some clean-up
>of the current bits before we embark into defining a new space for
>potentially questionable new cases.

I agree that some more justification (and potentially some subsequent "clean-up") of the already defined bits may be advisable prior to defining new space. 

>
>So, at this point, I do not support this draft.
>
>  - Alain.

Respectfully,

Tim Enos
Rom 8:28
>
> 
>
>> -----Original Message-----
>> From: Brian Haberman [mailto:[email-masked]] 
>> Sent: Friday, February 02, 2007 12:41 PM
>> To: [email-masked]
>> Subject: WG Request: Adopt draft-haberman-ipv6-ra-flags-option-00.txt
>> 
>> All,
>>      This is a formal call to request IPv6 WG feedback on 
>> adopting the below draft.  The premise of the draft is to 
>> expand the flags field that is quickly running out of bits.
>> 
>>      Please provide your preference (positive or negative) on 
>> having this document become an IPv6 WG document.  Comments on 
>> the contents are most welcome as well.
>> 
>> Regards,
>> Brian
>> 
>> 
>> -------- Original Message --------
>> Subject: I-D ACTION:draft-haberman-ipv6-ra-flags-option-00.txt
>> Date: Tue, 01 Aug 2006 15:50:01 -0400
>> From: [email-masked]
>> Reply-To: [email-masked]
>> To: [email-masked]
>> 
>> A New Internet-Draft is available from the on-line 
>> Internet-Drafts directories.
>> 
>> 
>> 	Title		: IPv6 Router Advertisement Flags Option
>> 	Author(s)	: B. Haberman, R. Hinden
>> 	Filename	: draft-haberman-ipv6-ra-flags-option-00.txt
>> 	Pages		: 7
>> 	Date		: 2006-8-1
>> 	
>> The IPv6 Neighbor Discovery's Router Advertisement message 
>> contains an 8-bit field reserved for single-bit flags.  
>> Several protocols have reserved flags in this field and 
>> others are preparing to reserve a sufficient number of flags 
>> to exhaust the field.  This document defines an option to the 
>> Router Advertisement message that expands the available 
>> number of flag bits available.
>> 
>> 
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-haberman-ipv6-ra-fla
>> gs-option-00.txt
>> 
>> 
>
>--------------------------------------------------------------------
>IETF IPv6 working group mailing list
>[email-masked]
>Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
>--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Tim Enos <[email-masked]>
Date: Mon, 05 Feb 2007 12:34:08 -0600 (CST)

Good afternoon all,

>So, at this point, I do not support this draft.

Best Regards,

Tim Enos
Rom 8:28