Subject: Proposal to change status of RFC 4038

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 4 Dec 2009 13:46:25 -0800 (PST)

Hello 6manners,
  We are hearing the news that RFC 4038 has started to be used by app developers for IPv6 transition. See recent softwire discussions.

  There is concern that this is an informational RFC. I think that IETF can reissue it as a BCP and 6man is probably the right place.

Regards,

Behcet

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 05 Dec 2009 11:40:28 +1300

> There is concern that this is an informational RFC.

I don't understand that. Why would anyone care?

I do have one concern, though. It would be much better if the
code fragments were clearly under the current regime (i.e.
simplified BSD license from the IETF Trust).

Apart from that, are there any major technical concerns that
would justify an update?

Regards
   Brian

(P.S. I do think this is a very valuable RFC!)

On 2009-12-05 10:46, Behcet Sarikaya wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 4 Dec 2009 15:14:00 -0800 (PST)

Brian, in view of changing times, I do think that it is recommended to republish this valuable RFC as a BCP, possibly with some small changes, so starting with 4038bis.

--behcet

----- Original Message ----
> From: Brian E Carpenter <[email-masked]>
> To: Behcet Sarikaya <[email-masked]>
> Cc: [email-masked]
> Sent: Fri, December 4, 2009 4:40:28 PM
> Subject: Re: Proposal to change status of RFC 4038
> 
> >  We are hearing the news that RFC 4038 has started to be used by app 
> developers for IPv6 transition. See recent softwire discussions.
> > 
> >  There is concern that this is an informational RFC. I think that IETF can 
> reissue it as a BCP and 6man is probably the right place.
> > 
> > Regards,
> > 
> > Behcet
> > 
> > 
> >

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 4 Dec 2009 19:06:40 -0500

> simplified BSD license from the IETF Trust).

And we would be glad to have them... if we could all the necessary  
permissions.

Marshall

>>  We are hearing the news that RFC 4038 has started to be used by  
>> app developers for IPv6 transition. See recent softwire discussions.
>>
>>  There is concern that this is an informational RFC. I think that  
>> IETF can reissue it as a BCP and 6man is probably the right place.
>>
>> Regards,
>>
>> Behcet
>>
>>
>>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 05 Dec 2009 16:34:49 +1300

Behcet,

You're still not giving any *reasons* why this should be a BCP.
The IETF doesn't standardise implementations, or even APIs,
so I don't see why we would make this a normative document.

Getting a good library out under the BSD license would do a lot
more than SHOULDs and MUSTs in an RFC, imho.

Regards
   Brian

---

From: Brian Haberman <[email-masked]>
Date: Sat, 05 Dec 2009 07:42:07 -0500

I agree with Brian C. on this.  What changes would go into the document? 
What limitations are people seeing from it being an Informational RFC?

Regards,
Brian

Brian E Carpenter wrote:
> Behcet,
> 
> You're still not giving any *reasons* why this should be a BCP. The
> IETF doesn't standardise implementations, or even APIs, so I don't
> see why we would make this a normative document.
> 
> Getting a good library out under the BSD license would do a lot more
> than SHOULDs and MUSTs in an RFC, imho.
> 
> Regards Brian
> 
>> Brian, in view of changing times, I do think that it is recommended
>> to republish this valuable RFC as a BCP, possibly with some small
>> changes, so starting with 4038bis.
>> 
>> --behcet
>> 
>>> From: Brian E Carpenter <[email-masked]> To: Behcet
>>> Sarikaya <[email-masked]> Cc: [email-masked] Sent: Fri,
>>> December 4, 2009 4:40:28 PM Subject: Re: Proposal to change
>>> status of RFC 4038
>>> 
>>> Regards Brian
>>>> Hello 6manners, We are hearing the news that RFC 4038 has
>>>> started to be used by app
>>>>  IETF IPv6 working group mailing list [email-masked] 
>>>> Administrative Requests:
>>>> https://www.ietf.org/mailman/listinfo/ipv6 
> IETF IPv6 working group mailing list [email-masked] Administrative
> Requests: https://www.ietf.org/mailman/listinfo/ipv6

---

From: Pekka Savola <[email-masked]>
Date: Mon, 7 Dec 2009 08:10:35 +0200 (EET)

> simplified BSD license from the IETF Trust).

For the record, the first version of code appeared in 2002 and was 
from someone at ETRI:

http://tools.ietf.org/html/draft-shin-ngtrans-application-transition-01

About a year later, I rewrote and reformatted most if not all of the 
code that now appears in RFC4038.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 7 Dec 2009 09:48:33 -0800 (PST)

----- Original Message ----
> Sent: Fri, December 4, 2009 9:34:49 PM

I looked briefly at previous BCPs, I think that 4038 is very much inline with the BCP spirit. Maybe we should change the title from:

Application Aspects of IPv6 Transition

to 

Transistioning Applications to IPv6.

then this would go well inline with BCPs like selecting and operating secondary DNS servers, and so on.

This is my reply to Brian H.'s question What changes would go into the document?

> more than SHOULDs and MUSTs in an RFC, imho.

I saw some BCPs that contain code.

To this point: What limitations are people seeing from it being an Informational RFC?

I think it would give a good boost to IPv6 migration that is currently under way much more than when this RFC was published, i.e. about four-five years ago.

Regards,

Behcet