Subject: Question for Flow Label

From: "Yiu L. Lee" <[email-masked]>
Date: Fri, 24 Sep 2010 22:14:04 -0400

Hi gents,

We have a design question of Flow Label. During the v6 transition, some DSL
providers may want to create an IPv4-in-IPv6 tunnel from the BRAS to the
AFTR to continue to provider v4 access over a v6 core network. To identify a
CPE behind the BRAS, we propose to use the Flow Label. Each CPE will be
assigned with a Flow Label. This Flow Label represents a flow of all encap
v4-in-v6 traffic behind a CPE. The Flow Label will be applied on the v6
address of the BRAS. v6 hosts behind the CPE will have their v6 addresses
and be most probably from a different v6 prefix, so their flow labels won't
be affected.

You can find the details in:
http://tools.ietf.org/html/draft-zhou-softwire-ds-lite-p2p-02

Our question is: "Is this usage compatible to RFC 3697?" We posted this
question to Softwires and we were told to also ask 6man for input.

Thanks,
Yiu

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 24 Sep 2010 22:25:00 -0400

It is quite a stretch to claim that all traffic originating from (or in 
the other direction destined to) a single customer constitute a 
meaningful "flow".  However, because RFC 3697 was carefully written to 
be vague about this, it would be difficult to prove that it is incompatible.

I would note that this usage of flow label would be inconsistent with 
mutable flow labels, and would be inconsistent with the desire to use 
flow label as a meaningful subsitute for transport protocol and port 
numbers in ECMP and LAG logic.  Whether either of those two incompatible 
desires will themselves be standardized is extremely unclear at this 
point, although there seems to be significant resistance to having flow 
labels be mutable.

Yours,
Joel M. Halpern

On 9/24/2010 10:14 PM, Yiu L. Lee wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: "Yiu L. Lee" <[email-masked]>
Date: Fri, 24 Sep 2010 22:40:52 -0400

Hi Joel,

Sorry for my ignorance. Can you explain to me what is mutable flow label or
pint me to a reference I can read? You are right, this usage wasn't intended
to substitute for transport protocol and port numbers in ECMP and LAG. But I
guess FL could be used for other purposes other than ECMP and LAG as long as
it wasn't caused any conflict.

Thanks,
Yiu

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 26 Sep 2010 08:53:37 +1300

The flow label has always been defined as immutable, but for
examples that break the standard, see draft-hu-flow-label-cases.

For the rest I agree with Joel.

Regards
   Brian Carpenter

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Sun, 26 Sep 2010 16:54:14 -0500

My only point would be, I don't think that this proposed use of flow label stretches the definition of "flow" all that much, as I have been interpreting "flow" over the years. I've always thought of "flow" as IETF-speak for "circuit," as sacriligious as that might sound to some folk. So anything that a provider might once have done by specifying an ATM VPI/VCI over an ATM network, that same provider could do with the combination of IP addresses and flow label in an IPv6 core. At least, in principle.

A tunnel does not seem to be an unusual application of the concept?

In IPv4, this task required MPLS. With an IPv6 core network, the FL could be used instead, as others have alluded to recently in the 6man list.

Bert 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Brian E Carpenter
> Sent: Saturday, September 25, 2010 3:54 PM
> To: Yiu L. Lee
> Cc: [email-masked]; Frank Brockners (fbrockne)
> Subject: Re: Question for Flow Label
> 
> >>> Administrative Requests: 
> https://www.ietf.org/mailman/listinfo/ipv6
> >>>

---

From: Rémi Després <[email-masked]>
Date: Thu, 30 Sep 2010 09:01:14 +0200

Hi Yiu,
Response below, with an added direct copy to Brian.

> question to Softwires and we were told to also ask 6man for input.

With RFC 3697 as is, it doesn't seem to be compatible.
This is because the RFC specifies a very specific way to assign FLs to flows.

Now, in the revision under study, what you propose should IMHO be unambiguously permitted.
(For a load-balancing application between BRAS and AFTRs, your proposal is clearly a good choice.)

Regards,
RD

---

From: "Yiu L. Lee" <[email-masked]>
Date: Thu, 30 Sep 2010 09:13:46 -0400

Hi Remi,

Thanks for helping us to look into this.

Yiu

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 01 Oct 2010 13:00:16 +1300

> This is because the RFC specifies a very specific way to assign FLs to flows.

I don't see the problem. The RFC leaves the packet source entirely free
to define a flow in any way it likes, and doesn't specify much
about the value of the flow label.

    Brian