Subject: RE: I-D Action: draft-kitamura-ipv6-zoneid-free-01.txt

From: Hiroshi Kitamura <[email-masked]>
Date: Wed, 23 Oct 2013 02:30:38 +0000

Dear All,

We have submitted the following I-D.
  Title           : Free from Using Zone Identifier for IPv6 Link-Local Address
  Filename        : draft-kitamura-ipv6-zoneid-free-01.txt

This I-D describes "Zone-ID Free" functions that make end users free from using zone identifiers (Zone-ID) for IPv6 link-local addresses.
This idea have been implemented and verified under Linux OS.

We think this issue must be very interesting for 6man WG.

Please, let us know your comments or interest on this idea.

Best Regards,
Hiroshi

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Monday, October 21, 2013 1:43 PM
> To: [email-masked]
> Subject: I-D Action: draft-kitamura-ipv6-zoneid-free-01.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : Free from Using Zone Identifier for IPv6 Link-Local Address
> 	Author(s)       : Hiroshi Kitamura
>                           Shingo Ata
>                           Masayuki Murata
> 	Filename        : draft-kitamura-ipv6-zoneid-free-01.txt
> 	Pages           : 14
> 	Date            : 2013-10-20
> 
> Abstract:
>    This document describes "Zone-ID Free" functions that make end
>    users free from using zone identifiers (Zone-ID) for IPv6 link-
>    local addresses.
> 
>    When users deal with IPv6 link-local addresses, it is thought that
>    it is mandatory thing to specify accompanied Zone-IDs. For end
>    users, however, it is troublesome and nuisance thing to do it.
>    Because it is very hard for normal end users to find appropriate
>    Zone-IDs for this purpose.
> 
>    From another viewpoint, the usage of IPv6 link-local addresses
>    accompanied with Zone-IDs is quite different from the traditional
>    usage of global addresses. Therefore many problems related with
>    Zone-ID are caused and new specifications are required to fix these
>    problems.
> 
>    This document explores and describes how "Zone-ID Free" functions
>    work and how end users are released from using Zone-IDs when they
>    deal with IPv6 link-local addresses.
> 
>    The "Zone-ID Free" functions are upper compatible with the current
>    usages of dealing with IPv6 link-local addresses and harmless to
>    the existing communications.
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-kitamura-ipv6-zoneid-free
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-kitamura-ipv6-zoneid-free-01
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-kitamura-ipv6-zoneid-free-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available
> at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Lorenzo Colitti <[email-masked]>
Date: Wed, 23 Oct 2013 13:20:18 +0900

> Please, let us know your comments or interest on this idea.

The reason why scope IDs exist is that the same address might exist on more
than one interface. The document does not solve this problem.

Example: what if there is a fe80::1 on two different interfaces? Sending a
packet to fe80::1 will cause two NSes to be transmitted, and two ND cache
entries to be created. What happens then? Do data packets also sent to both
neighbours? If so, which one? And if not, why not?

It might help if the document had a clear use case. But there are no real
examples of where this is a problem. The draft does says that the scope ID
is hard to type, and that cannot be shared, and can change, but it doesn't
say why the network is using link-local addresses instead of global
addresses or ULA.

If the justification is "to make it simpler for end users to deal with
link-local addresses", then why not use names (e.g., via link-local
multicast DNS)? Exposing end users to IPv6 addresses does not seem like a
good solution.

---

From: Brian Jones <[email-masked]>
Date: Wed, 23 Oct 2013 09:15:48 -0400

On Wed, Oct 23, 2013 at 12:20 AM, Lorenzo Colitti <[email-masked]>wrote:

> On Wed, Oct 23, 2013 at 11:30 AM, Hiroshi Kitamura <[email-masked]
> > wrote:
>
> The reason why scope IDs exist is that the same address might exist on
> more than one interface. The document does not solve this problem.
>

​Names would definitely make addresses more recognizable at a glance and
therefore easier to use... We want to promote IPv6 adoption and IPv6
addresses can be scary looking to end users...
fwiw
​
 __​
​bej​

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>
>