Subject: Stephen Farrell's No Objection on draft-ietf-6man-ext-transmit-04: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Tue, 08 Oct 2013 03:31:11 -0700

Stephen Farrell has entered the following ballot position for
draft-ietf-6man-ext-transmit-04: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-6man-ext-transmit/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- 2.1 says nodes SHOULD forward rfc4727 experimental
headers, but earlier said that its ok (nodes MAY) default
to not forwarding packets with experimental headers. I
think you need to add an "unless otherwise stated here"
to the statement about defaults for experimental headers.

- section 4: Is it wise to ask IANA to "redirect" users
from one (empty) registry to another? That could be the
start of a slippery slope turning IANA registries into a
miasma of hypertext;-) Maybe it'd be better to ask that
IANA mark that registry as having being replaced by this
new one. Also - what if someone else asks IANA to add an
entry to the currently empty registry but not the new one
- is it clear what should happen in that case?

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 11 Oct 2013 17:24:55 +1300

On 08/10/2013 23:31, Stephen Farrell wrote:
...
> to the statement about defaults for experimental headers.

I must be missing something, but I can't find an inconsistency.

> - is it clear what should happen in that case?

It does need to be clear that the old registry is closed,
but we have to leave a pointer because it's referred to
elsewhere. I think IANA can figure it out, but we should
add "close to new entries".

I think we are already in a miasma of hypertext.

     Brian

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 11 Oct 2013 13:13:40 +0100

> I must be missing something, but I can't find an inconsistency.

Or maybe I misread it.

I read it as saying "nodes MAY default to not forwarding
packets with experimental headers" and as also saying
"nodes SHOULD forward 4727 experimental headers."

My suggestion is to say "nodes MAY default to not forwarding
packets with experimental headers except as noted below"
since otherwise developers might just see the MAY and
ignore the SHOULD.

That's not quite fixing an inconsistency but more just
flagging that there's a SHOULD later for 4727. But if you
prefer it as-is that's fine.

Cheers,
S