Subject: Re-use of fragment header in SEAL

From: Brian Haberman <[email-masked]>
Date: Sat, 19 Oct 2013 10:27:04 -0400

Fred,
     The way you have re-used the Next Header value of the Fragment
Header may be troublesome.  If someone updates 2460 to change the
Fragment Header (i.e., add additional info in the current Reserved
field), they will step on your use of the header and make them
indistinguishable.

Regards,
Brian

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 21 Oct 2013 15:07:36 +0000

Hi Brian,

> field), they will step on your use of the header and make them

That is true, but if the SEAL document were the one to update RFC2460
then there would be no concerns for future collisions. So, in the next
document version I will add "Updates RFC2460". Thanks for the comment.

Fred
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Mon, 21 Oct 2013 09:21:53 -0700

Fred,

> document version I will add "Updates RFC2460". Thanks for the comment.

I don't think it is appropriate for a draft that is updating an experimental RFC to update a standards track RFC.  It will cause a lot of confusion in the community.

Bob

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 21 Oct 2013 16:36:30 +0000

Hi Bob,

> -----Original Message-----
> From: Bob Hinden [mailto:[email-masked]]
> Sent: Monday, October 21, 2013 9:22 AM
> To: Templin, Fred L
> Cc: Bob Hinden; Brian Haberman; [email-masked]
> Subject: Re: Re-use of fragment header in SEAL
> 
> Fred,
> 
> > Fred,
> I don't think it is appropriate for a draft that is updating an
> experimental RFC to update a standards track RFC.  It will cause a lot
> of confusion in the community.

I think then that we would need to re-target SEAL as standards-track,
and as obsoleting the previous experimental RFC. I can make that
change in the next draft version so that it is clear that we are
not trying to make an experimental update a standards track.

Then, I guess the next question is whether we want to continue with
SEAL as an individual sub or bring it in as a 6man wg item? I am
open to either approach.

Thanks - Fred

---

From: Bob Hinden <[email-masked]>
Date: Mon, 21 Oct 2013 10:01:09 -0700

Fred,

> SEAL as an individual sub or bring it in as a 6man wg item? I am

I don't know what is appropriate, but there would have to be enough interest in taking on this work.  I have only seen one person talking about it.

But as I said, in it's current state it is not appropriate to update a standards track RFC.

Bob

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 21 Oct 2013 17:17:12 +0000

Hi Bob,

> Sent: Monday, October 21, 2013 10:01 AM
> To: Templin, Fred L
> I don't know what is appropriate, but there would have to be enough
> interest in taking on this work.  I have only seen one person talking
> about it.

Can I get an agenda slot to talk about it in Vancouver?
 
> But as I said, in it's current state it is not appropriate to update a

OK - I will fix it.

Thanks - Fred