Subject: some question in subneting

From: iyad almasry <[email-masked]>
Date: Wed, 14 May 2014 07:44:06 +0300

Hello

I am NIR and I have some question
1)For dualstack wich beter to use DHCP or private IP for every customer and
can I use DHCP for IPv4 with nating with privet IPv6 ?
2)For one customer that he/she have one subnet /64 how he will make some
subneting with some  rule or firewall between has computer if he get DHCP
IPv6 ?

 thank you
-- 

Iyad ALmasry
Deputy of data network manager
Ministery Of Telecom. & Information Technology
Public Telecom. Corporation
YemenNet
Phone: +967 1 331011
Mobile: +967 777112580
Fax: +967 1 331350

---

From: John Mann <[email-masked]>
Date: Fri, 16 May 2014 13:14:51 +1000

Hi,

> I am NIR and I have some question

You didn't say what type of network environment you are working in.
I will assume you are an ISP providing service over wired infrastructure.

> 1)For dualstack wich beter to use DHCP or private IP for every customer
> and can I use DHCP for IPv4 with nating with privet IPv6 ?
>

Inside each customer's network, I think it is better to use
- (customer-defined) Private IPv4 addresses, with NAT to the Internet
- Global Unicast IPv6 Addresses (public), assigned using DHCP-PD, with a
firewall controlling traffic from the Internet.

For the external interface of each customer's border router,
- IPv4 address could be assigned by ISP's DHCPv4 server
- IPv6 could be generated via SLAAC or from ISP's DHCPv6 server.

> subneting with some  rule or firewall between has computer if he get DHCP

It is much better to allocate an IPv6 /56 (or /48) to each customer, and
then let them do their own subnetting using /64s.
See: tools.ietf.org/html/rfc6177

IPv6 subnets are plentiful and not expensive.

===
For a generic ISP service, I would advise against using just Unique Local
Address (private) IPv6 and NPTv6 or NAT66 to get to the Internet.
I think this introduces extra difficulties, and no benefit over a stateful
firewall.

===
There are lots of resources available to aid in designing a Dual-stack IPv6
ISP service,
and papers presented at conferences explaining what people did and what
worked or not.

A quick Google search turns up these suggestions:

tools.ietf.org/html/rfc6036

tools.ietf.org/html/rfc4864
tools.ietf.org/html/rfc6092

en.wikipedia.org/wiki/IPv6_deployment

www.txv6tf.org/wp-content/uploads/2010/08/Asadullah-Tutorial-TXv6TF_SP_IPv6.pdf
www.ipspace.net/Roadmap/IPv6_webinars

Thanks,
    John