Subject: Re: Draft slides for the 6lo presentation

From: Ralph Droms <[email-masked]>
Date: Fri, 14 Nov 2014 06:48:27 -1000

On Nov 11, 2014, at 7:47 AM 11/11/14, Dave Thaler <[email-masked]> wrote:

> They're ok.  I will reiterate my opinion at the meeting, which was:
> 
>> My opinion is that link layers MUST define a mechanism that provides privacy.
>> A link layer MAY also define a mechanism that is more efficient and does not
>> provide privacy.   The choice of whether to enable privacy or not SHOULD be
>> configurable in such a case.

I agree with this opinion.

Does "MUST define" imply "MUST implement"?  I ask because many, if not most nodes in an 802.15.4 network, for example, will be built to some specification like ZigBee-IP, Wi-SUN FAN or Thread.  Those specifications will mandate the use of privacy or compressible mode.  Will nodes be required to implement the unused mode?

I'll leave it to others with more implementation experience than I have to chime in about whether the code/data resources required for privacy mode are worth worrying about.

- Ralph

> 
> I don't care either way about whether that's in the slides, but it's not what's
> in the doc right now.  However my opinion is that it's consistent with what the
> doc says even if it doesn't say it explicitly.
> 
> -Dave

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 14 Nov 2014 07:19:59 -1000

On 14 Nov 2014, at 06:48, Ralph Droms <[email-masked]> wrote:
> 
> Will nodes be required to implement the unused mode?

Does “must implement” mean “must implement” or “must include unused code in the tailored Flash image for the specific device”?  I always read it as “must implement”.

Grüße, Carsten

---

From: Kerry Lynn <[email-masked]>
Date: Fri, 14 Nov 2014 13:29:55 -0500

On Fri, Nov 14, 2014 at 11:48 AM, Ralph Droms <[email-masked]> wrote:

> Does "MUST define" imply "MUST implement"?  I ask because many, if not
> most nodes in an 802.15.4 network, for example, will be built to some
> specification like ZigBee-IP, Wi-SUN FAN or Thread.  Those specifications
> will mandate the use of privacy or compressible mode.  Will nodes be
> required to implement the unused mode?
>
> I'll leave it to others with more implementation experience than I have to
> chime in about whether the code/data resources required for privacy mode
> are worth worrying about.
>
> I have two problems with the opinion as currently drafted.  First, this
single MUST seems
to mandate code in every host to provide privacy whether it is ever used or
not.  This
effectively changes all the SHOULDs and RECOMMENDEDs in the proposal to
SHALLs.
Second, it is not quantitative, so I have no idea what code needs to be
implemented.

Kerry

- Ralph
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 14 Nov 2014 20:43:45 +0000

We had a long discussion on it just now in 6man. Dave clarifies that "linklayer" means 'ipv6-over-foo" and MUST means specification only but not mandatory for implementation.

However, concern is that 'ipv6-over-foo' and ipv6-over-constrained node networks(6lo) are not the same thing.
In many situation, having a MUST for specification will lead extra work/time specifying privacy for some constrained node networks but there will be no deployment requirement for privacy in those networks. 

Often these nodes are isolated from the Internet and often privacy is not a concern for these constrained nodes rather they want to have less code, less processing and easy debugging and easy header compression.

I would really argue that the default-iid document  has a section on 'constrained node networks and have a relaxed mandates for these cases.  For example, IPv6-over-3GPP or Ipv6-over-802.16/11 networks are quite different that ipv6-over-btle, or 802.15.4 etc.

Thanks,
-Samita

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: Friday, November 14, 2014 8:48 AM
To: Dave Thaler; Fernando Gont
Cc: [email-masked]; [email-masked]; Samita Chakrabarti; 6man WG
Subject: Re: Draft slides for the 6lo presentation

- Ralph

> 
> I don't care either way about whether that's in the slides, but it's 
> not what's in the doc right now.  However my opinion is that it's 
> consistent with what the doc says even if it doesn't say it explicitly.
> 
> -Dave

---

From: "Turner, Randy" <[email-masked]>
Date: Fri, 14 Nov 2014 21:45:01 +0000

+1

Sent from my iPhone

> On Nov 14, 2014, at 10:44 AM, Samita Chakrabarti <[email-masked]> wrote:
>

P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.