Subject: RE: Source Address Dependent Routing and Source Address Selection for IPv6

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 30 Jan 2015 10:10:12 +0000

Hello Brian:

The difference with the generic mobile IP scenario is that the host roams within the house. 
So we could inject host routes in the home, aggregated at the home gateway, as opposed to renumber or tunnel.
RPL does that all day, but currently there's a need for some host support (RPL leaf) to advertise the address. 
With new work at 6lo related to efficient ND, we are generalizing the registration to make the host agnostic of the routing protocol.

Cheers,

Pascal

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Brian E Carpenter
> Sent: jeudi 29 janvier 2015 23:47
> To: Ray Hunter; [email-masked]
> Cc: [email-masked]
> Subject: Re: Source Address Dependent Routing and Source Address Selection
> for IPv6
> 
> Hi Ray,
> 
> On 29/01/2015 20:10, Ray Hunter wrote:
> >
> >
> > Behcet Sarikaya wrote:
> >>   Hi all,
> >>
> >> On the solutions to the problem and issues discussed in this draft:
> >> http://tools.ietf.org/id/draft-sarikaya-6man-sadr-overview-04.txt
> >>
> >> we would like to hear from the working group. Referring to Section 5,
> >> which solution approach WG prefers? RA options as in Section 5.2?
> >> Section 5.3?
> >> Also regarding the corresponding DHCP work, which direction is the
> >> preferred direction?
> >>
> >> Your opinions are welcome.
> >>
> >> Regards,
> >>
> >> Behcet
> >>
> >>
> > I have read this draft. May I humbly suggest that I don't think you guys are on
> the right track at all with your problem statement.
> >
> > You seem to think the problem with Homenet is how a non-mobile host
> > discovers the correct SADR outbound route in the presence of a link
> > shared between multiple provider routers, and there being no "cross link"
> higher in the topology to sort out incorrectly routed packets.
> >
> > To me that's fighting an old battle (equivalent to IPv4 HSRP/VRRP +
> > next hop/object trackers to counter split-brain and faults higher in the
> topology).
> 
> It may be an old battle but I'm not sure it's over.
> 
> >
> > IMHO the real issue in Homenet routing is how to ensure that hosts
> > that roam between various L3 subnets (because they move around in the
> > Homenet and pick up various L3 WiFi interfaces) are correctly routed, also in
> the presence of multiple alternative wireless links.
> 
> If I roam to a different L3 network I get renumbered (unless I run Mobile IP in
> the house). When I get a new address, don't I have to fight the old battle one
> more time?
> 
>     Brian
> >
> > That requires solving the reverse route too, and anything like VRRP is going to
> be hopeless.
> >
> > IMVHO I think that hosts that want to be this flexible will be forced
> > to actively participate in Homenet routing protocols, and that these
> > hosts will have to be assigned their own /64 to a non-time-variant software-
> loopback interface that does not have to renumber as the end node moves
> between L3 LANs..
> >
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 30 Jan 2015 20:52:34 +0000

> From: ipv6 [mailto:[email-masked]] On Behalf Of Pascal Thubert
> (pthubert)

> With new work at 6lo related to efficient ND, we are generalizing the
> registration to make the host agnostic of the routing protocol.

While it's probably true that WiFi access points are usually sold as routers, the painfully simpler option here, if a homenet has more than one WiFi access point, is to configure each one as a proper layer 2 AP, no? And then connect them to the modem/router to the ISP?

Bert