Subject: Re: I-D Action: draft-sarikaya-6man-sadr-overview-03.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 07 Jan 2015 13:19:16 +1300

Hi,

One general comment is that I think the title of the draft
is a little misleading, because it doesn't emphasise the
host aspect. This is clumsy but might be clearer:

"Source Address Dependent Routing and Source Address Selection for IPv6 Hosts"

I think the discussion in Section 5 "What Needs to be Done"
is getting closer to what we need to say, but is not quite
there yet. I think it would be better formulated in two
parts:

#1. Scenarios solved by Rule 5.5 in [RFC6724], and what needs
to be done for that to work (mainly, as I understand it, that
hosts SHOULD register which next-hop router announced each
prefix).

#2. Scenarios *not* solved by that, and exactly what information
hosts need for correct SA selection in that case.

Also, I think it's probably not made clear enough that SADR
SHOULD be supported by routers throughout a site that has
multiple exits. I guess Fred's draft implies that, but doesn't
say it in so many words.

(I don't want to comment on details of draft-sarikaya-6man-next-hop-ra
or draft-sarikaya-dhc-dhcpv6-raoptions-sadr until point #2 above
is settled.)

Regards
   Brian

On 09/12/2014 06:12, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Overview of Source Address Dependent Routing
>         Author          : Behcet Sarikaya
> 	Filename        : draft-sarikaya-6man-sadr-overview-03.txt
> 	Pages           : 14
> 	Date            : 2014-12-08
> 
> Abstract:
>    This document presents an overview of source address dependent
>    routing from the host perspective.  Multihomed hosts and hosts with
>    multiple interfaces are considered.  Different architectures are
>    introduced and with their help, why source address selection and next
>    hop resolution in view of source address dependent routing is needed
>    is explained.  The document concludes with a discussion on the
>    standardization work that is needed.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-sarikaya-6man-sadr-overview/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-sarikaya-6man-sadr-overview-03
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-sarikaya-6man-sadr-overview-03
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 8 Jan 2015 14:16:27 -0600

Hi Brian,

> "Source Address Dependent Routing and Source Address Selection for IPv6 Hosts"

Done that.

> hosts SHOULD register which next-hop router announced each

Will do.

> hosts need for correct SA selection in that case.

Will do.
> multiple exits. I guess Fred's draft implies that, but doesn't

Will do.
> or draft-sarikaya-dhc-dhcpv6-raoptions-sadr

Please use this latest version:
http://tools.ietf.org/id/draft-sarikaya-dhc-6man-dhcpv6-sadr-00.txt

> until point #2 above

Regards,

Behcet
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------