Subject: RE: Default IIDs (Re: I-D Action: draft-ietf-6man-default-iids-02.txt)

From: Dave Thaler <[email-masked]>
Date: Fri, 6 Feb 2015 23:53:17 +0000

Mark ZZZ Smith wrote: 
> I think there is a bit of a mismatch between the ID's title and the contents. I think
> the title is a bit too general when the ID is only specific to the SLAAC methods of
> address generation and address configuration.
> 
> I'd much prefer to see the title left as it is and the advice extended to
> 
> - the use of RFC7217 like IIDs as a default policy for stateful DHCPv6 (i.e., draft-
> ietf-dhc-stable-privacy-addresses), unless overridden by the stateful DHCPv6
> operator (as a side note and to support advising on a default DHCPv6 address
> generation policy, the current version of OpenWRT comes with both SLAAC and
> stateful DHCPv6 addressing enabled by default (not sure why though).)

I agree with that proposal.

> - a bit of advice that manually/statically generated and configured interface IDs
> should also be chosen with these sorts of properties too

I think it's fine to suggest that administrators might do so, although I wouldn't use
any RFC 2119 language for that since it's completely up to the admin.

-Dave

---

From: Fernando Gont <[email-masked]>
Date: Sat, 07 Feb 2015 08:55:50 +0100

> any RFC 2119 language for that since it's completely up to the admin.

But.. wouldn't this about something else other than *default* IIDs?

Cheers,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Mark ZZZ Smith <[email-masked]>
Date: Sat, 7 Feb 2015 10:21:19 +0000 (UTC)

I'd see advice on static/manual addresses to be more as a side note, and a way to keep all the current advice on IIDs for SLAAC, DHCPv6 and static/manual all in one place/document.
      From: Fernando Gont <[email-masked]>
 To: Dave Thaler <[email-masked]>; Mark ZZZ Smith <[email-masked]>; "[email-masked]" <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; Ralph Droms <[email-masked]> 
 Sent: Saturday, 7 February 2015, 18:55
 Subject: Re: Default IIDs (Re: I-D Action: draft-ietf-6man-default-iids-02.txt)

Cheers,