Subject: Fragment ID generation in Windows (Re: draft-ietf-6man-predictable-fragment-id-04.txt)

From: Stephen Bensley <[email-masked]>
Date: Thu, 19 Mar 2015 17:56:27 +0000

Hello,

I work on the TCP/IP stack in Windows. In Windows 8, we implemented the algorithm described in section 4.3 of this draft. Appendix B should be updated accordingly.

Thanks,
Stephen Bensley
Microsoft

---

From: Fernando Gont <[email-masked]>
Date: Sun, 22 Mar 2015 14:55:05 +0100

Hi, Stephen,

Thanks so much for your feedback! Please find my comments inline...

On 03/19/2015 06:56 PM, Stephen Bensley wrote:
> 
> I work on the TCP/IP stack in Windows. In Windows 8, we implemented
> the algorithm described in section 4.3 of this draft. Appendix B
> should be updated accordingly.

Has this been implemented since the very first release of Windows 8? O
was this later implemented in some e.g. service pack?

Thanks!

Best regards,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Stephen Bensley <[email-masked]>
Date: Mon, 23 Mar 2015 14:29:48 +0000

It was implemented in the very first release of Windows 8.

-----Original Message-----
From: Fernando Gont [mailto:[email-masked]] 
Sent: Sunday, March 22, 2015 6:55 AM
To: Stephen Bensley; [email-masked]
Subject: Re: Fragment ID generation in Windows (Re: draft-ietf-6man-predictable-fragment-id-04.txt)

Hi, Stephen,

> should be updated accordingly.

Has this been implemented since the very first release of Windows 8? O was this later implemented in some e.g. service pack?

Thanks!

Best regards,

---

From: Fernando Gont <[email-masked]>
Date: Mon, 23 Mar 2015 09:51:56 -0500

> It was implemented in the very first release of Windows 8.

Apologies for that, then. I probably screwed up at the time when I was
writing down my notes for all the OSes I was testing. I will fix this in
the next rev.

Thanks!

Best regards,