Subject: Re: [v6ops] State of play

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 2 Feb 2016 03:49:34 +0000

When you say "v6man", I assume you mean "6man".

I'm a little lost. I don't see the words "chair" or "question" in the draft. Could you be more specific about what your question is?

> On Feb 1, 2016, at 3:11 PM, Mark Andrews <[email-masked]> wrote:
> 
> 
> draft-andrews-tcp-and-ipv6-use-minmtu-04 has an open question directed
> at the v6man and v6ops chairs - should this be a v6man or v6ops?  It
> needs to be fixed and I don't care in which forum it gets done but it
> needs to be done.
> 
> Mark
> 
> In message <[email-masked]>, [email-masked] writes:
>> RFC Editor: AUTH48
>> 	2015-11-23	draft-ietf-v6ops-reducing-ra-energy-consumption
>> 	2015-10-26	draft-ietf-v6ops-siit-dc
>> 	2015-10-26	draft-ietf-v6ops-siit-dc-2xlat
>> 	2015-10-26	draft-ietf-v6ops-siit-eam
>> 
>> RFC Editor: In ISE Review
>> 	2016-01-20	draft-ietf-v6ops-mobile-device-profile
>> 
>> IESG: AD Evaluation
>> 	2016-01-31	draft-bao-v6ops-rfc6145bis
>> 
>> IESG: In Last Call
>> 	2016-01-28	draft-ietf-v6ops-ipv6-ehs-in-real-world
>> 
>> WG: Unupdated WG Document
>> 	2015-10-19	draft-ietf-v6ops-design-choices
>> 
>> WG: Updated WG Document
>> 	2016-01-21	draft-ietf-v6ops-unique-ipv6-prefix-per-host
>> 	2016-01-03	draft-ietf-v6ops-host-addr-availability
>> 
>> Individual Submission: Unupdated
>> 	2015-10-19	draft-xu-v6ops-dslite-redundancy
>> 	2015-10-15	draft-gont-v6ops-ipv6-ehs-packet-drops
>> 	2015-09-21	draft-ybai-v6ops-ipv6-for-openstack
>> 
>> Individual Submission: Updated
>> 	2016-01-05	draft-templin-v6ops-pdhost
>> 	2016-01-03	draft-xcf-v6ops-chinatelecom-deployment
>> 	2016-01-03	draft-xli-v6ops-cernet-deployment
>> 
>> _______________________________________________
>> v6ops mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v6ops
> --
> Mark Andrews, ISC
> 1 Seymour St., Dundas Valley, NSW 2117, Australia
> PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Mark Andrews <[email-masked]>
Date: Tue, 02 Feb 2016 14:55:20 +1100

In message <[email-masked]>, "Fred Baker (fred)
> When you say "v6man", I assume you mean "6man".

yep.
 
> I'm a little lost. I don't see the words "chair" or "question" in the =
> draft. Could you be more specific about what your question is?

Which WG should take ownership of the problem space in this draft?

Mark

> >=20
> >=20
> >=20
> >=20
> > In message <[email-masked]>, =
> [email-masked] writes:
> >> RFC Editor: AUTH48
> >>=20
> >>=20
> >>=20
> >>=20
> >>=20
> >>=20
> >>=20
> >>=20
> --Apple-Mail=_99008B0B-2380-47D5-A518-D24FACDEAD89
> Content-Transfer-Encoding: 7bit
> Content-Disposition: attachment; filename="signature.asc"
> Content-Type: application/pgp-signature; name="signature.asc"
> Content-Description: Message signed with OpenPGP using GPGMail
> 
> -----BEGIN PGP SIGNATURE-----
> Comment: GPGTools - http://gpgtools.org
> 
> iQIVAwUBVrAnTkayAOS/EQ8MAQL9Ug//e/6aNfv+AC2Iv2qAp6MjcIYyRcqRZLew
> hhXABkYFTk+/FPHe57xZ4W7h4eEpJ7L8Fha+M+tEzB1ydNc/n/3NsThP6iZCsIYE
> lemKravU5zMVEvGLeWoaj9YUdKXzlqgIT6TjcE/0wuyUS6a5MotVMXqLKNkwbwg5
> IIX1lZNeSWmc7dtWUIeh9/UzgzlGap9Nd0+MhQVoWvPXgNv4Xvq9AhFSOZsz3r1L
> dtiOGn6cwypfrNleDt7D62jtWpmtyM/R7CjDBVhEhDVXyEiEt5/BfPnfB8e5+Ozt
> +PvIPw7rPe3Y6tg37kZLTySOiHiJ0UDPCwk7B3KQtYlnfKjFmQ0w8aad+I9Gw7x6
> FtUuMZZn5GDzkzR1dpBMr9J2KGjtwO7szDo8C/ZONEfwzTkXwepvxfZoW8eQuTIu
> E09eFvtUmmpE5w3K9sU/8ku8h+rtNf85GO5rozDwGBlflZAnRHpE61UZZqHAenBm
> HZIdLBxpZ56RQYzCN+ifrjR4ELTIfI0tUWVJSUWuW34hTpYfLFxWvi+BLLwnDbyC
> brKIPmBtpks6HKctM/D4YBDiLC0/ZvvsmlWnzCX1ZxdkzZNm0Ah0rSvSP7I/wICA
> x6tcJPMrUehuA13koaI++2SE7mI87wZb8DygbnxobCgwRwKJz2JgjATFPoV3Asyz
> whJD47Pn2t8=
> =0jdz
> -----END PGP SIGNATURE-----
> 
> --Apple-Mail=_99008B0B-2380-47D5-A518-D24FACDEAD89--

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 2 Feb 2016 04:10:52 +0000

I would guess it belongs in 6man, but I'll let the 6man chairs decide whether they agree.

> On Feb 1, 2016, at 7:55 PM, Mark Andrews <[email-masked]> wrote:
> 
>

---

From: [email-masked]
Date: Tue, 2 Feb 2016 09:36:02 +0100

Mark,

> Which WG should take ownership of the problem space in this draft?

is this an implementation bug, specification bug or both?

Best regards,
Ole

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Mark Andrews <[email-masked]>
Date: Tue, 02 Feb 2016 19:46:37 +1100

> is this an implementation bug, specification bug or both?

Possibly both as implementers failed to apply the simple logic of
if the mtu is limited then the tcp segment size also limited.  If
limit is applied prior to the MSS negotiation then that too is also
limited.

It's all a matter of how much hand holding should there be which
is a judgement call.

Mark

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 2 Feb 2016 15:33:38 +0000

> needs to be fixed and I don't care in which forum it gets done but it

OK, I have now actually read the draft, rather than looking through it for what you described as an open question to the chairs embedded in it.

I suspect you might actually be looking at intarea.

In any event, I disagree with the proposal in the draft, which is that TCP should look at whether "use min MTU" is set. Yes, if it is set, that should be observed; I'm not sure why an implementation would offer the flag without considering it. However, if I understand the question, the key point is that the Maximum Segment Size offered in the TCP MSS should be a size that can be sent on the interface in question using the IP variant selected, and any options or extension headers that need to be present, not whether a given flag is set in a not-actually-standard API. If folks are offering an MSS value that can't be supported, they have an implementation bug, regardless of whether they are checking for the flag.

Can you describe the implementation? Is this Apple, Microsoft, Linux, FreeBSD, Android, something else? Give us a test for reproducing the fault?