Subject: 2460bis reference detail

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 Sep 2016 08:30:03 +1200

Hi,

Following up on Tim's recent erratum, it seems that every citation of [IANA-PN]
in 2460bis needs to be accompanied by a reference to the extension header
registry created by RFC 7045:

http://www.iana.org/assignments/ipv6-parameters/ipv6-parameters.xhtml#extension-header

Regards
   Brian Carpenter

---

From: Bob Hinden <[email-masked]>
Date: Wed, 21 Sep 2016 10:27:10 +0300

Brian,

> On Sep 20, 2016, at 11:30 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 

Not sure I follow.  All of the references to IANA-PN are of the form:

      Next Header         8-bit selector.  Identifies the type of header
                          immediately following the Destination Options
                          header.  Uses the same values as the IPv4
                          Protocol field [IANA-PN].

All extension headers are included in IANA-PN.

Please explain.

Thanks,
Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 22 Sep 2016 08:29:54 +1200

> All extension headers are included in IANA-PN.

Correct. But they are not identfieed as such in IANA-PN. You already have a
reference for this as [IANA-EH]. I think the text would be more helpful as:

      Next Header         8-bit selector.  Identifies the type of header
                          immediately following the Destination Options
                          header [IANA-EH].  Uses the same values as the
                          IPv4 Protocol field [IANA-PN].

Rgds
   Brian

---

From: Bob Hinden <[email-masked]>
Date: Thu, 22 Sep 2016 10:49:16 +0300

Brian,

> On Sep 21, 2016, at 11:29 PM, Brian E Carpenter <[email-masked]> wrote:
> 

While I could do that, I think it will be more confusing.  I would think the common case for use use of the “Next Header” field will be to point to a transport protocol.  That is things that are in [IANA-PN], not things that are in [IANA-EH].  I am assuming that most packets will not contain extension headers.

I am also not sure what problem including IANA-EH in this text will fix.  Please explain.

Thanks,
Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 23 Sep 2016 08:58:52 +1200

> I am also not sure what problem including IANA-EH in this text will fix.  Please explain.

OK, I think I've now figured out what's bothering me. It's the words "Uses the same values
as the IPv4 Protocol field" that I've been staring at for 20 years. They are shorthand
for something much more complex. An IPv4 packet with Protocol = 59 would be a strange
beast, for example. An IPv6 packet with Next Header = 5 would also be... unusual.

I also noticed something else a bit strange. We don't explicitly say anywhere that
the upper layer payload (TCP or whatever) follows the final Next Header - which is the
main reason for using the Protocol numbering space for Extension Headers. (Well, we
say it implicitly for one case only: No Next Header!) That's indeed why we now have a
distinction between extension header numbers [IANA-EH] and protocol numbers [IANA-PN].

So, either I'm worrying about nothing, or we actually lack a clear explanation
of this quite early in the document (at the end of section 3?).

   Brian

---

From: Tim Chown <[email-masked]>
Date: Fri, 23 Sep 2016 08:44:00 +0000

Hi,

> On 22 Sep 2016, at 21:58, Brian E Carpenter <[email-masked]> wrote:
> 

I think that’s a fair point, but what change to text do you propose?

> of this quite early in the document (at the end of section 3?).

But at the start of Section 4 it says:

"In IPv6, optional internet-layer information is encoded in separate
   headers that may be placed between the IPv6 header and the upper-
   layer header in a packet.”

and the subsequent diagram on the same page shows the EHs between the main header and the payload?

Tim

> 
>   Brian
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 24 Sep 2016 09:37:41 +1200

> and the subsequent diagram on the same page shows the EHs between the main header and the payload?

Right, but we don't explain how that fits with "the same values as the IPv4 Protocol field."

Something like this, after the 2nd sentence in section 4, would shut me up:

IP Protocol Numbers [IANA-PN] are the same for IPv4 and IPv6. Extension Headers
are numbered in the same series as IP Protocol Numbers. When scanning a sequence
of Next Header values in a packet, the first one that is not an Extension Header
[IANA-EH] indicates that the next item in the packet is the corresponding upper
layer header. A special "No Next Header" value is used if there is no upper
layer header.

   Bria

---

From: Bob Hinden <[email-masked]>
Date: Sat, 24 Sep 2016 11:26:49 -1000

Brian,

> On Sep 23, 2016, at 11:37 AM, Brian E Carpenter <[email-masked]> wrote:
> 

I think something like that is reasonable.  I will work on some text.

Bob

---

From: Bob Hinden <[email-masked]>
Date: Sun, 25 Sep 2016 16:44:52 -1000

Brian,

> I think something like that is reasonable.  I will work on some text.

Here is my text:

  4.  IPv6 Extension Headers

  In IPv6, optional internet-layer information is encoded in separate
  headers that may be placed between the IPv6 header and the upper-
  layer header in a packet.  There are a small number of such extension
  headers, each identified by a distinct Next Header value.

  Extension Headers are numbered from IANA IP Protocol Numbers
  [IANA-PN], the same values are used for IPv4 and IPv6.  When
  processing a sequence of Next Header values in a packet, the first
  one that is not an Extension Header [IANA-EH] indicates that the next
  item in the packet is the corresponding upper-layer header.  A
  special "No Next Header" value is used if there is no upper-layer
  header.

Bob

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 26 Sep 2016 03:12:46 +0000

A couple of minor editorial obsessive changes:

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden

>   layer header in a packet.  There **is** a small number of such extension
>   headers, each **one** identified by a distinct Next Header value.
> 
>   [IANA-PN], the same values [strike "are"] used for IPv4 and IPv6.  When

Sounds clear to me.

Bert

---

From: Bob Hinden <[email-masked]>
Date: Sun, 25 Sep 2016 17:19:41 -1000

Bert,

> On Sep 25, 2016, at 5:12 PM, Manfredi, Albert E <[email-masked]> wrote:
> 

I agree.

Thanks,
Bob