Subject: Site-Local in rfc2460bis

From: Bob Hinden <[email-masked]>
Date: Wed, 21 Sep 2016 15:45:50 +0300

Hi,

Regarding Site-Local in RFC2460bis, there is one more place where it is also mentioned in addition to Section 2.4.7.  Earlier in Section 2.4 the document is says:

   There are several types of unicast addresses in IPv6, in particular,
   Global Unicast, site-local unicast (deprecated, see Section 2.5.7),
   and Link-Local unicast.  There are also some special-purpose subtypes
   of Global Unicast, such as IPv6 addresses with embedded IPv4
   addresses.  Additional address types or subtypes can be defined in
   the future.

I was thinking of changing it to:

   There are several types of unicast addresses in IPv6, in particular,
   Global Unicast, Local unicast, and Link-Local unicast.  There are also
   some special-purpose subtypes of Global Unicast, such as IPv6 addresses
   with embedded IPv4 addresses.  Additional address types or subtypes can
   be defined in the future.

Any comments?

Bob

---

From: Alejandro Acosta <[email-masked]>
Date: Wed, 21 Sep 2016 09:01:27 -0400

Hello,
  Agree & my comments inline

>    addresses.  Additional address types or subtypes can be defined in

What I don't like of this one is that it mentions explicitly site-local
and in the future we might have more deprecated addresses and there is
chance we will need to rephrase the sentence.

>    be defined in the future.

I do prefer this one. Looks clear & cleaner to me 

Alejandro,

>
> Any comments?
>
> Bob
>
>
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: David Farmer <[email-masked]>
Date: Wed, 21 Sep 2016 13:24:54 -0500

On Wed, Sep 21, 2016 at 7:45 AM, Bob Hinden <[email-masked]> wrote:

> Hi,
>
> Regarding Site-Local in RFC2460bis, there is one more place where it is
> also mentioned in addition to Section 2.4.7.  Earlier in Section 2.4 the
> document is says:
>

1. I think you mean regarding Site-Local in RFC4291bis, not RFC2460bis.  By
the way I couldn't find any Site-Local references in RFC2460bis, thank
goodness.  We should probably double check are the other pieces of the
overall project to move IPv6 to Internet Standard for stray references to
Site- Local.

2. I like your proposed change!

3. There is Site-Local multicast scope in 2.6.  I remember discussion about
that, a quick reminder where that ended up seems relevant to the thread and
would be helpful to me.

Thanks.

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Bob Hinden <[email-masked]>
Date: Wed, 21 Sep 2016 21:50:56 +0300

David,

> On Sep 21, 2016, at 9:24 PM, David Farmer <[email-masked]> wrote:
> 
> 
> 
> 1. I think you mean regarding Site-Local in RFC4291bis, not RFC2460bis.  By the way I couldn't find any Site-Local references in RFC2460bis, thank goodness.  We should probably double check are the other pieces of the overall project to move IPv6 to Internet Standard for stray references to Site- Local.

Sorry, should have said rfc4291.

> 2. I like your proposed change!

Good

> 
> 3. There is Site-Local multicast scope in 2.6.  I remember discussion about that, a quick reminder where that ended up seems relevant to the thread and would be helpful to me.

That is completely separate.  Site-local scoped multicast addresses are not deprecated.

Thanks,
Bob