Subject: I-D Action: draft-ietf-6man-segment-routing-header-12.txt

From: [email-masked]
Date: Fri, 20 Apr 2018 02:19:30 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Maintenance WG of the IETF.

        Title           : IPv6 Segment Routing Header (SRH)
        Authors         : Stefano Previdi
                          Clarence Filsfils
                          John Leddy
                          Satoru Matsushima
                          Daniel Voyer
	Filename        : draft-ietf-6man-segment-routing-header-12.txt
	Pages           : 28
	Date            : 2018-04-19

Abstract:
   Segment Routing (SR) allows a node to steer a packet through a
   controlled set of instructions, called segments, by prepending an SR
   header to the packet.  A segment can represent any instruction,
   topological or service-based.  SR allows a node to steer a flow
   through any path (topological, or application/service based) while
   maintaining per-flow state only at the ingress node to the SR domain.

   Segment Routing can be applied to the IPv6 data plane with the
   addition of a new type of Routing Extension Header.  This document
   describes the Segment Routing Extension Header Type and how it is
   used by SR capable nodes.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6man-segment-routing-header/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-12
https://datatracker.ietf.org/doc/html/draft-ietf-6man-segment-routing-header-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-6man-segment-routing-header-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Fri, 20 Apr 2018 13:36:12 +0000

Hello 6man working group, a new version of the SRH draft has been published with many of the open last call items resolved.
The issue tracker is being updated with notes for each of the resolved items.

I’ll send out summaries today to the list per submitter with: issues and resolution addressed by revision 12 or on the mailing list.

We’ll be actively working on addressing the remaining open items via email and/or with another revision.

Thanks for all the valuable review so far!
  Darren

> On Apr 20, 2018, at 5:19 AM, [email-masked] wrote:
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 21 Apr 2018 14:39:27 +1200

Hi,

The changes look good to me. I still think there is a bit too much
detail about the SID functions, but that's not a show-stopper IMHO.

I think the reference to RFC6438 should be normative, since there
are some MUSTs in the citations.

Regards
   Brian

On 20/04/2018 21:19, [email-masked] wrote:
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> .
>

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Mon, 23 Apr 2018 17:31:49 +0000

Thanks for reading Brian, and the non-show-stopper status on the end discussion.  I’ll make RFC6438 normative. 

Darren

> On Apr 20, 2018, at 10:39 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
>