Subject: Segment Routing Header Flags - removal of OAP flags

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 26 Apr 2018 19:05:23 +0000

In revision 12 of the SRH draft we removed the O,A and P flags as Adrian and Ron had indicated there was no detailed description of their usage.

Adding that description would get into lengthy definition of OAM and repair path handling that didn’t belong in the definition and processing of the SRH.  The authors felt they were better defined in documents that could fully justify and define their use.

A-flag can be introduced again if TLVs are defined requiring any segment to inspect them.
O-flag can be defined in an OAM draft with handling instructions and usecases - i.e., draft-ali-spring-srv6-oam
P-flag can be defined in a document that describes path protection and how to set and act on such a flag when a packet takes a protected path.

An IANA registry will be created for Flags.

Does anyone have a strong position against the removal of these flags from the document?

Darren

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 26 Apr 2018 20:43:07 +0100

Oh, that sounds reasonable.

You're basically saying that the features might be described in other documents, and those documents would also define the flags they need. That's a fine way to go forward.

I guess the forward compatibility works fine as the reserved (unused) bits must be set to zero on transmission.

The only risk is that someone implemented based on the bit positions defined in the previous revision and will be "disappointed" if different bits are assigned in the future. But I suppose that the absence of any actual description of the functions makes it pretty unlikely that anyone had actually implemented anything corresponding to those three bits.

Thanks,
Adrian

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Darren Dukes (ddukes)
> Sent: 26 April 2018 20:05
> To: IPv6 List
> Subject: Segment Routing Header Flags - removal of OAP flags
> 
> In revision 12 of the SRH draft we removed the O,A and P flags as Adrian and Ron
> had indicated there was no detailed description of their usage.
> 
> Adding that description would get into lengthy definition of OAM and repair path
> handling that didn’t belong in the definition and processing of the SRH.  The
> authors felt they were better defined in documents that could fully justify and
> define their use.
> 
> P-flag can be defined in a document that describes path protection and how to
> set and act on such a flag when a packet takes a protected path.
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 26 Apr 2018 22:22:15 +0000

Yes, you are correct re forward compatibility.  I’ll try to keep the locations the same with instructions to the experts during bit assignment from Flags.  And the docs can request the historical position.

Darren

> On Apr 26, 2018, at 3:43 PM, Adrian Farrel <[email-masked]> wrote:
>