Subject: Re: Adoption call for <draft-hinden-ipv4flag-03>

From: Ole Troan <[email-masked]>
Date: Tue, 15 May 2018 21:56:03 +0200

All,

This turned out to be a two month adoption call rather than a two week adoption call.
I think all the changes that went into revision 4 has resolved most of the objections to adopting the document.

This document is now adopted as a 6MAN working group document.

Can the authors please submit a new revision and at the same time rename the draft filename to reflect the new name of the flag.

draft-ietf-6man-ipv6only-flag-00.

Best regards,
Ole

> On 22 Mar 2018, at 17:47, Ole Troan <[email-masked]> wrote:
> 
> This message starts a two week 6MAN call on adopting:
> 
>     Title     : IPv6 Router Advertisement IPv4 Unavailable Flag
>     Authors   : R. Hinden, B. Carpenter
>     Filename  : draft-hinden-ipv4flag-03
>     Pages     : 9
>     Date      : 2018-03-02
> 
>     https://datatracker.ietf.org/doc/draft-hinden-ipv4flag/
> 
> as a working group item. Substantive comments and statements of support
> for adopting this document should be directed to the mailing
> list. Editorial suggestions can be sent to the authors.  This adoption
> call will end on April 5th, 2018.
> 
> See also the gap analysis from sunset4 on disabling IPv4:
> https://tools.ietf.org/html/draft-ietf-sunset4-gapanalysis-09#section-3
> 
> Regards,
> 
> Ole Trøan
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 16 May 2018 09:22:23 +0200

Hi,

It seems to me that the technology described in this draft could very
well be used in cellular access networks where the PDP type of a
point-to-point link is IPv6. (there are three distinct types of PDP
possible on cellular access links: IPv4, IPv6 and IPv4IPv6).

The PGW would add this option in the RA it sends to a User Equipment, if
that PDP type is IPv6. If that UE is a Windows machine, there would be
some factor reducing energy consumption, provided Windows implements the
option.

So that could be a user of the technology described in this draft.

Alex

Le 15/05/2018 à 21:56, Ole Troan a écrit :
[...]
> ----------------MESSAGE ORGINAL ci-dessous------------------
> 
> All,
>

---

From: "Bjoern A. Zeeb" <[email-masked]>
Date: Wed, 16 May 2018 13:53:00 +0000

> some factor reducing energy consumption, provided Windows implements 

Does it matter if it’s Windows, OSX, iOS, Android, Linux, *BSD, Minix, 
and whether it has 1 user or 10.000.000?
Can it improve the world?

If you base it on OS vendor adoption then let them write the code and 
then you don’t have to care here anymore.
If you want them to see write the code, then simply say yes.
If you want it to work well, find someone writing the code prototyping 
and showing it’s ok, and then make all say “yes” and do the same.

It’s your choice, not theirs!  Theirs can only be “RFC compliant” 
or not.

You (the reader of this message) are (or can be) an individual 
participating here.  You have a choice of saying yes, no, or staying 
silent.