Subject: Regarding draft-li-6man-service-aware-ipv6-network-00

From: Lizhenbin <[email-masked]>
Date: Mon, 18 Mar 2019 17:12:15 +0000

Hi Folks,
Currently applications are developed very fast which are carried over the network and have
varying needs for network bandwidth, latency, jitter, and packet loss, etc. However, since 
the current network is lack of enough information of service requirements of such applications 
it is difficult to guarantee the SLA or it may take long time to provide such guarantee.  In order
to solve these these challenges, the draft proposes the solution to take use of IPv6 extensions 
header to convey the service requirement information along with the packet to the network and
accordingly the flow-driven method is adopted to facilitate the service deployment and network 
resource adjustment to guarantee SLA for applications. It defines the Service-aware IPv6 ID to 
identify the possible service/application/user and Service-Para Option is defined to convey the 
related service parameters.

Comments and suggestions are welcome!

Best Regards,
Zhenbin (Robin)

________________________________________
发件人: [email-masked] [[email-masked]]
发送时间: 2019年3月12日 0:46
收件人: Pengshuping (Peng Shuping); Lizhenbin
主题: New Version Notification for draft-li-6man-service-aware-ipv6-network-00.txt

A new version of I-D, draft-li-6man-service-aware-ipv6-network-00.txt
has been successfully submitted by Zhenbin Li and posted to the
IETF repository.

Name:           draft-li-6man-service-aware-ipv6-network
Revision:       00
Title:          Service-aware IPv6 Network
Document date:  2019-03-11
Group:          Individual Submission
Pages:          12
URL:            https://www.ietf.org/internet-drafts/draft-li-6man-service-aware-ipv6-network-00.txt
Status:         https://datatracker.ietf.org/doc/draft-li-6man-service-aware-ipv6-network/
Htmlized:       https://tools.ietf.org/html/draft-li-6man-service-aware-ipv6-network-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-li-6man-service-aware-ipv6-network

Abstract:
   A multitude of applications are carried over the network, which have
   varying needs for network bandwidth, latency, jitter, and packet
   loss, etc.  Some applications such as online gaming and live video
   streaming have very demanding network requirements thereof require
   special treatments in the network.  However, since the current
   network is lack of enough information of service requirements of such
   applications it is difficult to guarantee the SLA or it may take long
   time to provide such guarantee.  This document proposes the solution
   to make use of IPv6 extensions header to convey the service
   requirement information along with the packet to the network to
   facilitate the service deployment and network resource adjustment to
   guarantee SLA for applications.  Then it defines the service-aware
   options which can be used in the different IPv6 extension headers for
   the purpose.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 31 Mar 2019 10:13:34 +1300

Hi Zhenbin,

Thanks for your draft. I have a few general questions:

1. As you may know, it's been impossible to deploy new IPv4 options for operational reasons, and also very difficult to deploy new IPv6 extension headers or options. So my first question about your proposal is: what is the intended scope? Do you expect such options to be deployed locally or over the open Internet? (For some background on this question, see https://tools.ietf.org/html/draft-carpenter-limited-domains)

2. How does this proposal relate to the existing standard for network service headers (https://tools.ietf.org/html/rfc8300)?

3. How does ths proposal relate to the existing standard for segment routing (https://tools.ietf.org/html/rfc8402) and the segment routing header (https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header)?

4. How does this proposal relate to FAST tickets (https://tools.ietf.org/html/draft-herbert-fast-03)?

Regards
   Brian Carpenter

On 19-Mar-19 06:12, Lizhenbin wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Tom Herbert <[email-masked]>
Date: Sat, 30 Mar 2019 14:47:14 -0700

> Thanks for your draft. I have a few general questions:

Hi Brian,

> 1. As you may know, it's been impossible to deploy new IPv4 options for operational reasons, and also very difficult to deploy new IPv6 extension headers or options. So my first question about your…

Please look at draft-herbert-ipv4-udpencap-eh-01, both the part about
IPv4 extension headers and EHoUDP. I floated IPv4 EH at a couple of
IETF meetings last week and got some positive feedback. Also, there
was quite a bit of discussion for new EH options (Path MTU option was
in Hack-athon, In situ IOAM seems like good use case for HBH).

> 4. How does this proposal relate to FAST tickets (https://tools.ietf.org/html/draft-herbert-fast-03)?

Good question. It looks like the information model is conceptually the
same, packets carry information in the network header that indicate
services to apply to the packet. Perhaps the biggest difference is
scope of the information and security aspects. FAST tickets are only
interpretable in the network they are issued, looks like Service-aware
IPv6 Network is intended to provide global visibility to parameters
(either way has trade offs in terms of scope, security, and richness
of content).

Tom