Subject: Comment on draft-bonica-6man-vpn-dest-opt-02

From: Tom Herbert <[email-masked]>
Date: Fri, 1 Mar 2019 16:25:26 -0800

Hello,

I'm not sure what "VPN Context Information" refers to or why this
wouldn't be part of the transport encapsulation meta data. (Also why
is this a DO instead of HBH option?). An example of VPN Context
Information use might be enlightening.

Tom

---

From: Ron Bonica <[email-masked]>
Date: Mon, 4 Mar 2019 23:19:23 +0000

Hi Tom,

For an example of VPN Context information, see Sections 1, 2, 3 and 5 of RFC 4364. Section 5 discusses forwarding and makes a distinction between a "tunnel label" and a "VPN route label". When an ingress Provider Edge (PE) router accept a packet from a VPN site, it pushes two labels. The first label is a "VPN route label" and the second is a "tunnel label".

The VPN route label is consumed by the egress PE router (i.e., the tunnel endpoint). It tells the egress PE router how to forward the packet into a VPN. By contrast, the tunnel label is consumed by routers along the path from the ingress PE to the egress PE. It tells those intermediate routers how to reach egress PE. The VPN Route Label is a bridge between the underlay and overlay networks, while the tunnel label belongs exclusively to the underlay.

VPN Context Information is a generic term that refers to tunnel labels and similar constructs from other VPN technologies. The one thing that they have in common is that they are consumed by the egress PE. Therefore, they are best represented in a Destination Option.

                                                                                                              Ron

> -----Original Message-----
> From: Tom Herbert <[email-masked]>
> Sent: Friday, March 1, 2019 7:25 PM
> To: 6man <[email-masked]>; Ron Bonica <[email-masked]>
> Subject: Comment on draft-bonica-6man-vpn-dest-opt-02
> 
> Hello,
> 
> I'm not sure what "VPN Context Information" refers to or why this wouldn't
> be part of the transport encapsulation meta data. (Also why is this a DO
> instead of HBH option?). An example of VPN Context Information use might be
> enlightening.
> 
> Tom