Subject: draft-ietf-6man-segment-routing-header-16

From: Rajesh M <[email-masked]>
Date: Wed, 13 Mar 2019 05:41:35 +0000

Please find observations on draft-ietf-6man-segment-routing-header-16

  1.  Section 8.1 Segment Routing Header Flags Register why we need this bit for HMAC ? we should remove this section from this draft

Suggested Description Reference
Bit
-----------------------------------------------------
4         HMAC         This document

  1.  Better to mention Last Entry field usage apart from validation (to determine the starting location of the TLVs)

Thanks
Rajesh

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Wed, 20 Mar 2019 18:04:17 +0000

Hi Rajesh, yes the bit reservation can be removed since we removed that flag.
Thanks for noticing that using Last Entry to identify the TLV start location is not stated explicitly. We can address that by adding a small update to section 2.1.

Darren

From: ipv6 <[email-masked]> on behalf of Rajesh M <mrajesh=[email-masked]>
Date: Wednesday, March 13, 2019 at 1:42 AM
To: "Clarence Filsfils (cfilsfil)" <[email-masked]>, "[email-masked]" <[email-masked]>, John Leddy <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: SPRING WG <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: draft-ietf-6man-segment-routing-header-16

Thanks
Rajesh