Subject: Re: Adoption call for <draft-pref64folks-6man-ra-pref64-02>

From: Ole Troan <[email-masked]>
Date: Wed, 13 Mar 2019 21:11:12 +0100

All,

The chairs have (finally) reviewed the adoption thread for this draft.
We have concluded that there is enough support to adopt this draft.

When the draft submission is opened, would the authors please submit this as draft-ietf-6man-ra-pref64-00.

There will be an agenda slot for this draft in Prague.

Best regards,
Ole and Bob, 6MAN co-chairs

> On 5 Dec 2018, at 21:16, Ole Troan <[email-masked]> wrote:
> 
> This message starts a two week 6MAN call on adopting:
> 
>   Title     : Discovering PREF64 in Router Advertisements
>   Authors   : L. Colitti, E. Kline, J. Linkova
>   Filename  : draft-pref64folks-6man-ra-pref64-02
>   Pages     : 8
>   Date      : 2018-10-01
> 
>   https://datatracker.ietf.org/doc/draft-pref64folks-6man-ra-pref64
> 
> 
> as a working group item. Substantive comments and statements of support
> for adopting this document should be directed to the mailing
> list. Editorial suggestions can be sent to the authors.  This adoption
> call will end on December 19, 2018.
> 
> Could those who are willing to work on this document,
> either as contributors, authors or reviewers please notify the list.
> That gives us an indication of the energy level in the working group
> to work on this.
> 
> Regards,
> Bob and Ole

---

From: Erik Kline <[email-masked]>
Date: Wed, 13 Mar 2019 15:04:18 -0700

Where did we land on
https://tools.ietf.org/html/draft-troan-6man-universal-ra-option ?

I quite liked that, and could be more expressive for the non-/96 NAT64 use
cases.

On Wed, 13 Mar 2019 at 13:11, Ole Troan <[email-masked]> wrote:

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Bob Hinden <[email-masked]>
Date: Wed, 13 Mar 2019 15:14:55 -0700

Erik,

> On Mar 13, 2019, at 3:04 PM, Erik Kline <[email-masked]> wrote:
> 
> Where did we land on https://tools.ietf.org/html/draft-troan-6man-universal-ra-option ?

We have not landed yet, but it will be on the agenda for Prague.

Bob

> 
> I quite liked that, and could be more expressive for the non-/96 NAT64 use cases.
>

---

From: Ole Troan <[email-masked]>
Date: Thu, 14 Mar 2019 15:42:08 +0100

Hi Erik,

> I quite liked that, and could be more expressive for the non-/96 NAT64 use cases.

Bob and I had a discussion if it would have made sense to discuss the universal-RA proposal before the other drafts suggesting flags or options in the RA.
Given that it’s so early in the process and an experiment etc, we didn’t.

If we were to decide to proceed with the universal-RA experiment there is nothing stopping us from just using that format in pref64 / ipv6 only.
And although the requirements for “process” would be greatly limited in the universal-RA/IANA update case, I don’t think anyone would mind if the IANA registration also came with an IETF document reference.

Best regards,
Ole

---

From: <[email-masked]>
Date: Thu, 14 Mar 2019 15:01:12 +0000

Hi chairs, 

I objet this decision. 

With all due respect, I don't see any evidence of enough support when reviewing the thread.

Can you please clarify based on which criteria you made the call? Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : ipv6 [mailto:[email-masked]] De la part de Ole Troan
> Envoyé : mercredi 13 mars 2019 21:11
> À : 6man WG
> Cc : 6man Chairs
> Objet : Re: Adoption call for <draft-pref64folks-6man-ra-pref64-02>
> 
> All,
>

---

From: Ole Troan <[email-masked]>
Date: Thu, 14 Mar 2019 20:59:37 +0100

Dear Med,

This is working group adoption of the document, it is not declaring a consensus to advance it on the standards track.   We are a long way from a decision to advance it.  Issues raised will have to be dealt with as a w.g. document.

The chairs reviewed the email discussion and it seemed to us to be sufficient interest for the w.g. to adopt the draft as a working group document.

Best regards,
Ole and Bob, 6MAN co-chairs.

> On 14 Mar 2019, at 16:01, [email-masked] wrote:
> 
> Hi chairs, 
> 
> I objet this decision. 
>

---

From: <[email-masked]>
Date: Mon, 18 Mar 2019 08:04:13 +0000

Hi Ole, 

Thank you for your reply. 

The issues cannot be solved by a WG adoption, so I don't understand the decision.

Given that opinions in favor of adoption and those against were balanced, I was expecting at most to revive the discussion in the future. 

Cheers,
Med

> De : Ole Troan [mailto:[email-masked]]
> Envoyé : jeudi 14 mars 2019 21:00
> À : BOUCADAIR Mohamed TGI/OLN
> Cc : 6man Chairs; 6man WG
> This is working group adoption of the document, it is not declaring a
> consensus to advance it on the standards track.   We are a long way from a
> decision to advance it.  Issues raised will have to be dealt with as a w.g.
> document.
> 
> The chairs reviewed the email discussion and it seemed to us to be sufficient
> interest for the w.g. to adopt the draft as a working group document.
> 
> Best regards,
> >> When the draft submission is opened, would the authors please submit this
> as
> >> draft-ietf-6man-ra-pref64-00.
> >>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 18 Mar 2019 13:02:59 -0500

On Mon, Mar 18, 2019 at 3:05 AM <[email-masked]> wrote:

> Given that opinions in favor of adoption and those against were balanced,
> I was expecting at most to revive the discussion in the future.
>
>

+1

Behcet