Subject: Issue #38 - Ron

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 28 Mar 2019 00:21:12 +0000

Hi Ron, as we discussed on Tuesday lets summarize what TLVs the END SID, as defined in 4.3.1, would process.

<OLD>
2.1.  SRH TLVs
   This section defines TLVs of the Segment Routing Header.

<NEW>
2.1.  SRH TLVs
   This section defines TLVs of the Segment Routing Header.

   A TLV provides meta-data for segment processing.  The only
   TLVs defined in this document are the HMAC (Section 2.1.2.1)
   and PAD (Section 2.1.1) TLVs.  While processing a SID as
   defined in section 4.3.1, all TLVs are ignored unless
   configured to be processed by local policy (Section 4.3.1.1.1).
   Thus, TLV and HMAC support is optional for any implementation.
  Other documents may define TLVs and processing rules for them.

Darren

---

From: Ron Bonica <[email-masked]>
Date: Thu, 28 Mar 2019 08:31:18 +0000

Darren,

This looks good. I have closed the ticket.

                                       Ron

Juniper Internal
From: Darren Dukes (ddukes) <[email-masked]>
Sent: Thursday, March 28, 2019 1:21 AM
To: Ron Bonica <[email-masked]>
Cc: '6MAN' <[email-masked]>
Subject: Issue #38 - Ron

<OLD>
2.1.  SRH TLVs

<NEW>
2.1.  SRH TLVs

Darren

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 28 Mar 2019 11:01:53 +0100

I am a little unclear about what "A TLV provides meta-data for segment 
processing".  As far as I can tell, SRH TLVs apply to all segments.  One 
could conceptually imagine them applying to only specific types of SIDs. 
  But even then, a given TLV would apply to all SIDs of that type.

The HMAC TLV is not really metadata for processing a SID, it is metadata 
for processing the SRH.  WHich helps a bit as it thus does not have a 
quesiton of which SID it applied to.

Presumably, TLVs which apply to SID processing will appear in other 
documents.  I am not sure what they would be.  I can imagine more 
detailed information than can be encoded in the current SIDs.  But that 
would need a way to relate the TLV to the specific applicable SID. 
Preferably in a consistent fashion.
Is that what is intended?

Yours,
Joel

On 3/28/19 1:21 AM, Darren Dukes (ddukes) wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: James N Guichard <[email-masked]>
Date: Thu, 28 Mar 2019 11:18:21 +0000

Hi Joel,

I think the important text is " all TLVs are ignored unless configured to be processed by local policy" .. in other words local policy defines whether upon receipt of a given SID, TLV processing should be initiated or not.. I take this to mean that for a given function if you want some traffic flows to use the TLVs as input into the function processing and other traffic to not, then you would define two separate SIDs, one with local TLV processing policy and one without.

Jim

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Thursday, March 28, 2019 6:02 AM
To: Darren Dukes (ddukes) <[email-masked]>
Cc: '6MAN' <[email-masked]>
Subject: Re: Issue #38 - Ron

I am a little unclear about what "A TLV provides meta-data for segment processing".  As far as I can tell, SRH TLVs apply to all segments.  One could conceptually imagine them applying to only specific types of SIDs. 
  But even then, a given TLV would apply to all SIDs of that type.

The HMAC TLV is not really metadata for processing a SID, it is metadata for processing the SRH.  WHich helps a bit as it thus does not have a quesiton of which SID it applied to.

Presumably, TLVs which apply to SID processing will appear in other documents.  I am not sure what they would be.  I can imagine more detailed information than can be encoded in the current SIDs.  But that would need a way to relate the TLV to the specific applicable SID. 
Preferably in a consistent fashion.
Is that what is intended?

Yours,
Joel

---

From: "Bernier, Daniel" <[email-masked]>
Date: Thu, 28 Mar 2019 11:21:45 +0000

+1 to Jim's interpretation

Daniel Bernier | Bell Canada
________________________________________
From: ipv6 <[email-masked]> on behalf of James N Guichard <[email-masked]>
Sent: Thursday, March 28, 2019 7:18 AM
To: Joel M. Halpern; Darren Dukes (ddukes)
Cc: '6MAN'
Subject: RE: Issue #38 - Ron

Hi Joel,

Jim

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Thursday, March 28, 2019 6:02 AM
To: Darren Dukes (ddukes) <[email-masked]>
Cc: '6MAN' <[email-masked]>
Subject: Re: Issue #38 - Ron

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 28 Mar 2019 12:21:53 +0100

Maybe it is just a failure of imagination.  I can not see what kind of a 
TLV would be relevant for SID processing and could be relevant for all 
SIDs or for all SIDs of a given type.
Thus, the local policy hook does not help since I do not even see how 
local policy could decide if a particular TLV was relevant.

Yours,
Joel