Subject: [Technical Errata Reported] RFC7421 (5699)

From: RFC Errata System <[email-masked]>
Date: Fri, 19 Apr 2019 03:20:36 -0700 (PDT)

The following errata report has been submitted for RFC7421,
"Analysis of the 64-bit Boundary in IPv6 Addressing".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5699

--------------------------------------
Type: Technical
Reported by: Alexandre PETRESCU <[email-masked]>

Section: GLOBAL

Original Text
-------------
Internet Engineering Task Force (IETF)                 B. Carpenter, Ed.
Request for Comments: 7421                             Univ. of Auckland
Category: Informational                                         T. Chown
ISSN: 2070-1721                                     Univ. of Southampton
                                                                 F. Gont
                                                  SI6 Networks / UTN-FRH
                                                                S. Jiang
                                            Huawei Technologies Co., Ltd
                                                             A. Petrescu
                                                               CEA, LIST
                                                          A. Yourtchenko
                                                                   Cisco
                                                            January 2015

Corrected Text
--------------
Internet Engineering Task Force (IETF)                 B. Carpenter, Ed.
Request for Comments: 7421                             Univ. of Auckland
Category: Informational                                         T. Chown
ISSN: 2070-1721                                     Univ. of Southampton
                                                                 F. Gont
                                                  SI6 Networks / UTN-FRH
                                                                S. Jiang
                                            Huawei Technologies Co., Ltd
                                                          A. Yourtchenko
                                                                   Cisco
                                                            January 2015

Notes
-----
For some reason I got in the group, then participated positively to the discussion, and I let myself tempted to have my name up on the first page of a published RFC; but finally, after much time and reflexion, I think I do not agree with the effects of this RFC.

I do not agree that 64bit is a boundary.

Remark: you are asking Type 'Technical' or 'Editorial'; only one choice is possible.  I do not understand that.  My issue is both.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7421 (draft-ietf-6man-why64-08)
--------------------------------------
Title               : Analysis of the 64-bit Boundary in IPv6 Addressing
Publication Date    : January 2015
Author(s)           : B. Carpenter, Ed., T. Chown, F. Gont, S. Jiang, A. Petrescu, A. Yourtchenko
Category            : INFORMATIONAL
Source              : IPv6 Maintenance
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 25 Apr 2019 09:19:52 -0500

I support this errata.

Not on a technical basis but
by reducing one author, this RFC now has 5 authors which is the maximum
allowed.

What is not to like about it?

Regards,
Behcet

On Fri, Apr 19, 2019 at 5:20 AM RFC Errata System <[email-masked]>
wrote:

> For some reason I got in the group, then participated positively to the
> discussion, and I let myself tempted to have my name up on the first page
> of a published RFC; but finally, after much time and reflexion, I think I
> do not agree with the effects of this RFC.
>
> Remark: you are asking Type 'Technical' or 'Editorial'; only one choice is
> possible.  I do not understand that.  My issue is both.
>
> Instructions:
> -------------
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Tim Chown <[email-masked]>
Date: Thu, 25 Apr 2019 14:28:52 +0000

Well, as a co-author I object to the erratum.

Alex has a very similar view on the 64-bit boundary when he agreed to be a published author on the RFC.

We're opening a huge can of worms if people can choose to remove themselves from RFCs they no longer are happy with.  Sure, if the person was added without their consent, do it, but not when they change their mind about the contents a few years later.  As with academic papers, you put your name to it, you basically should live with it.

I'd also say that this is purely an Informational RFC, not Standards track or BCP.  It does not recommend anything; it simply states how the 64-bit boundary (as much as it exists) has arisen, the advantages of that approach, but explains the issues that would arise if you used other prefix lengths.

There is nothing stopping Alex writing a new draft on why the boundary should be variable length.  IPv6 routing is after all based on variable length prefixes.

Tim

On 25 Apr 2019, at 15:19, Behcet Sarikaya <[email-masked]<mailto:[email-masked]>> wrote:

I support this errata.

Not on a technical basis but
by reducing one author, this RFC now has 5 authors which is the maximum allowed.

Regards,
Behcet

On Fri, Apr 19, 2019 at 5:20 AM RFC Errata System <[email-masked]<mailto:[email-masked]>> wrote:
The following errata report has been submitted for RFC7421,
"Analysis of the 64-bit Boundary in IPv6 Addressing".

--------------------------------------
Type: Technical
Reported by: Alexandre PETRESCU <[email-masked]<mailto:[email-masked]>>

Section: GLOBAL

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Brian Haberman <[email-masked]>
Date: Thu, 25 Apr 2019 10:36:56 -0400

> We're opening a huge can of worms if people can choose to remove themselves from RFCs they no longer are happy with.  Sure, if the person was added without their consent, do it, but not when they c…

There is no "basically" needed in Tim's last sentence. The IETF IPR
rules are quite clear on this. Alex contributed to the RFC as an author.
That historical context cannot be erased.

https://www.ietf.org/standards/ipr/

Regards,
Brian

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 25 Apr 2019 14:37:53 +0000

Hi Alex/Tim/Behcet,
  I do plan to reject this Erratum. RFCs are immutable once published. Period. I am at an IESG meeting in Toronto and I have discussed this in person with the RFC Series Editor as well and she concurs.

Thanks
Suresh

On Apr 25, 2019, at 10:28 AM, Tim Chown <[email-masked]<mailto:[email-masked]>> wrote:

Tim

I support this errata.

Regards,
Behcet

Section: GLOBAL

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 25 Apr 2019 16:42:25 +0200

While I fully agree that once you become an author, you need to live with it ... I wonder if laws or courts can use something in the line of "Right to be forgotten" in Internet, to "censor" some authors data.

Again, I don't agree, but this is not a so simple topic.

Regards,
Jordi

El 25/4/19 16:38, "ipv6 en nombre de Brian Haberman" <[email-masked] en nombre de [email-masked]> escribió:

    

    Regards,
    Brian

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Bob Hinden <[email-masked]>
Date: Thu, 25 Apr 2019 07:50:09 -0700

Suresh,

> On Apr 25, 2019, at 7:37 AM, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi Alex/Tim/Behcet,

I concur as well.  There is no error here.

Bob

> 
> Thanks
> Suresh
> 
>> On Apr 25, 2019, at 10:28 AM, Tim Chown <[email-masked]> wrote:
>> 
>>> On 25 Apr 2019, at 15:19, Behcet Sarikaya <[email-masked]> wrote:
>>> 
>>> I support this errata.
>>> 
>>> On Fri, Apr 19, 2019 at 5:20 AM RFC Errata System <[email-masked]> wrote:

---

From: Brian Haberman <[email-masked]>
Date: Thu, 25 Apr 2019 10:54:08 -0400

Hi Jordi,

> While I fully agree that once you become an author, you need to live with it ... I wonder if laws or courts can use something in the line of "Right to be forgotten" in Internet, to "censor" some au…

IANAL...

A summary of the Court of Justice of the EU says "that individuals have
a right to force internet search engines to remove links regarding their
personal information that is "inaccurate," "inadequate, irrelevant or
excessive in relation to the purposes of the processing" the data,
unless there is an overriding public interest in the search results
remaining publicly available."

I can't see how any of the reasons listed apply in this situation.

Regards,
Brian

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 25 Apr 2019 10:04:54 -0500

On Thu, Apr 25, 2019 at 9:50 AM Bob Hinden <[email-masked]> wrote:

> >   I do plan to reject this Erratum. RFCs are immutable once published.
> Period. I am at an IESG meeting in Toronto and I have discussed this in
> person with the RFC Series Editor as well and she concurs.
>

My point was:
 there is no technical error but the problem is with the number of authors
and one author voluntarily wishing to take his name out, why not do it?
Yes that RFC is fixed but IETF can publish a new one that supersedes.

I am just a hopefully honest broker on this issue, actually all the
coauthors are my friends.

Behcet

> >> We're opening a huge can of worms if people can choose to remove
> themselves from RFCs they no longer are happy with.  Sure, if the person
> was added without their consent, do it, but not when they change their mind
> about the contents a few years later.  As with academic papers, you put
> your name to it, you basically should live with it.
> >>
> >> I'd also say that this is purely an Informational RFC, not Standards
> track or BCP.  It does not recommend anything; it simply states how the
> 64-bit boundary (as much as it exists) has arisen, the advantages of that
> approach, but explains the issues that would arise if you used other prefix
> lengths.
> >>
> >> There is nothing stopping Alex writing a new draft on why the boundary
> should be variable length.  IPv6 routing is after all based on variable
> length prefixes.
> >>
> >> Tim
> >>
> >>>                                                                  F.
> Gont
> >>>                                                   SI6 Networks /
> UTN-FRH
> >>>                                                                 S.
> Jiang
> >>>                                                              A.
> Petrescu
> >>>                                                                CEA,
> LIST
> >>>                                                           A.
> Yourtchenko
> >>>                                                             January
> 2015
> >>>                                                                  F.
> Gont
> >>>                                                   SI6 Networks /
> UTN-FRH
> >>>                                                                 S.
> Jiang
> >>>                                                           A.
> Yourtchenko
> >>>                                                             January
> 2015
> >>> For some reason I got in the group, then participated positively to
> the discussion, and I let myself tempted to have my name up on the first
> page of a published RFC; but finally, after much time and reflexion, I
> think I do not agree with the effects of this RFC.
> >>>
> >>> Remark: you are asking Type 'Technical' or 'Editorial'; only one
> choice is possible.  I do not understand that.  My issue is both.
> >>>
> >>> Instructions:
> >>> -------------

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 25 Apr 2019 17:15:46 +0200

Hi Brian,

El 25/4/19 17:06, "ipv6 en nombre de Brian Haberman" <[email-masked] en nombre de [email-masked]> escribió:

    Hi Jordi,

    IANAL...

Law may become evil ... if the author say he doesn't longer agree in his previous statements then it may be interpreted as "inaccurate".

This may become a so silly situation that the RFC is still there, but is not searchable by Internet search machines.

As said, I don't agree that an author can be removed, but we have seen other outrageous "law" censorship enforcements.

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 25 Apr 2019 21:55:50 +0100

JORDI PALET MARTINEZ wrote on 25/04/2019 15:42:
> While I fully agree that once you become an author, you need to live
> with it ... I wonder if laws or courts can use something in the line
> of "Right to be forgotten" in Internet, to "censor" some authors
> data.

The GDPR allows the right of erasure in Article 17:

https://gdpr-info.eu/art-17-gdpr/

Arguably, section 3(d) would allow the IETF to decline to remove 
personal information from an RFC.  This is clarified in section 89.

It would be good if the IETF could publish its legal position on GDPR 
compliance.

> Again, I don't agree, but this is not a so simple topic.

I agree - this is not simple.  Debating it on 6man isn't going to get 
anyone anywhere.

Nick

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 26 Apr 2019 16:17:50 +1200

I'm only going to reply once on this thread, since the AD has already stated his position:

On 26-Apr-19 03:04, Behcet Sarikaya wrote:
> 
> 
> On Thu, Apr 25, 2019 at 9:50 AM Bob Hinden <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Suresh,
> 
>     > On Apr 25, 2019, at 7:37 AM, Suresh Krishnan <[email-masked] <mailto:[email-masked]>> wrote:
>     >
>     > Hi Alex/Tim/Behcet,
>  there is no technical error but the problem is with the number of authors and one author voluntarily wishing to take his name out, why not do it?

The number of authors is at the discretion of the RFC Editor, and can exceptionally exceed 5. In this case I, as the active editor of the draft, asked for an exception because all 6 authors had contributed substantial shares of the text. The AD concerned agreed to this at https://mailarchive.ietf.org/arch/msg/ipv6/qLbbvkVMjADG5k2cpHBFeYCJToY

> Yes that RFC is fixed but IETF can publish a new one that supersedes.

Indeed, with the same six authors or a new set of authors. Personally, I have better ways of spending my time.

Regards
     Brian

> 
> I am just a hopefully honest broker on this issue, actually all the coauthors are my friends.
> 
> Behcet 
> 
> 
>     Bob
> 
> 
>     >
>     > Thanks
>     > Suresh
>     >
>     >> On Apr 25, 2019, at 10:28 AM, Tim Chown <[email-masked] <mailto:[email-masked]>> wrote:
>     >>
>     >>> On 25 Apr 2019, at 15:19, Behcet Sarikaya <[email-masked] <mailto:[email-masked]>> wrote:
>     >>>
>     >>> I support this errata.
>     >>>
>     >>> On Fri, Apr 19, 2019 at 5:20 AM RFC Errata System <[email-masked] <mailto:[email-masked]>> wrote:
>     >>> "Analysis of the 64-bit Boundary in IPv6 Addressing"..
>     >>>
>     >>> Reported by: Alexandre PETRESCU <[email-masked] <mailto:[email-masked]>>
>     >>>
>     >>> Section: GLOBAL
>     >>>
>     >>> Original Text
>     >>> -------------
>     >>> [email-masked] <mailto:[email-masked]>
>     >>> [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Lorenzo Colitti <[email-masked]>
Date: Fri, 26 Apr 2019 21:15:19 +0900

> Yes that RFC is fixed but IETF can publish a new one that supersedes.

Alexandre was one of the authors, even if he now disagrees with the
document. The record should reflect that. We should not change the document.

---

From: James R Cutler <[email-masked]>
Date: Fri, 26 Apr 2019 08:54:30 -0400

Question: Was Alexandre an author of RFC7421

Answer: Yes

Conclusion: Listing Alexandre specifies provenance of the RFC and is not a technical error. Thus, no change is required.

Opinion: Modification of recorded historical facts based on opinion is not efficacious. Do not do it.

James R. Cutler
[email-masked]
GPG keys: hkps://hkps.pool.sks-keyservers.net

---

From: tom petch <[email-masked]>
Date: Sat, 27 Apr 2019 11:41:50 +0000

----- Original Message -----
From: "Nick Hilliard" <[email-masked]>
Sent: Thursday, April 25, 2019 9:55 PM

Nick

The IAD made such a statement on the Announce Mailing List on ... 25th
May 2018 - when else?

Tom Petch

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 27 Apr 2019 13:52:33 +0200

El 27/4/19 13:42, "tom petch" <[email-masked]> escribió:

    ----- Original Message -----
    From: "Nick Hilliard" <[email-masked]>
    Sent: Thursday, April 25, 2019 9:55 PM

    Nick

I recall that, however, a search in the IETF web page shows nothing.

Also, the Privacy Statement in our web page say *nothing* about GDPR, and I believe, being clear that we collect personal data (emails) from EU citizens/residents, something explicit should be there to comply with the GDPR and avoid a possible fine.
    
    Tom Petch

---

From: Nick Hilliard <[email-masked]>
Date: Sat, 27 Apr 2019 22:07:45 +0100

tom petch wrote on 27/04/2019 12:41:
> The IAD made such a statement on the Announce Mailing List on ...25th May 2018  - when else?
it didn't address the right of erasure, or indeed lots of other things 
in the gdpr, and I would question whether the privacy policy is gdpr 
compliant.  Anyway, this is not a 6man thing.

Nick