Subject: Looking for support for draft-petrescu-6man-ll-prefix-len-11

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 19 Apr 2019 11:50:17 +0200

Hi 6MANers,

I am looking for support for draft-petrescu-6man-ll-prefix-len-11.

Please reply to this thread only if you support the draft, thank you.

It tries to explain why the prefix length of link local addresses is 
variable, from 10 to 127.

Maybe you do not agree with the precise range, but maybe you agree with 
it being 'variable'.  Probably a single most compelling reason of it 
being 'variable', could be seen by just typing a parameter-less 
'ifconfig' on BSD and see fe80::1/128 and fe80::IID/64 mandatory 
presence on two interfaces.  There is '/64' and there is '/128'.

Other reasons are explained in the draft.

The draft can be downloaded at:
https://tools.ietf.org/html/draft-petrescu-6man-ll-prefix-len-11

(other text suggestions have been provided to me recently in private; 
these contain a redirection to an earlier discussion, and an additional 
explanation that makes a distinction between 'on-link' determination and 
other; I still have to insert these in the draft).

Alex

---

From: Gyan Mishra <[email-masked]>
Date: Sat, 20 Apr 2019 01:23:42 -0400

I support the draft.

My initial thoughts were not supporting given I mixed vendor interoperability issue with prefix length greater then 64.

The major caveat for routed connections where in our design we wanted to make the LL more intuitive then a EUI64 station id we hardcoded the link local so if we went CISCO to CISCO same vendor we could do any mask since it’s supported.  So just because some vendors don’t support changing the Link Local address and use default /64 length does not mean other vendors that do support lengths greater than 64 cannot do that.

Another use case I thought of for link local greater than 64 is for FHRP router redundancy protocols like vrrp we would have /128 IPv6 VIP.

Another one is BGP peering where you peer with link local and not global uni the link local is a /128.

I am in full support of the RFC.

Gyan S. Mishra
IT Network Engineering & Technology Consultant
Routing & Switching / Service Provider MPLS & IPv6 Expert
www.linkedin.com/in/GYAN-MISHRA-RS-SP-MPLS-IPV6-EXPERT
Mobile – 202-734-1000

Sent from my iPhone

> On Apr 19, 2019, at 5:50 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> Hi 6MANers,
> 
> It tries to explain why the prefix length of link local addresses is variable, from 10 to 127.
> 
> Maybe you do not agree with the precise range, but maybe you agree with it being 'variable'.  Probably a single most compelling reason of it being 'variable', could be seen by just typing a parameter-less 'ifconfig' on BSD and see fe80::1/128 and fe80::IID/64 mandatory presence on two interfaces.  There is '/64' and there is '/128'.
> 
> (other text suggestions have been provided to me recently in private; these contain a redirection to an earlier discussion, and an additional explanation that makes a distinction between 'on-link' determination and other; I still have to insert these in the draft).
> 
> Alex
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 24 Apr 2019 16:46:17 +0200

> I support the draft.

Noted that you support draft-petrescu-6man-ll-prefix-len-11

> My initial thoughts were not supporting given I mixed vendor 
> interoperability issue with prefix length greater then 64.
> 
> The major caveat for routed connections where in our design we wanted to 
> make the LL more intuitive then a EUI64 station id we hardcoded the link 
> local so if we went CISCO to CISCO same vendor we could do any mask 
> since it’s supported.  So just because some vendors don’t support 
> changing the Link Local address and use default /64 length does not mean 
> other vendors that do support lengths greater than 64 cannot do that.
> 
> Another use case I thought of for link local greater than 64 is for FHRP 
> router redundancy protocols like vrrp we would have /128 IPv6 VIP.
> 

Said like that, it means full support of RFC4291...(?)

There are Internet Drafts and there are RFCs, at one moment.

Alex

> <http://www.linkedin.com/in/GYAN-MISHRA-RS-SP-MPLS-IPV6-EXPERT>
> Mobile – 202-734-1000 <tel:202-734-1000>
> 
> 
> Sent from my iPhone
> 
>> On Apr 19, 2019, at 5:50 AM, Alexandre Petrescu 
>> <[email-masked] <mailto:[email-masked]>> 
>> wrote:
>>
>> Hi 6MANers,
>>
>> Maybe you do not agree with the precise range, but maybe you agree 
>> with it being 'variable'.  Probably a single most compelling reason of 
>> it being 'variable', could be seen by just typing a parameter-less 
>> these contain a redirection to an earlier discussion, and an 
>> additional explanation that makes a distinction between 'on-link' 
>> determination and other; I still have to insert these in the draft).
>>
>> Alex
>>
>> [email-masked] <mailto:[email-masked]>