Subject: Section 4.3.1.2. Upper-layer Header or No Next Header of <draft-ietf-6man-segment-routing-header-18>

From: Xiejingrong <[email-masked]>
Date: Mon, 15 Apr 2019 08:09:37 +0000

Hello authors,

Section 4.3.1.2. Upper-layer Header or No Next Header of <draft-ietf-6man-segment-routing-header-18> doesn't include the No Next Header case ?

The SRv6-Network-programming relies heavily on the No-next-header in SRv6-L2VPN cases.

Thanks
Jingrong

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 17 Apr 2019 21:53:53 -0400

I am in agreement with the RFC SR requirements for no next header.

Gyan S. Mishra
IT Network Engineering & Technology Consultant
Routing & Switching / Service Provider MPLS & IPv6 Expert
www.linkedin.com/in/GYAN-MISHRA-RS-SP-MPLS-IPV6-EXPERT
Mobile – 202-734-1000

Sent from my iPhone

> On Apr 15, 2019, at 4:09 AM, Xiejingrong <[email-masked]> wrote:
> 
> Hello authors,
>  
> Section 4.3.1.2. Upper-layer Header or No Next Header of <draft-ietf-6man-segment-routing-header-18> doesn’t include the No Next Header case ?
>  
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 18 Apr 2019 16:03:19 +0000

Hi Jingrong.

The processing of protocol type 59 “no next header” is intentionally defined to drop in section 4.3.1.2 of draft-ietf-6man-segment-routing-header-18.

4.3.1 says:
   This document, and section, defines a single SRv6 SID called END.
   Future documents may define additional SRv6 SIDs.  In which case, the
   entire content of this section will be defined in that document.

The SRv6 network programming draft does define other SIDs that would replace the text in 4.3.1 and its subsections.
This is accomplished for L2VPN with the END.DT2*/END.DX2* SID types.

Darren

On Apr 15, 2019, at 4:09 AM, Xiejingrong <[email-masked]<mailto:[email-masked]>> wrote:

Hello authors,

Thanks
Jingrong

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------