Subject: Fwd: New Version Notification for draft-petrescu-6man-ll-prefix-len-12.txt

From: Alexandre PETRESCU <[email-masked]>
Date: Wed, 24 Apr 2019 17:00:13 +0200

Hi, participants to 6MAN,

I have just submitted version -12 of this draft.

This is the ChangeLog:
- the '64' in GUA vs '64' in LL are issued by distinct sources: RA vs
   RFC4291 respectively;
- the address fe80::1/128 is present on the loopback interface of BSD;
- detailed, again, the distinction for 'on-link' determination;
- detailed, again, the distinction between 'assignment' and
  'allocation';
- added the fact that Cisco supports manual assignment of fe80:1::1.

Yours,

Alex

-------- Message transféré --------
Sujet : New Version Notification for 
draft-petrescu-6man-ll-prefix-len-12.txt
Date : Wed, 24 Apr 2019 07:57:40 -0700
De : [email-masked]
Pour : Naveen Kottapalli <[email-masked]>, Loganaden Velvindron 
<[email-masked]>, Alexandre Petrescu <[email-masked]>, 
Alexandre Petrescu <[email-masked]>

A new version of I-D, draft-petrescu-6man-ll-prefix-len-12.txt
has been successfully submitted by Alexandre Petrescu and posted to the
IETF repository.

Name:		draft-petrescu-6man-ll-prefix-len
Revision:	12
Title:		The length of the prefix of an IPv6 link-local address ranges 
from 10 to 127
Document date:	2019-04-24
Group:		Individual Submission
Pages:		9
URL: 
https://www.ietf.org/internet-drafts/draft-petrescu-6man-ll-prefix-len-12.txt
Status: 
https://datatracker.ietf.org/doc/draft-petrescu-6man-ll-prefix-len/
Htmlized: 
https://tools.ietf.org/html/draft-petrescu-6man-ll-prefix-len-12
Htmlized: 
https://datatracker.ietf.org/doc/html/draft-petrescu-6man-ll-prefix-len
Diff: 
https://www.ietf.org/rfcdiff?url2=draft-petrescu-6man-ll-prefix-len-12

Abstract:
    A rejected Errata to RFC4291 "IPv6 Addr Archi" on the topic of link-
    local addresses 'needs' a draft.  This is an answer to that need.

    The length of the prefix of an IPv6 link-local address is variable.
    The minimal value is 10 decimal.  The maximum value is 127 decimal.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 26 Apr 2019 16:54:54 -0400

Alexandre

In this section where you have the LL field broke. Down can you split the 54 bits into its own field called subnet id with remaining 64 bits as the interface id which is by default EUI64 formatted so is important to split.  Also depicts the change clearly that the 54 bit all 0s field is now can be changed to a 1.

| leftmost | Subnet ID and Interface ID | 10 bits | 118 bits | +----------+------------------------------------------------------+ |1111111010+ Bits that MAY be either 0 or 1 | +----------+------------------------------------------------------+ Figure 1: The IPv6 link-local address Examples: fe80::1/10, fe80:1::1/32 and fe80::1:1/64 are all IPv6 link-local addresses; their prefix lengths are 10, 32 and 64 respectively. Each such IPv6 address has the leftmost 10 bits equal to binary 1111111010.

The fe80:1::1 as written is  128 bit masked 

An example of 32 48 and 64 bit would be fe80:1::/32  fe80:1:1::/48. fe80:1:1:1::/64 

Gyan

Sent from my iPhone

> On Apr 24, 2019, at 11:00 AM, Alexandre PETRESCU <[email-masked]> wrote:
> 
> Sujet : New Version Notification for draft-petrescu-6man-ll-prefix-len-12.txt
> Pour : Naveen Kottapalli <[email-masked]>, Loganaden Velvindron <[email-masked]>, Alexandre Petrescu <[email-masked]>, Alexandre Petrescu <[email-masked]>
> 
> 
> Title:        The length of the prefix of an IPv6 link-local address ranges from 10 to 127
> URL: https://www.ietf.org/internet-drafts/draft-petrescu-6man-ll-prefix-len-12.txt
> Status: https://datatracker.ietf.org/doc/draft-petrescu-6man-ll-prefix-len/
> Htmlized: https://tools.ietf.org/html/draft-petrescu-6man-ll-prefix-len-12
> Htmlized: https://datatracker.ietf.org/doc/html/draft-petrescu-6man-ll-prefix-len
> Diff: https://www.ietf.org/rfcdiff?url2=draft-petrescu-6man-ll-prefix-len-12
> 
> Abstract:

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 26 Apr 2019 17:16:59 -0400

Alexandre 

With these changes I support the RFC.

Just thought of this below:

The use case that I had deployed which takes the global IPv6 address and embedded into the station id since RFC 4291 does not allow changing to 0 the 54 bit field we ended up having to drop the 1st 16 bits.  Would have been great if we did not have to but now with this RFC that use case would work and  we could directly map the entire global unicast prefix into the LL now 118 available bits.

Example 
2600:80c:100:1::1 

Mapping into the LL address to make the LL more intuitive as what your next hop is for routing protocols.

Fe80::2600:80c:100:1:1

Gyan

Sent from my iPhone

> On Apr 26, 2019, at 4:54 PM, Gyan Mishra <[email-masked]> wrote:
> 
> Alexandre
>