Subject: SRv6 Network Programming: More Headers

From: Ron Bonica <[email-masked]>
Date: Mon, 6 May 2019 01:02:14 +0000

Folks,

In draft-ietf-spring-srv6-network-programming, can a packet that is destined for an End.DX4 SID contain a Fragment header? An Authentication header? An Encapsulating Security Payload header? A Destination Options header?

My initial guess is that it cannot. According to the draft:

"The effective next-header (ENH) is the next-header field of the IP header when no SRH is present, or is the next-header field of the last SRH"

Also, according to Section 4.9 of the draft, the packet will be dropped if the Effective Next Header is not equal to 4 (IPv4).

Do I have this right?

                                                       Ron

Juniper Internal

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Tue, 7 May 2019 07:11:46 +0000

Hi Ron,

Your guess is wrong. Please read the sentence right after the one you quote.

   "The effective next-header (ENH) is the next-header field of the IP
   header when no SRH is present, or is the next-header field of the
   last SRH.

   In this version of the document, we assume that there are no other
   extension headers than the SRH.  These will be lifted in future
   versions of the document."

As said in the note, as part of the work on this draft we will update the pseudocodes to get better alignment with SRH draft, removing the stated limitations. For simplicity we did not add them in previous revisions of the draft.

Thanks,
Pablo.

-----Original Message-----
From: ipv6 <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Date: Monday, 6 May 2019 at 03:05
To: SPRING WG <[email-masked]>, 6man WG <[email-masked]>
Subject: SRv6 Network Programming: More Headers

    Folks,

    

    Do I have this right?
    
                                                           Ron
    
    Juniper Internal
    
    --------------------------------------------------------------------
    IETF IPv6 working group mailing list
    [email-masked]
    Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
    --------------------------------------------------------------------

---

From: Ron Bonica <[email-masked]>
Date: Tue, 7 May 2019 15:49:57 +0000

Fair enough.....

                         Ron

Juniper Internal

> From: Pablo Camarillo (pcamaril) <[email-masked]>
> Sent: Tuesday, May 7, 2019 3:12 AM
> To: Ron Bonica <[email-masked]>; SPRING WG <[email-masked]>; 6man
> WG <[email-masked]>
> Subject: Re: SRv6 Network Programming: More Headers
> 
> Hi Ron,
> 
> As said in the note, as part of the work on this draft we will update the
> pseudocodes to get better alignment with SRH draft, removing the stated
> limitations. For simplicity we did not add them in previous revisions of the
> draft.
> 
> Thanks,
> Pablo.
> 
>     In draft-ietf-spring-srv6-network-programming, can a packet that is
> destined for an End.DX4 SID contain a Fragment header? An Authentication
> header? An Encapsulating Security Payload header? A Destination Options
> header?
> 
>     "The effective next-header (ENH) is the next-header field of the IP header
> when no SRH is present, or is the next-header field of the last SRH"
> 
>     Also, according to Section 4.9 of the draft, the packet will be dropped if the
> Effective Next Header is not equal to 4 (IPv4).
> 
>     Do I have this right?
> 
>                                                            Ron
> 
>     Juniper Internal
> 
>     Administrative Requests:
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_ipv6&d=DwIGaQ&c=HAkYuh63rsuhr6S
> cbfh0UjBXeMK-ndb3voDTXcWzoCI&r=Fch9FQ82sir-BoLx84hKuKwl-
> AWF2EfpHcAwrDThKP8&m=9__zPeS8pIEeQn-
> yltzzkkSouJsgk608zqvUPZnwX8I&s=-
> LcJh19BMSp6Od7fj7FImTi9TWGdONgnHTiUUClrRaQ&e=