Subject: Re: Last Call: <draft-ietf-6lo-backbone-router-13.txt> (IPv6 Backbone Router) to Proposed Standard

From: Ted Lemon <[email-masked]>
Date: Thu, 23 Jan 2020 10:59:48 -0500

On Jan 23, 2020, at 7:59 AM, The IESG <[email-masked]> wrote:
> The IESG has received a request from the IPv6 over Networks of
> Resource-constrained Nodes WG (6lo) to consider the following document: -
> 'IPv6 Backbone Router'
>  <draft-ietf-6lo-backbone-router-13.txt> as Proposed Standard
> 
>   This document updates RFC 6775 and RFC 8505 in order to enable proxy
>   services for IPv6 Neighbor Discovery by Routing Registrars called
>   Backbone Routers.  Backbone Routers are placed along the wireless
>   edge of a Backbone, and federate multiple wireless links to form a
>   single MultiLink Subnet.

I’m not sure how much visibility this has had to IETF wgs that aren’t in the IoT space, but FYI, the key thing to know about this proposal is that it’s not actually a router.   It’s a weird sort of bridge, using proxy ND to make it appear as if all the devices on the IoT network are actually on the conventional (ethernet or WiFi) LAN.   I’m not taking a position on whether this is a good or a bad idea, but since it’s in last call, I wanted people who haven’t been involved thus far to just notice what’s being proposed and think about it (and possibly review the document).

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 23 Jan 2020 16:22:46 +0000

Great point Ted.

There are actually 2 modes:
- one for use in a L3 switch where the data packets are actually switched in which case the ND proxy uses the device's LLA in xLLAOs over the backbone. When used on Wi-Fi, this makes the backbone router a L3 AP, and corresponds to a demand from IEEE 802 to limit the use of L3 multicast that really end up broadcasted.
- the other is a real router where the ND proxy defends the device's address with it's MAC address on the backbone, and installs a more specific /128 route on the interface where the device is located. This breaks L2 continuity, and hides the MAC addresses of the devices from the core fabric, making it more stable.

Cheers,

Pascal

> -----Original Message-----
> From: ipv6 <[email-masked]> On Behalf Of Ted Lemon
> Sent: jeudi 23 janvier 2020 17:00
> To: [email-masked]
> Cc: 6MAN <[email-masked]>
> Subject: Re: Last Call: <draft-ietf-6lo-backbone-router-13.txt> (IPv6 Backbone
> Router) to Proposed Standard
> 
> I’m not sure how much visibility this has had to IETF wgs that aren’t in the IoT
> space, but FYI, the key thing to know about this proposal is that it’s not
> actually a router.   It’s a weird sort of bridge, using proxy ND to make it appear
> as if all the devices on the IoT network are actually on the conventional
> (ethernet or WiFi) LAN.   I’m not taking a position on whether this is a good or
> a bad idea, but since it’s in last call, I wanted people who haven’t been
> involved thus far to just notice what’s being proposed and think about it (and
> possibly review the document).
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------