Subject: Re: Extending a /64

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 16 Nov 2020 15:33:50 +0000

On the comment of "race to the bottom", AERO/OMNI (which have been matured
under the ICAO activities Tony and Saulo are referring to) takes the philosophy of
RFC6177 for assignment of IPv6 prefixes to aircraft as "sites". We would prefer /56
or shorter, but per Tony's message there is currently a leaning toward /60.

However, the AERO/OMNI mechanisms are capable of extending to prefix lengths
up to /112. That would give a 112-bit "network part" and a 16-bit "host part", which
seems like just enough individual addresses for even the smallest of networks.

So, why are we thinking of "race to the bottom" in terms of the /128 extreme?
What if we defined "the bottom" to be /112?

Fred

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 16 Nov 2020 16:02:37 +0000

The AERO/OMNI technologies are air-air capable, and not just air-ground. That is
one big reason why they are also being considered for ground transportation and
urban air mobility where "vehicle-to-vehicle" (V2) is important.

Fred

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Tony Whyman
> Sent: Monday, November 16, 2020 7:55 AM
> To: Da Silva, Saulo <[email-masked]>; [email-masked]
> Subject: [EXTERNAL] Re: Extending a /64
>
> I take your point - but these considerations are not (to my knowledge)
> in the scope of the work being undertaken by Working Group I. You are
> looking here a future concepts and these should be all limited to line
> of sight.
> 
> Currently, any air-to-air routing is out of scope. If you want to bring
> air-to-air routing in scope then we need to discuss.
> 
> Tony
> 
> On 16/11/2020 15:05, Da Silva, Saulo wrote:
> > Tony.
> > The evolution of the aviation system towards increasing capacity and acess of what we call new entrants (drones, high level
> operations, supersonic acft, etc) through strategic and tactical self separation do need air-to-air comm. The concept of management
> by trajectory instead of isolated clearances do need air-to-air. The aviation industry is working towards that direction.
> >
> > -----Original Message-----
> > From: ipv6 [mailto:[email-masked]] On Behalf Of Tony Whyman
> > Sent: 16-Nov-20 9:39 AM
> > To: [email-masked]
> > Subject: Re: Extending a /64
> >
> > This discussion seems to have gone off in the wrong direction. There are no ICAO applications that foresee aircraft to aircraft
> communication using datalink. The underlying set of applications is:
> >
> > 1. Controller to Pilot Datalink Communication (CPDLC) - the name says it all
> >
> > 2. Automatic Dependent Surveillance (ADS) - allows an ATS Provider to monitor an aircraft's position and intent.
> >
> > 3. Flight Information Services (FIS) - allows a pilot to pull information (e.g. on runway conditions).
> >
> > TCAS also exists as a collision avoidance system and this does use air-to-air communication. However, this is a rider on the Mode S
> surveillance radar and is not IP based.
> >
> > On 16/11/2020 14:30, Philip Homburg wrote:
> >> However, this seems to be a case of doing things at the wrong level.
> >> If aircaft use IPv6 to communicate then obvious they need unique IPv6
> >> addresses. However, each plane only needs to know its own address. Any
> >> time a plane communicates with an unknown plane, they can exchange higher level identities.
> > --------------------------------------------------------------------
> > IETF IPv6 working group mailing list
> > [email-masked]
> > Administrative Requests: https://secure-web.cisco.com/1Ttb6AZE6VAf8slZg6Up2Wbc-
> yRRw1bRFNxq3xFe0rvxo57JW3EORgd4Y26YVF1A3xJsGZYRey0b4EIYy8ftofcyCu7BKkGwioWSLWoCYbTzIMknfOy-
> InoUgJYGfaqD7b1PlyjfOs8ZkaaScuic6BjfH5hTsbJpBV2VmzoNDG6f7CoPZtjQqwXQ19FQu3evxWz0PTffaVTwtvvzpf9p9kkX8LX_mM4wx3
> g_jmYCK195bx7bKPQ0K0yoQzrihSnUSf7IQpTyfWp1zyNnknt4KbOeHobj8oxycxJAY6QC3ckVxhuUM85Vly6EtrO37uaUL/https%3A%2F%
> 2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fipv6
> > --------------------------------------------------------------------
> >
> >
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------