Subject: Variable SLAAC linux kernel implementation (SLAAC with prefixes of arbitrary length in PIO)

From: Dmytro Shytyi <[email-masked]>
Date: Tue, 10 Nov 2020 19:05:35 +0100

Dear participants of v6ops and 6man working groups,

I just released the open source implementation of Variable SLAAC (SLAAC with prefixes of arbitrary length in PIO) in the next github repository: https://github.com/dmytroshytyi/variable-slaac

Compatible linux kernels with patches in this repo:
net-next branch
   Linux ferby 5.10.0-rc2-00757-g8be33ecfc1ff-dirty #2 SMP PREEMPT Tue Nov 10 12:33:35 CET 2020 x86_64 GNU/Linux
net branch
   Linux kernel: Linux ferby 5.10.0-rc1-00133-gfffffda4fefb #1 SMP PREEMPT Mon Nov 2 21:42:42 CET 2020 x86_64 GNU/Linux
   Linux kernel: Linux ferby 5.9.0-rc3-00357-gcc8e58f8325c-dirty #1 SMP PREEMPT Thu Sep 10 10:50:34 CEST 2020 x86_64 GNU/Linux

Feel free to try it and leave your comments :)
__________________
Dmytro SHYTYI

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 10 Nov 2020 20:55:38 +0100

Dmytro,

We discussed in private about this, but I learned from your article that 
there are two methods to generate an Interface ID of an arbitrary 
length: the default random, and the RFC 7217 stable plus privacy extensions.

When you say 'stable' - in what is it stable?

For my part, I plan to use this implementation in my projects of 
vehicular networks connected to cellular links.

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 10 Nov 2020 20:57:44 +0100

A suggestion of correction on that howto article of the kernel patch: 
use 2001:db8 instead of 2000:db8 :-)

It's the documentation prefix specified in RFC.

Alex

Le 10/11/2020 à 20:55, Alexandre Petrescu a écrit :
>> I just released the open source implementation of Variable SLAAC 
>> (SLAAC with prefixes of arbitrary length in PIO) in the next github 
>> repository: https://github.com/dmytroshytyi/variable-slaac
>>
>>     Linux ferby 5.10.0-rc2-00757-g8be33ecfc1ff-dirty #2 SMP PREEMPT 
>> Tue Nov 10 12:33:35 CET 2020 x86_64 GNU/Linux
>> net branch
>>     Linux kernel: Linux ferby 5.10.0-rc1-00133-gfffffda4fefb #1 SMP 
>> PREEMPT Mon Nov 2 21:42:42 CET 2020 x86_64 GNU/Linux
>>     Linux kernel: Linux ferby 5.9.0-rc3-00357-gcc8e58f8325c-dirty #1 
>> SMP PREEMPT Thu Sep 10 10:50:34 CEST 2020 x86_64 GNU/Linux
>>

---

From: Mark Smith <[email-masked]>
Date: Wed, 11 Nov 2020 07:03:47 +1100

> It's the documentation prefix specified in RFC.

Why do you care about complying with specifications?

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Dmytro Shytyi <[email-masked]>
Date: Tue, 10 Nov 2020 21:30:00 +0100

Hello,

>use 2001:db8 instead of 2000:db8 :-)

Indeed.  I just changed that. Now it is 2001:db8.

 >  > length: the default random, and the RFC 7217 stable plus privacy 

There is a short website article that is shared around this subject: https://dmytro.shytyi.net/variable-slaac-ipv6-slaac-with-prefixes-of-arbitrary-length-in-pio/

______________
Dmytro SHYTYI

---- On Tue, 10 Nov 2020 21:03:47 +0100 Mark Smith <[email-masked]> wrote ----

 > 
 > 
 > On Wed, 11 Nov 2020, 06:58 Alexandre Petrescu, <[email-masked]> wrote:

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 10 Nov 2020 21:38:56 +0100

Le 10/11/2020 à 21:03, Mark Smith a écrit :
> 
> 
> On Wed, 11 Nov 2020, 06:58 Alexandre Petrescu, 
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
> 

Part of the reasons is a sort of laziness coupled to a need for things
that last.

Ideally, I would take standardized things cheaply open source
off-the-shelf, put them in cars, vi some files, and that's it.
Probably such ideal does not exist, but I like it.

But, what makes one think I wouldnt care complying with specifications?

Alex

>>>  (SLAAC with prefixes of arbitrary length in PIO) in the next 
>>> github repository: 
>>> https://github.com/dmytroshytyi/variable-slaac
> <https://github.com/dmytroshytyi/variable-slaac>
>>> 
>>> Compatible linux kernels with patches in this repo: net-next 
>>> branch Linux ferby 5.10.0-rc2-00757-g8be33ecfc1ff-dirty #2 SMP 
>>> PREEMPT Tue Nov 10 12:33:35 CET 2020 x86_64 GNU/Linux net branch
>>>  PREEMPT Mon Nov 2 21:42:42 CET 2020 x86_64 GNU/Linux Linux 
>>> kernel: Linux ferby
> 5.9.0-rc3-00357-gcc8e58f8325c-dirty #1
>>> Feel free to try it and leave your comments :) __________________
>>> Dmytro SHYTYI
>>> 
>>> 
>>> 
> 
>  IETF IPv6 working group mailing list [email-masked] 
> <mailto:[email-masked]> Administrative Requests: 
> https://www.ietf.org/mailman/listinfo/ipv6 
> <https://www.ietf.org/mailman/listinfo/ipv6>