Subject: Re: The bottom is /112 (was: RE: Extending a /64)

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 16 Nov 2020 17:03:09 +0000

> Well I tend to agree with the part that still these RFCs apply, but I
> dont see how the aviation world applies.
> 
> I still have to see a passenger airplane on IPv6, or offering IPv6 to
> passengers.

Alex, others in the aviation community may have more to say on this, but
we have been talking about the safety domain (front of the airplane) and
not the passenger domain (back of the airplane). The two domains are
physically separated to avoid any cross-talk.

Fred

> -----Original Message-----
> From: Alexandre Petrescu [mailto:[email-masked]]
> Sent: Monday, November 16, 2020 8:55 AM
> To: Templin (US), Fred L <[email-masked]>; [email-masked]
> Subject: Re: [EXTERNAL] Re: The bottom is /112 (was: RE: Extending a /64)
> 
> Le 16/11/2020 à 17:47, Templin (US), Fred L a écrit :
> > OK, so now that we have raced to the bottom we need to ask what we
> > are giving up?
> 
> The more we race to the bottom, the longer the search algorithm at the
> edges takes to forward a packet.  It's unfortunate for these low
> capability devices at the edges to have to scan so deep into a prefix,
> whereas their counterparts in the DFZ are more powerful and have shorter
> prefixes to look at.
> 
> But that's because how IP routing works.  And I will not propose to
> change it.
> 
> Were short prefixes at the edges and long prefixes in the core, then it
> would be different.
> 
> >> IMHO, there will still be use cases for RFC4941(bis) where we will
> >> still want to stop at /64. In those cases, RFC6177 still applies
> >> and our aviation world is one example.
> 
> Well I tend to agree with the part that still these RFCs apply, but I
> dont see how the aviation world applies.
> 
> I still have to see a passenger airplane on IPv6, or offering IPv6 to
> passengers.
> 
> Alex
> 
> >
> > Fred
> >
> >> -----Original Message----- From: ipv6
> >> [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
> >> Sent: Monday, November 16, 2020 8:38 AM To: [email-masked] Subject:
> >> Re: The bottom is /112 (was: RE: Extending a /64)
> >>
> >>
> >> Le 16/11/2020 à 17:30, Templin (US), Fred L a écrit :
> >>> New thread just to make sure this simple assertion is not lost.
> >>> I hereby declare "the bottom" to be /112. That gives a 112-bit
> >>> "network part" and a 16-bit "host part". That is as many
> >>> addresses as an old-fashioned IPv4 "class-B", and it also
> >>> parallels the number of transport port numbers available in a
> >>> 16-bit UDP/TCP port number space, so it is also good for
> >>> multi-addressing.
> >>>
> >>> I think /112 is good for now and for all time - with the
> >>> exception of /127 for P2P links, of course. Agreed?
> >>
> >> I do not oppose that.
> >>
> >> Alex
> >>
> >>>
> >>> Fred
> >>>
> >>>
> >>> --------------------------------------------------------------------
> >>>
> >>>
> >>>
> IETF IPv6 working group mailing list
> >>> [email-masked] Administrative Requests:
> >>> https://www.ietf.org/mailman/listinfo/ipv6
> >>> --------------------------------------------------------------------
> >>>
> >>
> >>
> >>>
> >>>
> --------------------------------------------------------------------
> >> IETF IPv6 working group mailing list [email-masked] Administrative
> >> Requests: https://www.ietf.org/mailman/listinfo/ipv6
> >> --------------------------------------------------------------------

---

From: "Da Silva, Saulo" <[email-masked]>
Date: Mon, 16 Nov 2020 17:32:37 +0000

And I second Fred's sentence.

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Templin (US), Fred L
Sent: 16-Nov-20 12:03 PM
To: Alexandre Petrescu <[email-masked]>; [email-masked]
Subject: Re: The bottom is /112 (was: RE: Extending a /64)

> I still have to see a passenger airplane on IPv6, or offering IPv6 to 

Alex, others in the aviation community may have more to say on this, but we have been talking about the safety domain (front of the airplane) and not the passenger domain (back of the airplane). The two domains are physically separated to avoid any cross-talk.

Fred

> whereas their counterparts in the DFZ are more powerful and have 
> shorter prefixes to look at.
> 
> Were short prefixes at the edges and long prefixes in the core, then 
> it would be different.
> 
> >>> "network part" and a 16-bit "host part". That is as many addresses 
> >>> as an old-fashioned IPv4 "class-B", and it also parallels the 
> >>> number of transport port numbers available in a 16-bit UDP/TCP 
> >>> port number space, so it is also good for multi-addressing.
> >>>
> >>> I think /112 is good for now and for all time - with the exception 
> >>> of /127 for P2P links, of course. Agreed?
> >>
> >> I do not oppose that.
> >>
> >> Alex
> >>
> >>>
> >>> Fred
> >>>
> >>>
> >>> https://secure-web.cisco.com/1BOsM8qr57ZSe1wnWdwV5wwlZ_gDwtAiH69EU
> >>> MJckAXMcFyjRWgZV3xPiHJaCuwyr3OKF1nUm3IK2XjHMPRkbaJCPyStFyLPxiK7l_7
> >>> WmnRL3mfNO7d0R9n8UMjGmSxH6bxEBQDRFCp6iBM5HzZRQ0a8HvitgKLHCW-CGJ3pb
> >>> cGausjtL95a6LwjTUjBatO9_arEirKgnTooHbST9WiK7itDhzeWYiuOCIS9mG915Qt
> >>> 50y6lr2-2e-iG5MNDGwjo-0qEdaBT_HLZ_m3lqZjeaMWjxNrCH_oGKSd-DwEk2zLp5
> >>> 7ql1CSLVB9WEQz5vSqb1/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistin
> >>> fo%2Fipv6
> >> Requests: 
> >> https://secure-web.cisco.com/1BOsM8qr57ZSe1wnWdwV5wwlZ_gDwtAiH69EUM
> >> JckAXMcFyjRWgZV3xPiHJaCuwyr3OKF1nUm3IK2XjHMPRkbaJCPyStFyLPxiK7l_7Wm
> >> nRL3mfNO7d0R9n8UMjGmSxH6bxEBQDRFCp6iBM5HzZRQ0a8HvitgKLHCW-CGJ3pbcGa
> >> usjtL95a6LwjTUjBatO9_arEirKgnTooHbST9WiK7itDhzeWYiuOCIS9mG915Qt50y6
> >> lr2-2e-iG5MNDGwjo-0qEdaBT_HLZ_m3lqZjeaMWjxNrCH_oGKSd-DwEk2zLp57ql1C
> >> SLVB9WEQz5vSqb1/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fi
> >> pv6

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://secure-web.cisco.com/1BOsM8qr57ZSe1wnWdwV5wwlZ_gDwtAiH69EUMJckAXMcFyjRWgZV3xPiHJaCuwyr3OKF1nUm3IK2XjHMPRkbaJCPyStFyLPxiK7l_7WmnRL3mfNO7d0R9n8UMjGmSxH6bxEBQDRFCp6iBM5HzZRQ0a8HvitgKLHCW-CGJ3pbcGausjtL95a6LwjTUjBatO9_arEirKgnTooHbST9WiK7itDhzeWYiuOCIS9mG915Qt50y6lr2-2e-iG5MNDGwjo-0qEdaBT_HLZ_m3lqZjeaMWjxNrCH_oGKSd-DwEk2zLp57ql1CSLVB9WEQz5vSqb1/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fipv6
--------------------------------------------------------------------