Subject: Expiration impending: <draft-thubert-6man-ipv6-over-wireless-06.txt>

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 22 Nov 2020 08:17:31 +0000

Dear all:

I do not have much to add to the individual submission. It is up to the WG to take it from there or let it die. What do you think ?

Keep safe!

Pascal

Début du message transféré :

De: IETF Secretariat <[email-masked]>
Date: 22 novembre 2020 à 09:01:00 UTC+1
À: [email-masked]
Objet: Expiration impending: <draft-thubert-6man-ipv6-over-wireless-06.txt>

The following draft will expire soon:

Name:     draft-thubert-6man-ipv6-over-wireless
Title:    IPv6 Neighbor Discovery on Wireless Networks
State:    I-D Exists
Expires:  2020-12-03 (in 1 week, 3 days)

---

From: Philip Homburg <[email-masked]>
Date: Sun, 22 Nov 2020 12:29:46 +0100

>    I do not have much to add to the individual submission. It is
>    up to the WG to take it from there or let it die. What do you
>    think ? Keep safe!  Pascal Dbut du message transfr :

In my opinion we should look at Ole's point-2-point link model before making
protocol changes.

---

From: Nabil Benamar <[email-masked]>
Date: Sun, 22 Nov 2020 12:34:58 +0100

Hi Pascal,

This is a good work and it should not be given up!
I support this draft and I want to add some stuff to it.

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Sun, Nov 22, 2020 at 9:18 AM Pascal Thubert (pthubert) <pthubert=
[email-masked]> wrote:

> Dear all:
>
> I do not have much to add to the individual submission. It is up to the WG
> to take it from there or let it die. What do you think ?
>
> Keep safe!
>
> Pascal
>
> *De:* IETF Secretariat <[email-masked]>
> *Date:* 22 novembre 2020 à 09:01:00 UTC+1
> *À:* [email-masked]
> *Objet:* *Expiration impending:
> <draft-thubert-6man-ipv6-over-wireless-06.txt>*
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Xipengxiao <[email-masked]>
Date: Sun, 22 Nov 2020 18:51:45 +0000

Hi Pascal, Chairs, All,

I also think that it’s a good piece of work, and shouldn’t be given up.

I would also like to take this opportunity to propose that the WG start a “problem statement of IPv6 first-hop protocols” draft.  The rationale is: many IPv6 first-hop protocols like ND, SLAAC were designed long time ago; many things have changed over the years, e.g. the advent of wireless, mobility, IoT, overlays;  lately there are multiple drafts trying to fix various issues in a number of IPv6 first-hop protocols, including:

·      Ole’s P2P & Universal IPv6 Configuration drafts,

·      Pascal’s ipv6-over-wireless,

·      Gyan’s Variable SLAAC draft,

·      Fred’s Unified Stateful/Stateless Configuration & OMNI drafts,

·      Eduard’s Prevent MITM draft

Some changes are incremental, some are bigger than that.  Therefore, it may be good to take a systematic look at the first-hop protocols, to identify the issues and discuss how to deal with them. This may help the WG decide whether to make certain changes, especially those bigger-than-incremental ones.

Thanks for your attention.

XiPeng

From: ipv6 [mailto:[email-masked]] On Behalf Of Nabil Benamar
Sent: Sunday, November 22, 2020 12:35 PM
To: Pascal Thubert (pthubert) <pthubert=[email-masked]>; 6man Chairs <[email-masked]>; [email-masked]
Subject: Re: Expiration impending: <draft-thubert-6man-ipv6-over-wireless-06.txt>

Hi Pascal,

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Sun, Nov 22, 2020 at 9:18 AM Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:[email-masked]>> wrote:
Dear all:

Pascal

Début du message transféré :
De: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
Date: 22 novembre 2020 à 09:01:00 UTC+1
À: [email-masked]<mailto:[email-masked]>
Objet: Expiration impending: <draft-thubert-6man-ipv6-over-wireless-06.txt>
The following draft will expire soon:

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 23 Nov 2020 08:57:38 +1300

Pascal,

Can you explain why this is proposed as a standards track document? As far as I can see it doesn't define any new protocol elements.

If it is, as I suspect, simply an explanation of how various other standards fit together to provide WiND, it might be equally useful as Informational, as well as much easier to get it published. Viewed that way, I think it is very useful work.

(There is also the standards track option of an Applicability Statement, which the IETF uses very rarely and most people don't know about.)

One comment you would surely get from reviewers is that the Security Considerations should at least contain a summary of issues, even if the details are in the references.

One nit is that if you want to promote the "WiND" acronym, it should be included in the document title.

Regards
   Brian Carpenter

On 22-Nov-20 21:17, Pascal Thubert (pthubert) wrote:
>> *Objet:* *Expiration impending: <draft-thubert-6man-ipv6-over-wireless-06.txt>*
>>

---

From: Michael Richardson <[email-masked]>
Date: Sun, 22 Nov 2020 19:24:14 -0500

> I would also like to take this opportunity to propose that the WG start
    > a “problem statement of IPv6 first-hop protocols” draft.  The rationale
    > is: many IPv6 first-hop protocols like ND, SLAAC were designed long
    > time ago; many things have changed over the years, e.g. the advent of
    > wireless, mobility, IoT, overlays;  lately there are multiple drafts
    > trying to fix various issues in a number of IPv6 first-hop protocols,
    > including:

So, the idea being to write down the issues, give the attacks names, and then
clarify what defenses we have already and how well they work?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Michael Richardson <[email-masked]>
Date: Sun, 22 Nov 2020 19:29:35 -0500

Brian E Carpenter <[email-masked]> wrote:
    > Can you explain why this is proposed as a standards track document? As
    > far as I can see it doesn't define any new protocol elements.

because it's a particular way of doing things, and there is a compliance
activity around implementing and testing it.

    > If it is, as I suspect, simply an explanation of how various other
    > standards fit together to provide WiND, it might be equally useful as
    > Informational, as well as much easier to get it published. Viewed that
    > way, I think it is very useful work.

Would you be okay for an RFP to go out citing an informational RFC?
True, the trade tribunals don't know the difference, but we do.

    > (There is also the standards track option of an Applicability
    > Statement, which the IETF uses very rarely and most people don't know
    > about.)

I'd be happy with using that.

    > One comment you would surely get from reviewers is that the Security
    > Considerations should at least contain a summary of issues, even if the
    > details are in the references.

    > included in the document title.

I'm skeptical that this TLA will survive :-)

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Nov 2020 05:16:24 +0000

That’s a oups, Brian.

It is intended at informational. I thought I created it that way and never looked again.

The document presents architecture concepts. This should be useful in the discussion on IPv6 over modern foos. 

The document does not define protocols. It is not not even a problem statement, like the document Xipeng suggested we write.

If I republish I’ll fix that point. I do appreciate your reading the draft and your support.

Keep safe !

Pascal

> Le 23 nov. 2020 à 01:29, Michael Richardson <[email-masked]> a écrit :
> 
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Nov 2020 05:20:39 +0000

Hello Phil 

Did you read the draft?

Pascal

> Le 22 nov. 2020 à 12:30, Philip Homburg <[email-masked]> a écrit :
> 
> 
>>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Nov 2020 05:24:22 +0000

Hello Nabil,

Thanks for your support!

The draft could be improved, eg adding a section on 3GPP that summarizes the /64 threads on this list. There could be text on LEO satellites and on OMNI. But what’s the point is the work is not published and then used?

Take care,

Pascal

Le 22 nov. 2020 à 12:35, Nabil Benamar <[email-masked]> a écrit :

Hi Pascal,

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

Keep safe!

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Nov 2020 05:29:37 +0000

Hello Xipeng

The problem statement is the next logical step, and I fully agree with you, willing to contribute.

The goal of the wireless draft is to present architecture fundamentals so there’s a common understanding of terms and constraints.

I believe that your problem statement proposal would be the first user if that specification.

Is that how you see it too?

Pascal

Le 22 nov. 2020 à 19:52, Xipengxiao <[email-masked]> a écrit :

Hi Pascal, Chairs, All,

XiPeng

Hi Pascal,

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Nov 2020 05:36:17 +0000

Hello Michael 

Sorry, replying to Brian took me to the end of the thread and my reply went to you.

Sometimes people including me try to publish an architecture as standard track. This was the case recently with DetNet and 6TiSCH. 

 I agree with your arguments I found that the IESG preferred informational for that type of work and then sign off on the down ref. Same goes for terminology documents.

Take care,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Nov 2020 05:55:22 +0000

Hello Brian 

I keep in mind your suggestion in WiND. 

This draft has text on WiND but it is not just about WiND; it is about architecture, eg how to apply L2 and L3 models on wireless.

25 years ago, I was working on the port of the Proteon code (by Jean Noel Chiappa for the most part) in IBM big boxes (3746-900). 

Their NBMA and P2MP supports on frame relay was a revelation, how applying the right model can simplify the configuration and operation of an IP network.

So nothing much new under the sun, and lots of recycling as usual...

Take care,

Pascal

> Le 22 nov. 2020 à 20:57, Brian E Carpenter <[email-masked]> a écrit :
> 
> Pascal,
>

---

From: Philip Homburg <[email-masked]>
Date: Mon, 23 Nov 2020 11:59:23 +0100

> Did you read the draft?

Yes, but quite a while ago.

In my opinion this working does not need to adopt a draft that changes ND
on wifi unless we find that p2p ethernet doesn't solve our problems.

>From the abstract, this draft only solves the problem of promoting WiND.
That is not a problem that needs solving.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 24 Nov 2020 08:41:52 +1300

> That is not a problem that needs solving.

I don't think that's fair. The IETF has an extremely bad habit of publishing
lots of inter-related RFCs but failing to publish applicability statements
(or ISDs, or whatever you want to call them) that explain how things fit
together. That *is* a problem that needs solving, case by case.

If you're objecting that 6lo has done work that shouldn't have been done,
that's another matter entirely.

    Brian

---

From: Philip Homburg <[email-masked]>
Date: Mon, 23 Nov 2020 21:05:21 +0100

>that's another matter entirely.

I don't have an opinion about what 6lo did. I do think that applying RFC 6775
to wifi is at the moment the wrong thing to do.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 24 Nov 2020 16:05:01 +0000

Hello Brian;

Many thanks again for you support. Since I sensed more support than opposition I republished.

The new version points on the RFC numbers for the full WiND suite, now that it is available.
To your point below, I changed the intended status to informational. See:
https://www.ietf.org/archive/id/draft-thubert-6man-ipv6-over-wireless-08.txt

keep safe!

Pascal

> -----Original Message-----
> From: Brian E Carpenter <[email-masked]>
> Sent: dimanche 22 novembre 2020 20:58
> To: Pascal Thubert (pthubert) <[email-masked]>; 6man WG
> <[email-masked]>
> Can you explain why this is proposed as a standards track document? As far as I
> can see it doesn't define any new protocol elements.
> 
> If it is, as I suspect, simply an explanation of how various other standards fit
> together to provide WiND, it might be equally useful as Informational, as well as
> much easier to get it published. Viewed that way, I think it is very useful work.
> 
> (There is also the standards track option of an Applicability Statement, which the
> IETF uses very rarely and most people don't know about.)
> 
> Considerations should at least contain a summary of issues, even if the details
> are in the references.
> 
> > I do not have much to add to the individual submission. It is up to the WG to
> take it from there or let it die. What do you think ?
> >
> > Keep safe!
> >
> > Pascal
> >

---

From: Nabil Benamar <[email-masked]>
Date: Fri, 27 Nov 2020 09:11:16 +0100

Dear all,

I would recommend the adoption of this draft by 6man. The document is
needed and debate around its content is healthy!

Best regards
Nabil Benamar
-------------------
نبيل بنعمرو

On Sun, Nov 22, 2020 at 12:34 PM Nabil Benamar <[email-masked]> wrote:

>> I do not have much to add to the individual submission. It is up to the
>> WG to take it from there or let it die. What do you think ?
>>
>> Keep safe!
>>
>> Pascal
>>