Subject: Re: [v6ops] How do you solve 3GPP issue if neither operator nor handset supports PD?

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 30 Nov 2020 16:08:37 +0000

Philip, your statements don't match with the reality of Duplicate Address Detection.
DAD is required if there is not going to be any differentiation between LLA generation
mechanisms. I want to be able to avoid DAD whenever possible - certainly in the
aviation domain this is very important. And, having the LLA Type field would aid in
capitalizing on cases when DAD can be avoided.

Fred

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Philip Homburg
> Sent: Monday, November 30, 2020 8:04 AM
> To: [email-masked]
> Cc: Templin (US), Fred L <[email-masked]>
> Subject: Re: [v6ops] How do you solve 3GPP issue if neither operator nor handset supports PD?
> 
> > Having the Type field
> > would allow an administrator to manually configure an
> > administratively-assigned LLA without risk of colliding with another
> > LLA that was configured via one of the multiple and growing numbers
> > of LLA autoconfiguration methods. This is true today, and will
> > become even more true as more and more LLA autoconfiguration methods
> > are standardized.
> 
> Obviously, a manually configured LLA doesn't conflict with EUI-64. We can
> assume that an administrator is smart enough to not set the middle two bytes
> of the IID to FFFE. So that doesn't happen.
> 
> The chance that a manually configured IID collides with a pseudo random is 1 in
> 2^64. Realistically that doesn't happen.
> 
> In practice we also see that nodes with manually configured IIDs have all other
> IID mechanisms disabled.
> 
> Any future IID mechanism that does not try to use IID bits for other purposes
> is pseudo random. So there no risk of collisions.

---

From: Philip Homburg <[email-masked]>
Date: Mon, 30 Nov 2020 18:08:53 +0100

> your statements
> don't match with the reality of Duplicate Address Detection.  DAD
> is required if there is not going to be any differentiation between
> LLA generation mechanisms. 

DAD is required, but DAD cannot detect things that aren't there.

If two hosts have different MAC addresses then their EUI-64 IIDs cannot collide.

By and large the implementation of the pseudo random IIDs generators is good
enough the collision don't occur.

Of course, there are plenty of lines that end up in loopback. But in that case
your flags scheme would not help either.

> I want to be able to avoid DAD whenever
> possible - certainly in the aviation domain this is very important.
> And, having the LLA Type field would aid in capitalizing on cases
> when DAD can be avoided.

You are trying to burden every IPv6 system with the specific needs you have
for aviation. That is a bad trade off.

Other link types still have to do DAD, so adding those flags doesn't help at all.

If you know that OMNI IIDs are unique, then just specify that on OMNI links only
OMNI IIDs are used and disable DAD.

I think 6lo does something similar for EUI-64.