Subject: FW: Next steps discussing Routing Challenges of Semantic Addressing

From: "Manfredi (US), Albert E" <[email-masked]>
Date: Thu, 6 May 2021 19:08:20 +0000

This is something that ought to be of interest to organizations which want to use their own semantics, in the IPv6 prefixes. There was some discussion on 6man some time ago, in which the assumption appeared to be, such a thing is already viable.

Bert 

-----Original Message-----
From: routing-discussion <[email-masked]> On Behalf Of Adrian Farrel
Sent: Thursday, May 06, 2021 05:49
To: [email-masked]; [email-masked]
Subject: [EXTERNAL] Next steps discussing Routing Challenges of Semantic Addressing

EXT email: be mindful of links/attachments.

Dear all,

Back in March we posted an initial draft to open the discussion of research
related to routing based on additional meaning assigned to IP addresses, and
to routing based on fields other than the destination address field of an IP
packet. That draft attracted some comments, and one thing was clear: we
needed to split the draft into a survey of work that has happened / is
happening, and a discussion of the challenges to routing together with the
research question.

So we have done this now (sorry it took so long) and have posted:
https://datatracker.ietf.org/doc/draft-king-irtf-semantic-routing-survey/ 
https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/ 

These new drafts do not pick up all of the comments received (we focused on
the split), but we hope to address the comments in new revisions soon.

At the same time, we have set up a dedicated mailing list for discussion of
"Semantic Addressing Routing and Hardware" (SARAH) at [email-masked].
This is an academic, research-based community where we can discuss all
aspects of the drafts, introduce our research to each other, and advertise
related conference activity. You can subscribe at
https://www.jiscmail.ac.uk/cgi-bin/webadmin?A0=SARAH.

We hope the new list will help to focus discussion and avoid spamming
existing mailing lists.

Looking forward to hearing your opinions.

Adrian and Dan

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/routing-discussion

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 6 May 2021 22:04:54 +0200

All,

May I ask why this topic is being taken outside of IETF ?

Is it so difficult to create a new list ? Or is this so off topic to say
ipv6 or 6man lists that it can not be discussed there ?

Thx,
Robert

On Thu, May 6, 2021 at 9:09 PM Manfredi (US), Albert E <
[email-masked]> wrote:

> This is something that ought to be of interest to organizations which want
> to use their own semantics, in the IPv6 prefixes. There was some discussion
> on 6man some time ago, in which the assumption appeared to be, such a thing
> is already viable.
>
> Bert
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 6 May 2021 22:04:54 +0200

All,

Thx,
Robert

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 6 May 2021 22:21:53 +0200

> May I ask why this topic is being taken outside of IETF ?

Maybe because https://www.jiscmail.ac.uk/cgi-bin/webadmin?A0=SARAH is
not on IPv6?

> Is it so difficult to create a new list ?

I think it is very easy for IETF Secretariat to create email lists, but
it is very difficult for me to create a new local filter for each new
mailing list, and since some time now.  To address that problem, there
is a need of a new communications protocol feature to be used by the
IETF Secretariat in a trustful manner, such that it automatically
creates an email filter in my email reader and a new folder, upon the
creation of a new email list.

Creating a list first outside the IETF, and then potentially moving it
to IETF or IRTF, poses a significant challenge in automatically updating
these filters.  Because there would be no single entity (like the IETF
Secretariat) that could trigger this.  The Secretariat would have to
have a close relationship with that organisation outside of IETF.

> Or is this so off topic to say ipv6 or 6man lists that it can not be
>  discussed there ?

I think it does make sense to discuss it at IETF.

I doubt though that routing on more bits than a dst address can be
qualified as semantics.  Semantics would be if the packets could smell
something and routing would happen on that smell.  Or be coloured
something, or have a spin, or similar.

Addressing something with something else than an address also poses a
challenge.  On another hand, the semantics of an address could be
augmented with port numbers, and then routing could be done based on
address+portnumbers, maybe traffic engineering.

Just some simple thoughts...  I have to read the description first.

Alex

> 
> Thx, Robert
> 
> 
> On Thu, May 6, 2021 at 9:09 PM Manfredi (US), Albert E 
> <[email-masked] <mailto:[email-masked]>>
>  wrote:
> 
> This is something that ought to be of interest to organizations which
> want to use their own semantics, in the IPv6 prefixes. There was some
> discussion on 6man some time ago, in which the assumption appeared to
> be, such a thing is already viable.
> 
> Bert
> 
> -----Original Message----- From: routing-discussion 
> <[email-masked] 
> <mailto:[email-masked]>> On Behalf Of Adrian 
> Farrel Sent: Thursday, May 06, 2021 05:49 To: [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]> Subject: [EXTERNAL] Next steps 
> discussing Routing Challenges of Semantic Addressing
> 
> Back in March we posted an initial draft to open the discussion of 
> research related to routing based on additional meaning assigned to 
> IP addresses, and to routing based on fields other than the 
> destination address field of an IP packet. That draft attracted some
>  comments, and one thing was clear: we needed to split the draft into
>  a survey of work that has happened / is happening, and a discussion
>  of the challenges to routing together with the research question.
> 
<https://datatracker.ietf.org/doc/draft-king-irtf-semantic-routing-survey/>
> https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/
<https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/>
> 
> 
> These new drafts do not pick up all of the comments received (we 
> focused on the split), but we hope to address the comments in new 
> revisions soon.
> 
> At the same time, we have set up a dedicated mailing list for 
> discussion of "Semantic Addressing Routing and Hardware" (SARAH) at 
> [email-masked] <mailto:[email-masked]>. This is an 
> academic, research-based community where we can discuss all aspects 
> of the drafts, introduce our research to each other, and advertise 
> https://www.jiscmail.ac.uk/cgi-bin/webadmin?A0=SARAH 
> <https://www.jiscmail.ac.uk/cgi-bin/webadmin?A0=SARAH>.
> 
> We hope the new list will help to focus discussion and avoid
> spamming existing mailing lists.
> 
> _______________________________________________ routing-discussion 
> mailing list [email-masked] 
> <mailto:[email-masked]> 
> <https://www.ietf.org/mailman/listinfo/routing-discussion>
> 
> IETF IPv6 working group mailing list [email-masked] 
> <mailto:[email-masked]> Administrative Requests: 
> https://www.ietf.org/mailman/listinfo/ipv6 
> <https://www.ietf.org/mailman/listinfo/ipv6> 
> IETF IPv6 working group mailing list [email-masked] Administrative 
> Requests: https://www.ietf.org/mailman/listinfo/ipv6

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 6 May 2021 21:34:30 +0100

> ipv6 or 6man lists that it can not be discussed there ?

briefly:

1. yes
2. no
3. yes

Nick

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 7 May 2021 10:21:44 +1200

>> ipv6 or 6man lists that it can not be discussed there ?

4. It's an IRTF topic anyway.

    Brian

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 7 May 2021 06:54:59 +0000

Hi Alex,

Please see inline.

Best,

Dirk

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: 06 May 2021 22:22
To: [email-masked]
Subject: Re: FW: Next steps discussing Routing Challenges of Semantic Addressing

[SNIP]

I doubt though that routing on more bits than a dst address can be qualified as semantics.  Semantics would be if the packets could smell something and routing would happen on that smell.  Or be coloured something, or have a spin, or similar.
[DOT] Semantic is about 'meaning of words'; if you equate 'words' with the (packet) fields taken as input for routing decisions, the meaning of those words/fields matters obviously. Point of the draft is the observation that semantic routing in that sense has been ongoing for a long time; it's a fact of life but worthwhile stating as an observation. Even the routing on IP addresses is semantic routing since the meaning of those addresses matters for many (all?) IP routing solutions. More importantly, the meaning of the IP address field can be changed, particularly in limited domains. Semantic prefixes are one example but also simply using the field to convey an entirely different semantic to route over is possible and has been done. Why is this worth observing now? Maybe it's the ease with which one can 'rummage' around in a packet and use various fields to make routing decisions. If you look at the progression from SDN to P4, for instance, the limitations of SDN to only allow actions on a limited set of fields is all but gone now in P4; the packet is your oyster now, so to speak!

Addressing something with something else than an address also poses a challenge.  On another hand, the semantics of an address could be augmented with port numbers, and then routing could be done based on
address+portnumbers, maybe traffic engineering.

[DOT] This relates to your comment before, i.e., that it makes sense to discuss it at the IETF: I do agree but also agree with Brian that it is eventually the IRTF that may be the target here. The emergence and possibility of semantic routing to be done so easily (see my previous reference to SDN->P4) poses indeed a number of challenges, particularly from an interoperability perspective (which is of particular interest to a standards forum and audience). The insights of the larger (IETF) community are important here as input, while the IRTF may provide the forum to bring together researchers (academic and industrial alike) who develop such semantic routing solutions to exchange views with the wider IETF community on how those solutions all come together and work 'friendly' with each other. This fruitful exchange is something that the IRTF can facilitate. An outcome may be recommendations (to developers of solutions and the IETF) on how semantic routing can/should be done sustainably, i.e., without the challenges that the draft also observes.  

Alex

> research related to routing based on additional meaning assigned to IP 
> addresses, and to routing based on fields other than the destination 
> address field of an IP packet. That draft attracted some  comments, 
> and one thing was clear: we needed to split the draft into  a survey 
> of work that has happened / is happening, and a discussion  of the 
> challenges to routing together with the research question.
> 
> academic, research-based community where we can discuss all aspects of 
> the drafts, introduce our research to each other, and advertise

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 7 May 2021 12:56:42 +0100

> 4. It's an IRTF topic anyway.

On the separate mailing list thing, these are ideas which need a bit of 
blue-sky thinking, so there really isn't an issue using a separate mail 
server for it. The most productive discussions often happen with wild 
ideas thrown around over a coffee with notes written on the back of a 
paper napkin, so neither the IRTF nor the IETF need to feel insecure 
that any initial discussions are happening elsewhere.  If there's an 
outcome which is worth pursuing, that'll be the time when people will 
naturally move it over to I*TF.

Nick

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 7 May 2021 14:00:08 +0200

Nick,

Please observe that those ideas have been shipping for years and are
deployed in SP networks.

Hint: Slide 5 of https://ripe67.ripe.net/presentations/251-ripe2-4.pdf

Best,
R.

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 7 May 2021 14:00:08 +0200

Nick,

Best,
R.

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 7 May 2021 13:48:44 +0100

> Please observe that those ideas have been shipping for years and are 

the proposals presented in terastream were, iirc, deployed to some 
degree in some networks but didn't end up with the wider rollout that 
was originally anticipated.  Some of the people involved with terastream 
are on v6ops/6man, so they may (or may not) want to provide more 
information.

Nick