Subject: Fwd: New Version Notification for draft-smith-6man-accurate-ra-router-lifetime-00.txt

From: Mark Smith <[email-masked]>
Date: Tue, 4 May 2021 18:24:55 +1000

Hi All,

I've been thinking for a while that the Router Lifetime field name
wasn't as accurate and expressive as it could be, and then we had
somebody asking fairly recently on the mailing list about how Router
Lifetime and ND lifetime (IIRC) values interacted on the mailing list.

So an ID proposing to rename the field to Default Router Lifetime, and
also providing an example scenario of when a zero value Default Router
Lifetime would be used to demonstrate that a zero value RA is valid
and useful in some scenarios.

Comments and suggestions most welcome.

Thanks very much,
Mark.

---------- Forwarded message ---------
From: <[email-masked]>
Date: Tue, 4 May 2021 at 18:14
Subject: New Version Notification for
draft-smith-6man-accurate-ra-router-lifetime-00.txt
To: Mark Smith <[email-masked]>

A new version of I-D, draft-smith-6man-accurate-ra-router-lifetime-00.txt
has been successfully submitted by Mark Smith and posted to the
IETF repository.

Name:           draft-smith-6man-accurate-ra-router-lifetime
Revision:       00
Title:          More Accurately Naming IPv6 RA Router Lifetime
Document date:  2021-05-04
Group:          Individual Submission
Pages:          4
URL:
https://www.ietf.org/archive/id/draft-smith-6man-accurate-ra-router-lifetime-00.txt
Status:
https://datatracker.ietf.org/doc/draft-smith-6man-accurate-ra-router-lifetime/
Htmlized:
https://datatracker.ietf.org/doc/html/draft-smith-6man-accurate-ra-router-lifetime
Htmlized:
https://tools.ietf.org/html/draft-smith-6man-accurate-ra-router-lifetime-00

Abstract:
   IPv6 Router Advertisements (RAs) have a "Router Lifetime" field,
   which specifies how long the advertising router will act as a default
   router for the receiving hosts, unless refreshed with another
   advertisement.  The field name "Router Lifetime" is quite general,
   and could easily be misunderstood to mean the bounded lifetime of all
   of the information contained in the RA.  This memo more accurately
   renames this field "Default Router Lifetime".

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Mark Smith <[email-masked]>
Date: Wed, 5 May 2021 17:43:39 +1000

Now with a more exciting email subject!

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 5 May 2021 10:15:22 +0200

> Now with a more exciting email subject!

Thanks,

The idea sounds great and it would solve a common problem of 
understanding the meaning of that field.  A better understanding would 
lead to better implementations.

But, there might be drawbacks as well: will it confuse a reader of an 
old code commented with 'Router Lifetime' everywhere and not finding 
that 'Router Lifetime' text in a potentially updated RFC?

> The Router Lifetime field of an RA indicates whether or not the
>    advertising router will act as a default router for the receiving
>    IPv6 hosts, and if so, for how many seconds it will perform that
>    role, unless it is refreshed by a subsequent RA from the router.

YEs, it is well formulated.  Maybe to be complete it should say that the 
'how many seconds' is non-zero.

>    If the RA Router Lifetime field value is zero, it means that the
>    router is not or will no longer be acting as a default router.

yes, but it will still be able to act as a router.  Maybe as a router 
for more specific routes, or maybe as a router to advertise the MTU of 
the link, or maybe for SLAAC (maybe for VSLAAC too).

(also, a side note, I think nothing prohibits a Host receiving that RA 
containing a 0 router lifetime to actually use it in whatever way it 
feels necessary.  That concept of 'default' route is a concept in the 
Host.  The Host might use it as it wants, irrespective of what the 
router suggests.)

Alex

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Vasilenko Eduard <[email-masked]>
Date: Thu, 6 May 2021 11:15:38 +0000

Hi Mark,
I believe too that naming things in a self-explanatory way is a good idea.
But is it a big enough problem for separate RFC? Is it possible to create an Errata to RFC 4861?
Eduard
-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Wednesday, May 5, 2021 11:15 AM
To: [email-masked]
Subject: Re: ID: More Accurately Naming IPv6 RA Router Lifetime (Re: New Version Notification for draft-smith-6man-accurate-ra-router-lifetime-00.txt)

Thanks,

The idea sounds great and it would solve a common problem of understanding the meaning of that field.  A better understanding would lead to better implementations.

But, there might be drawbacks as well: will it confuse a reader of an old code commented with 'Router Lifetime' everywhere and not finding that 'Router Lifetime' text in a potentially updated RFC?

>    role, unless it is refreshed by a subsequent RA from the router.

YEs, it is well formulated.  Maybe to be complete it should say that the 'how many seconds' is non-zero.

>    router is not or will no longer be acting as a default router.

yes, but it will still be able to act as a router.  Maybe as a router for more specific routes, or maybe as a router to advertise the MTU of the link, or maybe for SLAAC (maybe for VSLAAC too).

(also, a side note, I think nothing prohibits a Host receiving that RA containing a 0 router lifetime to actually use it in whatever way it feels necessary.  That concept of 'default' route is a concept in the Host.  The Host might use it as it wants, irrespective of what the router suggests.)

Alex

>> So an ID proposing to rename the field to Default Router Lifetime, 
>> and also providing an example scenario of when a zero value Default 
>> Router Lifetime would be used to demonstrate that a zero value RA is 
>> valid and useful in some scenarios.
>>
>> A new version of I-D, 
>> has been successfully submitted by Mark Smith and posted to the IETF 
>> repository.
>>
>> Please note that it may take a couple of minutes from the time of 
>> submission until the htmlized version and diff are available at tools.ietf.org.
>>
>> The IETF Secretariat
>

---

From: tom petch <[email-masked]>
Date: Thu, 6 May 2021 15:42:24 +0000

From: ipv6 <[email-masked]> on behalf of Alexandre Petrescu <[email-masked]>
Sent: 05 May 2021 09:15

Thanks,

<tp>
Not just old code but current code until it gets updated,  if it ever does.  And then there is all the documentation, manual pages and so on, thousands of places for people to misunderstand and get confused, not to mention a number of other RFC that use the existing terminology.

An identifier has to be usable, unique within its namespace, it does not have to carry all the semantics - that is what an RFC is for.

This seems to arise from people who have not done their homework, who think that Webster's dictionary can explain the meaning of code.  No, that is why we write RFC.

Tom Petch

p.s. get the name right first time, something that IETF WGs do not pay enough attention to IMHO.

Alex