Subject: FW: Application-Aware Networking (APN) focused interim

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Fri, 14 May 2021 00:55:10 +0000

Dear all,

The APN Interim meeting has been scheduled on June 3rd. Please find the meeting information shared by the Chairs of the RTG WG below.

In this APN Interim meeting, we are going to focus more on the discussions of the solutions (more overview than details), including
1.       the design of the APN attribute itself
2.       the encapsulation of the APN attribute on the various data planes (the encapsulation on the IPv6 data plane is an example)
3.       the control plane protocols extensions for exchanging the APN attribute
4.       NETCONF/YANG models for the NBI and SBI

You are very welcomed to join the discussions, and your comments and suggestions are very much appreciated.

Thank you!

Best regards,
Shuping

From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Friday, May 7, 2021 6:38 AM
To: Routing WG <[email-masked]>; RTGWG <[email-masked]>
Subject: Application-Aware Networking (APN) focused interim

Dear RTGWG,

We have scheduled Application-Aware Networking (APN) focused interim (agenda to be published), June 3rd, 2021, 7:00AM PST

Looking forward to seeing you,

Cheers,
Jeff and Chris

When it's time, start your Webex meeting here.

Thursday, June 3, 2021

7:00 AM  |  (UTC-07:00) Pacific Time (US & Canada)  |  2 hrs

Start meeting<https://ietf.webex.com/ietf/j.php?MTID=mc8ee2b80cb0fdd92745199a121f452db>

More ways to join:

Join from the meeting link

https://ietf.webex.com/ietf/j.php?MTID=mc8ee2b80cb0fdd92745199a121f452db

Join by meeting number

Meeting number (access code): 161 149 3477

Meeting password: gpN26drAet4

Tap to join from a mobile device (attendees only)

+1-650-479-3208,,1611493477##<tel:%2B1-650-479-3208,,*01*1611493477%23%23*01*> Call-in toll number (US/Canada)

Join by phone

1-650-479-3208 Call-in toll number (US/Canada)

Global call-in numbers<https://ietf.webex.com/ietf/globalcallin.php?MTID=m8fc024386f16ac264aaa306eeb5dff0c>

Join from a video system or application

Dial [email-masked]<sip:[email-masked]>

You can also dial 173.243.2.68 and enter your meeting number.

Join using Microsoft Lync or Microsoft Skype for Business

Dial [email-masked]<sip:[email-masked]>

If you are a host, click here<https://ietf.webex.com/ietf/j.php?MTID=m6b0d9545f1c064a6aa8f7739e2d4c763> to view host information.

Need help? Go to https://help.webex.com

---

From: Gyan Mishra <[email-masked]>
Date: Fri, 21 May 2021 18:38:56 -0400

Hi Shuping & APN WG

I agree as well that the agenda looks good and many thanks to the RTGWG for
providing a time slot to host the discussion.

I support the basic concept of the gap APN is trying to solve and provide
fine grain SLA for primary use case of 5G network slicing.

Traditionally and historically customer SLA been provided using Diffserv
QOS Marking and PHB scheduling as well as customer application layer SLA
using RSVP TE class or path based tunnel selection DS TE RFC 4124 and RFC
3270 MPLS Diffserv uniform and pipe mode explicit null framework to meet
customer SLA requirements.  Also ALTO / SDN PCE / PCE CC based network
based application flow optimizations of flows as well as ACTN abstraction
framework for underlay path resource provisioning.

As an agenda item I think it maybe a good idea to briefly touch on the
problem statement and the gap that requires a solution based on  existing
technologies and solutions that exist today.

Also applicability of the APN ID fine grain SLA for 5G network slicing,
DETNET, SD WAN as well as any other use cases.

As we have discussed caveats and complexity related to host to network
signaling that it makes sense to update the existing drafts to reflect
application edge CE based network marking of the APN ID.   Also, as the APN
ID marking as we have discussed will change  to network layer marking on
the application edge CE, how does the marking closely or not resemble the
VTN ID marking in the data packet for VPN+ E2E network slicing.

This will help facilitate the discussion so we don’t get stuck on the
complexity of host to network signaling.

Kind Regards

Gyan

On Thu, May 13, 2021 at 8:55 PM Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> Dear all,
>
>
>
> The APN Interim meeting has been scheduled on June 3rd. Please find the
> meeting information shared by the Chairs of the RTG WG below.
>
>
>
> In this APN Interim meeting, we are going to focus more on the discussions
> of the solutions (more overview than details), including
>
> 2.       the encapsulation of the APN attribute on the various data planes
> (the encapsulation on the IPv6 data plane is an example)
>
> *From:* rtgwg [mailto:[email-masked]] *On Behalf Of *Jeff Tantsura
> *Sent:* Friday, May 7, 2021 6:38 AM
> *To:* Routing WG <[email-masked]>; RTGWG <[email-masked]>
>
> *Subject:* Application-Aware Networking (APN) focused interim
>
>
>
> Dear RTGWG,
>
> We have scheduled Application-Aware Networking (APN) focused interim
> (agenda to be published), June 3rd, 2021, 7:00AM PST
>
> Start meeting
> <https://ietf.webex.com/ietf/j.php?MTID=mc8ee2b80cb0fdd92745199a121f452db>
>
>
>
>
>
> *More ways to join:*
>
>
>
>
>
> *Join from the meeting link*
>
> *Join by meeting number*
> *Tap to join from a mobile device (attendees only)*
>
> +1-650-479-3208,,1611493477##
> <%2B1-650-479-3208,,*01*1611493477%23%23*01*> Call-in toll number
> (US/Canada)
>
>
>
>
>
> *Join by phone*
>
> Global call-in numbers
> <https://ietf.webex.com/ietf/globalcallin.php?MTID=m8fc024386f16ac264aaa306eeb5dff0c>
>
>
>
>
>
>
>
> *Join from a video system or application*
>
> Dial [email-masked]
>
> *Join using Microsoft Lync or Microsoft Skype for Business*
>
> Dial [email-masked]
>
>
>
>
>
>
>
> If you are a host, click here
> <https://ietf.webex.com/ietf/j.php?MTID=m6b0d9545f1c064a6aa8f7739e2d4c763>
> to view host information.
>
>
>
> --
> Apn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apn
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Tue, 25 May 2021 03:56:42 +0000

Hi Gyan, folks,

Thank you for your suggestions! Besides the guiding slides for the solution discussions, we will also have a set of slides for the problem statement to clarify the WHY.

According to the feedback we have received so far, we have updated the main drafts to sync the information.

The main changes we have made to the drafts are as follows:

1. Removed the application-side solution, only keep the network-side solution

2. The APN attribute is acquired based on the existing information in the packet header such as 5-tuple and QinQ (S-VLAN and C-VLAN) at the edge devices of the APN domain, added to the data packets along with the tunnel encapsulation.

3. When the packets leave the APN domain, the attribute will be removed together with the tunnel encapsulation header.

4. APN aims to apply various policies in different nodes along a network path onto a traffic flow altogether, for example, at the headend to steer into corresponding path, at the midpoint to collect corresponding performance measurement data, and at the service function to execute particular policies.

https://datatracker.ietf.org/doc/html/draft-li-apn-framework-03

https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-02

https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis-02

https://datatracker.ietf.org/doc/html/draft-peng-apn-security-privacy-consideration-01

Your reviews and comments are very welcomed. Thank you!

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Gyan Mishra
Sent: Saturday, May 22, 2021 6:39 AM
To: Pengshuping (Peng Shuping) <[email-masked]>
Cc: [email-masked]; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Shuping & APN WG

I agree as well that the agenda looks good and many thanks to the RTGWG for providing a time slot to host the discussion.

I support the basic concept of the gap APN is trying to solve and provide fine grain SLA for primary use case of 5G network slicing.

Traditionally and historically customer SLA been provided using Diffserv QOS Marking and PHB scheduling as well as customer application layer SLA using RSVP TE class or path based tunnel selection DS TE RFC 4124 and RFC 3270 MPLS Diffserv uniform and pipe mode explicit null framework to meet customer SLA requirements.  Also ALTO / SDN PCE / PCE CC based network based application flow optimizations of flows as well as ACTN abstraction framework for underlay path resource provisioning.

As an agenda item I think it maybe a good idea to briefly touch on the problem statement and the gap that requires a solution based on  existing technologies and solutions that exist today.

Also applicability of the APN ID fine grain SLA for 5G network slicing, DETNET, SD WAN as well as any other use cases.

As we have discussed caveats and complexity related to host to network signaling that it makes sense to update the existing drafts to reflect application edge CE based network marking of the APN ID.   Also, as the APN ID marking as we have discussed will change  to network layer marking on the application edge CE, how does the marking closely or not resemble the VTN ID marking in the data packet for VPN+ E2E network slicing.

This will help facilitate the discussion so we don’t get stuck on the complexity of host to network signaling.

Kind Regards

Gyan

On Thu, May 13, 2021 at 8:55 PM Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Thank you!

Best regards,
Shuping

From: rtgwg [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jeff Tantsura
Sent: Friday, May 7, 2021 6:38 AM
To: Routing WG <[email-masked]<mailto:[email-masked]>>; RTGWG <[email-masked]<mailto:[email-masked]>>
Subject: Application-Aware Networking (APN) focused interim

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

More ways to join:

Join by meeting number

Join by phone

--
Apn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apn
--

[图像已被发件人删除。]<http://www.verizon.com/>

Gyan Mishra

Network Solutions Architect

Email [email-masked]<mailto:[email-masked]>

M 301 502-1347

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 27 May 2021 17:02:46 +0000

Shuping and APN proponents,

https://datatracker.ietf.org/doc/draft-mcd-rtgwg-extension-tn-aware-mobility/ describes a framework to enable the IP network (over the 5G N6 interface) to be aware of the 5G UE traffic to achieve optimized transport aligning with the 5G Slices characteristics .
The proposed framework aligns with the APN scope of work described in the APN BoF description. Do you think it is worthwhile to add this draft to the APN interim meeting?

Thank you very much.
Linda Dunbar

From: Apn <[email-masked]> On Behalf Of Pengshuping (Peng Shuping)
Sent: Monday, May 24, 2021 10:57 PM
To: Gyan Mishra <[email-masked]>
Cc: [email-masked]; RTGWG <[email-masked]>; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Gyan, folks,

https://datatracker.ietf.org/doc/html/draft-li-apn-framework-03<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-li-apn-framework-03&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239682662%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=NGn3A8uQEesRTdgDQK8R%2BrVUkMNquU3aDBmmes3WrCY%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-li-apn-problem-statement-usecases-02<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-li-apn-problem-statement-usecases-02&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239682662%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=734J6KBv7Hc3RqqaBCUVKaqPjAs9gwtbfilyntCPVy4%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis-02<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis-02&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239692621%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=KFh4OhC07Z5X9RkaNY%2FkQtyMQ1H6xNa19q8SLwEuF%2FY%3D&reserved=0>

https://datatracker.ietf.org/doc/html/draft-peng-apn-security-privacy-consideration-01<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-security-privacy-consideration-01&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239692621%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=oA6OkUf04E6uKIQY2hDYNPgAqta0TeyRYHxcmoQNUJM%3D&reserved=0>

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Gyan Mishra
Sent: Saturday, May 22, 2021 6:39 AM
To: Pengshuping (Peng Shuping) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; 6MAN <[email-masked]<mailto:[email-masked]>>; Routing Area Working Group <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Shuping & APN WG

This will help facilitate the discussion so we don't get stuck on the complexity of host to network signaling.

Kind Regards

Gyan

Thank you!

Best regards,
Shuping

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

Start meeting<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dmc8ee2b80cb0fdd92745199a121f452db&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239692621%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ezf9qTDC7bUS%2BpO1kN8I%2B%2BfS5t5hxUgI0uu2mBGU6Y8%3D&reserved=0>

More ways to join:

Join from the meeting link
https://ietf.webex.com/ietf/j.php?MTID=mc8ee2b80cb0fdd92745199a121f452db<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dmc8ee2b80cb0fdd92745199a121f452db&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239702578%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ZcGHZwMbAl87dhDV6krdBTGBO%2F5n5P3kA33xRN8tBUs%3D&reserved=0>

Join by meeting number

Join by phone
1-650-479-3208 Call-in toll number (US/Canada)
Global call-in numbers<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fglobalcallin.php%3FMTID%3Dm8fc024386f16ac264aaa306eeb5dff0c&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239702578%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=JLdqvHmkDVDqrFzS6cZF6YU0MC7rsIvdgwayi1JbgEA%3D&reserved=0>

Join from a video system or application
Dial [email-masked]<mailto:[email-masked]>
You can also dial 173.243.2.68 and enter your meeting number.

Join using Microsoft Lync or Microsoft Skype for Business
Dial [email-masked]<mailto:[email-masked]>

If you are a host, click here<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fietf.webex.com%2Fietf%2Fj.php%3FMTID%3Dm6b0d9545f1c064a6aa8f7739e2d4c763&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239702578%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=m%2B7PX7dQ2j42%2FkurgECqI0dPYtasuIQ4hoTiEniOE30%3D&reserved=0> to view host information.

Need help? Go to https://help.webex.com<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fhelp.webex.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239712535%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=76kh2QvvAO6d9pnfHXcj54X3Iv%2FR2mAd5Gyj08Y7uLo%3D&reserved=0>

--
Apn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apn<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fapn&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239712535%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=0irNAbnOJtZ7a9mN%2BbBMYFaEVmM6iGSIf5uIw4rZTKY%3D&reserved=0>
--

[??????????]<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.verizon.com%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C2135160315e4459f633f08d91f312652%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637575118239722487%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=PDZnAGGzpo7DUlRbK2m12WK5cHXTinPaVCSxvRxOycM%3D&reserved=0>

Gyan Mishra

M 301 502-1347

---

From: Lizhenbin <[email-masked]>
Date: Fri, 28 May 2021 04:10:15 +0000

Hi Linda,
Thanks very much for your proposal. I have following comments for your reference:
1. The coming APN interim meeting will focus on the solution discussion including the forwarding plane (IPv6-based and MPLS-based) encapsulation, the possible control protocols (IGP/BGP/PCEP) extension and YANG models.
2. We have changed the scope of APN to focus on the network-side solution and updates the related drafts accordingly. I am a little doubtful that the solution in your draft is still related with the case to tag the information in the application side. Even if not, because most of the GTP-u work is under the scope of 3GPP instead of IETF, it may be not a right time to discuss the encapsulation of APN attributes with the GTP-u tunnel now. We should focus on the IETF-based tunnel technologies firstly.

Best Regards,
Robin

From: Linda Dunbar [mailto:[email-masked]]
Sent: Friday, May 28, 2021 1:03 AM
To: Pengshuping (Peng Shuping) <[email-masked]>; Gyan Mishra <[email-masked]>
Cc: [email-masked]; RTGWG <[email-masked]>; 6MAN <[email-masked]>; Routing Area Working Group <[email-masked]>; [email-masked]
Subject: RE: [Apn] FW: Application-Aware Networking (APN) focused interim

Thank you very much.
Linda Dunbar

From: Apn <[email-masked]<mailto:[email-masked]>> On Behalf Of Pengshuping (Peng Shuping)
Sent: Monday, May 24, 2021 10:57 PM
To: Gyan Mishra <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; RTGWG <[email-masked]<mailto:[email-masked]>>; 6MAN <[email-masked]<mailto:[email-masked]>>; Routing Area Working Group <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Apn] FW: Application-Aware Networking (APN) focused interim

Hi Gyan, folks,

Best regards,
Shuping

Hi Shuping & APN WG

Kind Regards

Gyan

Thank you!

Best regards,
Shuping

Dear RTGWG,

Cheers,
Jeff and Chris

Thursday, June 3, 2021

More ways to join:

Join by meeting number

Join by phone

Gyan Mishra

M 301 502-1347