Subject: [Isis-wg] Reg. multiple IP addr and Advt of L1 Addr in L2 Lsps

From: "vanisri .k" <[email-masked]>
Date: Wed, 22 Mar 2000 11:50:37 +0530

Hi,

I have doubts regarding the following. Please
clarify  me.

1. 
IS-IS allows  multiple IP addresses assigned to
an physical interface. What is the significant of it
and  where it is applied?

2.
L2 Router advertises in its level 2 LSPs all the IP  addresses
reachable in their area. Summary address can be configured, 
otherwise all the level 1 Addresses obtained from the level 1 
LSPs has to be advertised.
My doubt is can we get the addresses from the "level 1 Forwarding Data base" 
instead of "level1 LSPs".
RFC says (Sec 3.2 of 1195) these are determined from
level 1 LSPs. Should the l2 router collects all  l1 reachable
addresses and the cost to reach them from level 1 LS data base, 
if summary address is not configured.

Thanks
-vani

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Rajesh Saluja" <[email-masked]>
Date: Wed, 22 Mar 2000 09:37:43 -0500

> an physical interface. What is the significant of it

You can support multinetting on one physical interface.

> if summary address is not configured.

Spec says "address obtained from level1  LSP". It is  an implementation choice
whether you want to extract this information from L1 LSPs or forwarding
database or some other data structure.

Regards,
Rajesh

---

From: Mike Shand <[email-masked]>
Date: Thu, 23 Mar 2000 12:00:29 +0000

>database or some other data structure.

But its important that what you extract is the REACHABLE addresses, not 
just any old addresses that happen to be skulking around in some 
unconnected L1 LSP. So in that sense you should get them from the RIB/FIB 
not from the raw LSP database.

         Mike