Subject: RE: [Isis-wg] Re: I-D ACTION:draft-ietf-isis-wg-mesh-group-00.txt

From: Jeff Parker <[email-masked]>
Date: Wed, 8 Mar 2000 10:28:20 -0500

> At 10:32 02/03/2000 -0500, [email-masked] wrote:
> >
> >         Title           : IS-IS Mesh Groups
> >         Author(s)       : R. Balay, D. Katz, J. Parker
> >         Filename        : draft-ietf-isis-wg-mesh-group-00.txt
> >         Pages           : 9
> >         Date            : 01-Mar-00
> 
> Just a few comments.

Mike -
	Thanks for your careful reading.  

> In the modified 7.3.15.1. e.1.ii) there is no mention of what 
> to do if the incoming circuit is 'meshblocked'. I assume this 
> is do nothing, since if things are correctly configured you 
> wouldn't receive an LSP over such a circuit, but the spec 
> should be clear on this point.

I would imagine that this would be a legal configuration,
and that some might find a use for one way links like this.
 
> It could do with an example of how one is supposed to deploy it.

I suppose documenting them is one step on the slippery slope
to advocating them.  Perhaps I can find some weasel words
and add an example: maybe a 6-way complete mesh constrained
to have a couple of alternative flooding paths between each pair.

> It might be helpful to say that a very good way of shooting 
> yourself in the foot is to define some links as meshSet and 
> some links as meshBlocked in the same 'mesh'. One could argue 
> that use of CSNPs gets you out of the hole, but maybe that is 
> even worse because although you get the LSPs delivered 
> eventually you introduce a considerable propagation delay.
>
> Oh and I think there's a typo. In the sentence leading up to 
> the changes to 
> section 7.3.15.3 clause b) (bottom of page 4) it says
> 
> "...links with a mesh group meshEnabled or meshBlocked."
> 
> presumably this should read
> "... links with a meshEnabled value of meshSet or meshBlocked"
> 
>          Mike

Thanks - will make that edit.  

- jeff parker
- [email-masked]

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Wed, 8 Mar 2000 10:57:54 -0500

> >In the modified 7.3.15.1. e.1.ii) there is no mention of 
> >what to do if the incoming circuit is 'meshblocked'. 
> 
> Hmmm. Thinking about this some more, its not so obvious. If 
> you received a CSNP over a meshBlocked circuit, and you had 
> a newer LSP you would send it out over the meshBlocked circuit 
> (since the draft makes no changes to section 7.3.15.2 c). 
> Hence it would be entirely reasonable to receive an LSP over 
> a circuit marked meshBlocked, even in a correctly configured 
> network. So presumably one would want to accept that LSP and 
> treat it as for meshSet?
> 
>          Mike

Sorry, missed this when replying to previous.

Is there a reason to discard any valid LSP?  We do solicit
them when we detect a missing LSP listed in a CSNP.      
We could check to see if this one arrived "on it's 
own" or if we asked for it, but this seems excessive.  

I see Mesh Groups as a way to cut back on transmissions.
Once the network has taken the trouble to deliver an
LSP, taking the time to check to see if the LSP is new, 
and keeping it if it is, seems conservative.   

- [email-masked]
- Lucent INS