Subject: [Isis-wg] Clarification on ISIS configuration

From: Navaneeth K <[email-masked]>
Date: Tue, 21 Mar 2000 17:58:03 +0530

Hi all..

My doubt is with regard to the configuration of Summary Addresses in ISIS . 

i. Can summary addresses be configured for both Level 1 and Level 2? 
   If so , how do we use the Level 1 summary addresses? In advertising the summary addresses , 
   do we take it from the Level 1 LSPs or from the routes calculated by Level 1 Decision process?
ii. In the configuration of the summary address , there are two parts the address mask and the prefix mask.
   How are these used and what values do these take? Can anyone explain these with an illustration?
   
Any help in this regard is most welcome.

Thanks and Regards
Navaneeth.

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Rajesh Saluja" <[email-masked]>
Date: Tue, 21 Mar 2000 08:33:37 -0500

> i. Can summary addresses be configured for both Level 1 and Level 2?

Only for Level2 as far as RFC is concerned. Summarization is done while
advertising L1 routes into L2 domain.

>    do we take it from the Level 1 LSPs or from the routes calculated by Level 1 Decision process?

from the routes calculated by Level 1 decision process.

>    How are these used and what values do these take? Can anyone explain these with an illustration?

If you have 192.9.3.0/24 and 192.9.2.0/24 networks allocated to  your L1
domain, you could configure 192.9.2.0/23 as summary address which will
basically aggregate both while advertising to L2 domain.

Regards,
Rajesh

---

From: [email-masked]
Date: Tue, 21 Mar 2000 19:11:57 +0100 (CET)

Hello Navaneeth, hello all,

> i. Can summary addresses be configured for both Level 1 and Level 2? 

  Yes, they can now. RFC1195 only specifies L1->L2 leaking, and only
 specifies redistribution into L2. This has changed with the new draft
 draft-ietf-isis-domain-wide-02.txt.

>    If so , how do we use the Level 1 summary addresses?

  With the new draft about route-leaking, there are now two descriptions
 of how routes can be summarized into L1. 1) is via L2->L1 route-leaking,
 and 2) via redistribution from outside the IGP into ISIS.

>    In advertising the summary addresses , do we take it from the Level
>    1 LSPs or from the routes calculated by Level 1 Decision process?

  From routes calculated. The rule of thumb for routing protocols is 
 that you only advertise routes that you use yourself. So if a prefix
 is in the LSPDB, but for some reason you didn't install it in the
 RIB, then you will not advertise it. Nor use it when calculating
 summary addresses.

  Hope this helps,

        Henk.