Subject: RE: [Isis-wg] Reg. multiple IP addr and Advt of L1 Addr in L2 Lsp s

From: Satish Dattatri <[email-masked]>
Date: Thu, 23 Mar 2000 12:30:43 -0800

Hi Jeff,
Take a configuration of R1 and R2
in a area. Let R1 have 2 interfaces
R1I1 and R1I2. R1 and R2 are connected
via R1I2.
Now, if R1I1 has multiple IP addresses,
The only way R2 will know is by the LSP
of R1 [ assume only isis is running;-) ]

Then, where is the option of none of the IP
reachability info in L1 LSP holds out?

Well, there may be other cases where with a
router sending none of the IP info still may
have connectivity. But that does not mean
protocol can have the option of not sending
local reachability.

Please let me know if I am missing something here.
thanks,
satish

<snip>
These IP Addresses could appear in two places:
	In the hello pkt sent out that port
	In the LSPs sent by that router

If you have multiple IP addresses on a port, you could
advertise one, both, or none in your L1 LSP and in your 
hellos.  I think this is an implementation issue: but
the principle of least surprise would probably suggest
that you include both in Hellos and in LSPs.  

- jparker

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Thu, 23 Mar 2000 13:04:25 -0800

]Hi Jeff,
 ]Take a configuration of R1 and R2
 ]in a area. Let R1 have 2 interfaces
 ]R1I1 and R1I2. R1 and R2 are connected
 ]via R1I2.
 ]Now, if R1I1 has multiple IP addresses,
 ]The only way R2 will know is by the LSP
 ]of R1 [ assume only isis is running;-) ]
 ]
 ]Then, where is the option of none of the IP
 ]reachability info in L1 LSP holds out?
 ]

depends on if there is a need for R2 to know
the IP address on R1I1. some IP addresses should
be stay local only. so this is an implementation
and configuration issue.

even if R1I1 has isis configured on the interface,
you don't have to stuff all the IP addresses on
the LSPs, you have a choice say only put "primary"
address there, or put all the addresses there, or
even use some kind of filtering to selectively
stuff part of the addresses there. An example is
if you have a 10/x address on the interface as a
secondary IP address, you may choose not to advertise
it into your isis LSP.

you can also use redistribution to selectively bring
in your connected IP addresses using some kind of policy.

 ]Well, there may be other cases where with a
 ]router sending none of the IP info still may
 ]have connectivity. But that does not mean
 ]protocol can have the option of not sending
 ]local reachability.
 ]
 ]Please let me know if I am missing something here.
 ]thanks,
 ]satish
 ]
 ]<snip>
 ]These IP Addresses could appear in two places:
 ]	In the hello pkt sent out that port
 ]	In the LSPs sent by that router
 ]
 ]If you have multiple IP addresses on a port, you could
 ]advertise one, both, or none in your L1 LSP and in your 
 ]hellos.  I think this is an implementation issue: but
 ]the principle of least surprise would probably suggest
 ]that you include both in Hellos and in LSPs.  
 ]
 ]- jparker
 ]
 ]_______________________________________________
 ]Isis-wg mailing list  -  [email-masked]
 ]http://external.juniper.net/mailman/listinfo/isis-wg
 ]
 ]_______________________________________________
 ]Isis-wg mailing list  -  [email-masked]
 ]http://external.juniper.net/mailman/listinfo/isis-wg

- Naiming