Subject: RE: [Isis-wg] Reg. multiple IP addr and Advt of L1 Addr in L2 Lsp s

From: Jeff Parker <[email-masked]>
Date: Wed, 22 Mar 2000 09:34:40 -0500

> Hi,
> 
> I have doubts regarding the following. Please
> clarify  me.
> 
> 1. 
> IS-IS allows  multiple IP addresses assigned to
> an physical interface. What is the significant of it
> and  where it is applied?

IP allows multiple IP addresses assigned the the same
interface.  This can be used to allow a router to
participate in multiple networks.  ISIS just relays 
the information.  
 
> 2.
> L2 Router advertises in its level 2 LSPs all the IP  addresses
> reachable in their area. Summary address can be configured, 
> otherwise all the level 1 Addresses obtained from the level 1 
> LSPs has to be advertised.

An optimization lets you reduce the network load by
checking to see if the L1 route is comming from an L1/L2
router, which can be trusted to put it into L2 for you.

> My doubt is can we get the addresses from the "level 1 
> Forwarding Data base" 
> instead of "level1 LSPs".
> RFC says (Sec 3.2 of 1195) these are determined from
> level 1 LSPs. Should the l2 router collects all  l1 reachable
> addresses and the cost to reach them from level 1 LS data base, 
> if summary address is not configured.
> 
> Thanks
> -vani

There are a number of issues in your question: I'm not
sure which you are asking about.

- jeff parker
- Lucent INS

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "vanisri .k" <[email-masked]>
Date: Thu, 23 Mar 2000 11:42:44 +0530

Hi Jeff,
My comments are inlined.

> an physical interface. What is the significant of it

IP allows multiple IP addresses assigned   the same
interface.  This can be used to allow a router to
participate in multiple networks.  ISIS just relays 
the information.  
[vanisri .k]  Then how IS-IS should handle, when advertising reachable information about the nbr,having multiple IP addresses.?
 There will be multiple IP addresses (Reachable information) to that neighbor .?
I am not much clear how IS-IS handles and relays the multiple IP addresses information.
  Could you please explain.

There are a number of issues in your question: I'm not
sure which you are asking about.
[vanisri .k]  My question was clarfied by Rajesh.
My actual question was ,
How do the L1L2 Router collects the level 1 reachablity information, before it
advertises in its level2 LSPs to other areas, from its level1 LSPs or Level 1 Forwarding Data base. ?
Rajesh says, It is implementaion specific.

- jeff parker
- Lucent INS
Thanks
-vani

---

From: Jeff Parker <[email-masked]>
Date: Thu, 23 Mar 2000 15:14:08 -0500

> [vanisri .k]  Then how IS-IS should handle, when advertising 
> reachable information about the nbr,having multiple IP addresses.?

These IP Addresses could appear in two places:
	In the hello pkt sent out that port
	In the LSPs sent by that router

If you have multiple IP addresses on a port, you could
advertise one, both, or none in your L1 LSP and in your 
hellos.  I think this is an implementation issue: but
the principle of least surprise would probably suggest
that you include both in Hellos and in LSPs.  

- jparker

---

From: Jeff Parker <[email-masked]>
Date: Thu, 23 Mar 2000 15:52:14 -0500

Satish -
	I will not try to defend the option "none",
though I admit that I raised it earlier.  There 
is a place for unnumbered interfaces, but that
is another discussion.  

I am just trying to suggest that there is a great 
deal of leyway for implementations.  There may be a 
reason to have a second IP address, and there
may be a reason not to mention that address
to the ISIS protocol.  R2 will not know about 
it: that may be what the user wants.  
We do not want to be in the business of
telling you how your users use the protocol.

- jeff parker
- I'm not sure if these opinions are mine,
- much less those of Lucent Technologies.  

> Hi Jeff,
> Take a configuration of R1 and R2
> in a area. Let R1 have 2 interfaces
> R1I1 and R1I2. R1 and R2 are connected
> via R1I2.
> Now, if R1I1 has multiple IP addresses,
> The only way R2 will know is by the LSP
> of R1 [ assume only isis is running;-) ]
> 
> Then, where is the option of none of the IP
> reachability info in L1 LSP holds out?
> 
> Well, there may be other cases where with a
> router sending none of the IP info still may
> have connectivity. But that does not mean
> protocol can have the option of not sending
> local reachability.
> 
> Please let me know if I am missing something here.
> thanks,
> satish
> 
> <snip>