Subject: Re: [Isis-wg] ManualL2Only

From: Koen Vermeulen <[email-masked]>
Date: Wed, 17 Oct 2001 17:13:30 +0200

Hello Jeff,

I think I have to be more specific, because it seems that
my question was not understood completely. I will try to
explain what I meant with an example.

Suppose you have following 3 IS's:

      1          2
A ----- B ----- C
L1     L1/L2     L2

where link 2 has network address x and is configured as
manualL2only. This means that B will only try to form
a L2 adjacency with C.
My question is now: is it allowed to add address x in an ip
reachability TLV to the L1 LSP of B or will this lead to
some problems?
Right now, I can't think of any problems adding the
network address of a manualL2only to L1. I would
even expect that this way of working is the correct
one because of the fact that IS-IS areas cut through
interfaces and not through routers as is done in OSPF.

I hope this makes my question more clear?

Thanks,
Koen

Jeff Learman wrote:

> At 02:33 AM 10/16/2001, Koen Vermeulen wrote:
> >Hello,
> >
> >Nor in ISO/IEC 10589, neither in rfc 1195 I can't find an
> >explicit rule whether or not to include the network address
> >of a manualL2only-enabled interface in the L1 LSP generated
> >by a L1/L2 IS.
> >Somebody has some ideas/good reasons for not including
> >the address of that manualL2only interface in L1?
>
> Without consulting the specs, I can say that it doesn't make
> sense to include such an adjacency in the L1 LSP.  If you do,
> then when you run SPF, you will either use "inadmissible"
> local knowledge when running SPF (thereby creating a different
> topology than other ISs) or else you won't heed the L2-only
> nature of the link and will forward L1 traffic on it.
>
> For example:
>
>   A --- B ==== C ---- D
>   |                   |
>   E -- F -- G -- H -- I
>
> where all are in the same area, but the link between B and C
> is L2-only.  If A wants to send data to D, it will send it to
> B.  If B heeds the l2-only property, it would send it back to A.
>
> Note that B runs the SPF using the same data as everyone else:
> the LSDB.  It uses its adjacency database also, true, but only
> to preload "tent" (or is it "paths", it's been a while).
>
> B needs to advertise links consistently with how it would use
> them itself, so that the area topology is identical for all ISs
> in the area.
>
> Regards,
> Jeff
>
> >Thanks,
> >Koen
> >
> >_______________________________________________
> >Isis-wg mailing list  -  [email-masked]
> >http://external.juniper.net/mailman/listinfo/isis-wg
>
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Wed, 17 Oct 2001 11:44:32 -0400

Reading your original email more carefully, I see I made a
mistake.  You were talking about the interface address,
not the adjacency.  This case would not be covered in ISO 10589,
because in OSI, interfaces do not have network layer addresses.
It's only an issue for IP addresses.

In general, I would prefer using an unnumbered interface between
areas, if possible, to avoid wasting a subnet address that can't
be wholly within a single area, and therefore able to be summarized.
This is a minor point, and it's often not possible to use an
unnumbered interface, so the question remains.

I don't see any harm in including the address, and I don't
see any benefit to omitting it.  I don't have a lot of experience
in integrated IS-IS, though, so you may want to wait for other
opinions.

Regards,
Jeff

Disclaimer: I am not working on IS-IS at Cisco nor am I familiar with
Cisco's IS-IS implementation.  Just trying to keep brain cells from
a previous job alive.

---

From: Jeff Learman <[email-masked]>
Date: Fri, 19 Oct 2001 18:25:20 -0400

Koen,

Sorry, I have to change my answer again.  Les pointed out to
me that you said "network address" (meaning with a net mask
less than 32 bits), not "host address" (with 32 bits).  I
agree with Les that only L1 network addresses should be advertised
in an L1 LSP.  The host address of the router on that network
could be advertised.

Jeff