Subject: [Isis-wg] RE: About the IS Adjacency Area Address Table

From: Jeff Parker <[email-masked]>
Date: Mon, 25 Mar 2002 18:34:07 -0500

> Jeff
> 
> I have a couple of questions about the IS Adjacency Area Address Table
> Index  as compared to
> the IS Adjacency IP Address Table.
> 
>  Why is it that we have the isisISAdjAreaAddrAdjIndex  I believe that
> the isisISAdjIndex  could be used here as well ?

Good suggestion.  Done.  
> 
>  We have  isisISAdjIPAddrAdjIndex for the ip addresses why not have an
> index for the area addresses as well.
> IMHO, this would simplify greatly the code having an index (len 1)
> instead of the address (len 22)
> 
> Padma

You are not the first person to complain about the efforts needed to
walk the Adj Address Table, given that ISO addresses are variable 
length.  I will add an index to simplify implementation.

- jeff parker

     IsisISAdjAreaAddrEntry ::=
         SEQUENCE {
             isisISAdjAreaAddrIndex
                Integer32,
             isisISAdjAreaAddress
                 OSINSAddress
             }

    isisISAdjAreaAddrIndex OBJECT-TYPE
         SYNTAX Integer32 (1..2000000000)
         MAX-ACCESS not-accessible
         STATUS current
         DESCRIPTION
             "An index for the areas associated with one neighbor.
              This provides a simpler way to walk the table."
     ::= { isisISAdjAreaAddrEntry 1 }
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Mon, 25 Mar 2002 15:43:42 -0800

Jeff

I also came up with the same situation with the
isisISAdjProtSuppTable
we could make all the tables under adjacency consistent
by putting the isisISAdjIndex  and an index on the entry
we are walking

Thanks

Padma