Subject: Re: [Isis-wg] Ipv4/Ipv6 routers in 1 area

From: Koen Vermeulen <[email-masked]>
Date: Mon, 18 Mar 2002 16:09:38 +0100

Hello,

OK, I agree with the fact that in case we take the RFC 1195 topological
restrictions into account (which means that in case we want to forward
IPv6 traffic inside an area all routers need to be able to forward IPv6
traffic) only 1 SPF is required and we don't need to look at the
'protocols supported' TLV.
However, this makes it hard according to me for the transition of an
area from IPv4 to IPv6. This means that from the moment we want
to forward IPv6 traffic through an area, all routers and all its
interfaces
needs to be IPv6 capable.

I don't see immediately how this can work during transition.

Any suggestions?

Regards,
Koen

Koen Vermeulen wrote:

> Hello,
>
> I have a question related to the support of IPv4/IPv6
> mixed routing domains.
>
> Every router will indicate inside its LSP what IP
> version it is capable off using the 'protocols supported'
> TLV: an IPv4-only router will indicate it supports
> IPv4, and IPv6-only router will indicate it supports
> IPv6 and an IPv4/IPv6 router indicates it supports both.
>
> This 'protocols supported' TLV can be used inside the
> SPF for a certain IP version (I assume that an IPv4/IPv6
> router will need to run 2 SPFs, one for IPv4 and one for
> IPv6) to determine whether ot not to take the related LSP
> into account.
>
> This mechanism will work fine as long as an IPv4/IPv6
> capable router can forward both IPv4 and IPv6 traffic
> on all its interfaces. Because of the 'node level' nature
> of the 'protocols supported' TLV, it is not possible
> to perform a correct calculation with IPv4/IPv6 routers
> which have a mixture of IPv4-only and IPv6-only interfaces.
> This can be shown easily with an example:
>
>                 +----+
>                 | R1 | IPv4/IPv6
>                 +----+
>                    |
>                    | IPv6 capable link (1)
>                    |
>                    |
>                 +----+
>                 | R2 | IPv4/IPv6
>                 +----+
>                    |
>                    | IPv4-only capable link (2)
>                    |
>                    |
>                 +----+
>                 | R3 | IPv4/IPv6
>                 +----+
>                    |
>                    | IPv6 capable link (3)
>                    |
>                    |
>                 +----+
>                 | R4 | IPv4/IPv6
>                 +----+
>                   |
>                   x
>
> R1, R2, R3 and R4 are IPv4/IPv6 capable routers. Links (1) and
> (3) can forward IPv6 packets, link (2) can only forward IPv4
> traffic. x is an IPv6 network address.
>
> Suppose R1 is calculating a route to IPv6 network x. Because
> of the fact that R2 and R3 are both generating an LSP which
> indicates they are IPv6 capable, the resulting route to x will
> be via R2 and R3. Although, the link (2) between R2 and R3 is
> not capable of forwarding IPv6 traffic.
>
> I went back to RFC 1195 1.4 'Support of Mixed Routing Domains',
> because here similar problems occur. From what I understand
> from this text, is that a dual router here can both forward
> CLNS and IP on all its interfaces, although it is not specifically
> stated.
>
> In case we take this rule also for IPv4/IPv6 capable routers
> (all interfaces are IPv4/IPv6 capable), there is of course no
> problem. On the other hand, during the transition of IPv4
> to IPv6 I can image a lot of routers which will have a
> mixture of IPv4-only and IPv6-only interfaces.
>
> As a solution for this problem we were considering of announcing
> in every IS-reachablity TLV via a sub-TLV the capability of
> that specific interface (again via 'protocols supported')?
> This can be picked up in the SPF to decide whether or not
> take that link into account for a certain IP version.
>
>
> All suggestions/remarks/corrections are welcome.
>
> Thanks,
> Koen _______________________________________________ Isis-wg mailing
> list - [email-masked]
> http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: "Ken Larmer" <[email-masked]>
Date: Mon, 18 Mar 2002 10:39:34 -0500

Hi Koen,

RFC-1195 states the following:

 4.4 Maintaining Router Adjacencies
...
...
...
Dual routers must operate in a dual fashion on every link in the routing
domain over which they are running IS-IS. Thus, the value of the "protocols
supported" field must be identical on every link(i.e., for any one router
running IS-IS, all of the Hellos and LSPs   transmitted by it must contain
the same "protocols supported"   values).

Cheers,
Ken Larmer
CommSense Networks
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Koen Vermeulen
  Sent: Monday, March 18, 2002 10:10 AM
  To: Isis-wg
  Subject: Re: [Isis-wg] Ipv4/Ipv6 routers in 1 area

  Hello,

  Any suggestions?

  Regards,
  Koen

  Koen Vermeulen wrote:

    Hello,

                    +----+
                    | R1 | IPv4/IPv6
                    +----+
                       |
                       | IPv6 capable link (1)
                       |
                       |
                    +----+
                    | R2 | IPv4/IPv6
                    +----+
                       |

    Thanks,

---

From: Jeff Learman <[email-masked]>
Date: Mon, 18 Mar 2002 11:25:08 -0500

I agree, I suspect that 1195's restrictions are unnecessarily severe,
and that they won't serve us well for migrating to IPV6.  I think this
is a very important discussion for us to be having.

There are two restrictions that we need to consider:

  1.  Interface rules (a router must support all "supported protocols"
      on all interfaces)

  2.  Area / Domain rules (need I list them here?)

A third consideration that is important is whether adjacency establishment
should be a function of protocols supported.  While it seems sensible to
do this, it would break the DR election process.

I hesitate to recommend changing restriction 1, but if it would be
completely impractical to stand on this rule, we need to know about it.
I'd really like input from service providers here.

The second rule is easy to violate; some implementations already do.
Those that do behave identically as those that don't, when deployed in
a network that meets the restrictions.  You can't deploy a router that
doesn't violate the second restriction (i.e., a router that runs a single
SPF) in a network that violates the rules, of course, so compatibility
issues shouldn't be a problem here.

Regards,
Jeff

At 10:09 AM 3/18/2002, Koen Vermeulen wrote:
>to forward IPv6 traffic through an area, all routers and all its interfaces 
>>Koen _______________________________________________ Isis-wg mailing list - [email-masked] <http://spider.juniper.net/mailman/listinfo/isis-wg>http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Mon, 18 Mar 2002 09:36:25 -0800

] 
 ] Hello,
 ] 
 ] OK, I agree with the fact that in case we take the RFC 1195 topological
 ] restrictions into account (which means that in case we want to forward
 ] IPv6 traffic inside an area all routers need to be able to forward IPv6
 ] traffic) only 1 SPF is required and we don't need to look at the
 ] 'protocols supported' TLV.
 ] However, this makes it hard according to me for the transition of an
 ] area from IPv4 to IPv6. This means that from the moment we want
 ] to forward IPv6 traffic through an area, all routers and all its
 ] interfaces
 ] needs to be IPv6 capable.
 ] 
 ] I don't see immediately how this can work during transition.
 ] 
 ] Any suggestions?

please take a look at:

 draft-ietf-isis-wg-multi-topology-02.txt

to see if your problem is solved by using M-ISIS.

 ] 
 ] Regards,
 ] Koen
 ] 
 ] Koen Vermeulen wrote:
 ] 
 ] > Hello,
 ] >
 ] > I have a question related to the support of IPv4/IPv6
 ] > mixed routing domains.
 ] >
 ] > Every router will indicate inside its LSP what IP
 ] > version it is capable off using the 'protocols supported'
 ] > TLV: an IPv4-only router will indicate it supports
 ] > IPv4, and IPv6-only router will indicate it supports
 ] > IPv6 and an IPv4/IPv6 router indicates it supports both.
 ] >
 ] > This 'protocols supported' TLV can be used inside the
 ] > SPF for a certain IP version (I assume that an IPv4/IPv6
 ] > router will need to run 2 SPFs, one for IPv4 and one for
 ] > IPv6) to determine whether ot not to take the related LSP
 ] > into account.
 ] >
 ] > This mechanism will work fine as long as an IPv4/IPv6
 ] > capable router can forward both IPv4 and IPv6 traffic
 ] > on all its interfaces. Because of the 'node level' nature
 ] > of the 'protocols supported' TLV, it is not possible
 ] > to perform a correct calculation with IPv4/IPv6 routers
 ] > which have a mixture of IPv4-only and IPv6-only interfaces.
 ] > This can be shown easily with an example:
 ] >
 ] >                 +----+
 ] >                 | R1 | IPv4/IPv6
 ] >                 +----+
 ] >                    |
 ] >                    | IPv6 capable link (1)
 ] >                    |
 ] >                    |
 ] >                 +----+
 ] >                 | R2 | IPv4/IPv6
 ] >                 +----+
 ] >                    |
 ] >                    | IPv4-only capable link (2)
 ] >                    |
 ] >                    |
 ] >                 +----+
 ] >                 | R3 | IPv4/IPv6
 ] >                 +----+
 ] >                    |
 ] >                    | IPv6 capable link (3)
 ] >                    |
 ] >                    |
 ] >                 +----+
 ] >                 | R4 | IPv4/IPv6
 ] >                 +----+
 ] >                   |
 ] >                   x
 ] >
 ] > R1, R2, R3 and R4 are IPv4/IPv6 capable routers. Links (1) and
 ] > (3) can forward IPv6 packets, link (2) can only forward IPv4
 ] > traffic. x is an IPv6 network address.
 ] >
 ] > Suppose R1 is calculating a route to IPv6 network x. Because
 ] > of the fact that R2 and R3 are both generating an LSP which
 ] > indicates they are IPv6 capable, the resulting route to x will
 ] > be via R2 and R3. Although, the link (2) between R2 and R3 is
 ] > not capable of forwarding IPv6 traffic.
 ] >
 ] > I went back to RFC 1195 1.4 'Support of Mixed Routing Domains',
 ] > because here similar problems occur. From what I understand
 ] > from this text, is that a dual router here can both forward
 ] > CLNS and IP on all its interfaces, although it is not specifically
 ] > stated.
 ] >
 ] > In case we take this rule also for IPv4/IPv6 capable routers
 ] > (all interfaces are IPv4/IPv6 capable), there is of course no
 ] > problem. On the other hand, during the transition of IPv4
 ] > to IPv6 I can image a lot of routers which will have a
 ] > mixture of IPv4-only and IPv6-only interfaces.
 ] >
 ] > As a solution for this problem we were considering of announcing
 ] > in every IS-reachablity TLV via a sub-TLV the capability of
 ] > that specific interface (again via 'protocols supported')?
 ] > This can be picked up in the SPF to decide whether or not
 ] > take that link into account for a certain IP version.
 ] >
 ] >
 ] > All suggestions/remarks/corrections are welcome.
 ] >
 ] > Thanks,
 ] > Koen _______________________________________________ Isis-wg mailing
 ] > list - [email-masked]
 ] > http://spider.juniper.net/mailman/listinfo/isis-wg
 ] 

- Naiming
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg