Subject: [Isis-wg] RE: About the IS Adjacency Area Address Table

From: Jeff Parker <[email-masked]>
Date: Mon, 25 Mar 2002 18:55:41 -0500

> Jeff
> 
> I also came up with the same situation with the
> isisISAdjProtSuppTable we could make all the 
> tables under adjacency consistent
> by putting the isisISAdjIndex  

Done

> and an index on the entry we are walking
> 
> Padma

I understand the problems in walking complex types 
like the new IP address or an OSI address.  But
help me understand why we need an index to walk
a scalar.  Isn't this something that GetNext papers
over for us?

- jeff parker
 
     isisISAdjProtSuppEntry OBJECT-TYPE
         SYNTAX IsisISAdjProtSuppEntry
         MAX-ACCESS not-accessible
         STATUS current
         DESCRIPTION
             "Each entry contains one protocol supported by a
             neighboring Intermediate System as reported in its IIH
             PDUs."
         INDEX {  isisSysInstance,
             isisCircIndex,
             isisISAdjIndex,
             isisISAdjProtSuppProtocol }
     ::= { isisISAdjProtSuppTable 1 }

     IsisISAdjProtSuppEntry ::=
         SEQUENCE {
             isisISAdjProtSuppProtocol
                 SupportedProtocol
         }

     isisISAdjProtSuppProtocol OBJECT-TYPE
         SYNTAX SupportedProtocol
         MAX-ACCESS read-only
         STATUS current
         DESCRIPTION
             "One supported protocol as reported in IIH PDUs received
             from the neighbor."
     ::= { isisISAdjProtSuppEntry 1 }
--
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Padma Pillay-Esnault <[email-masked]>
Date: Mon, 25 Mar 2002 16:16:58 -0800

> a scalar.  Isn't this something that GetNext papers

I was thinking of a list built from the tlv which is not
necessarily ordered . Then it is easier to to code a
lookup on an index than  run thru the list to find the
next entry based on the value ...
I guess I could do that differently.

May be I am uniformizing too much ;-)

Padma