Subject: [Isis-wg] confusion regarding IP summarization

From: Aravind Ravikumar <[email-masked]>
Date: Tue, 26 Mar 2002 23:11:35 -0800 (PST)

Hi, All

I am not  clear about, what other information 
should be included in IP reachability 
field of level 2 LSP by a L1L2 IS, apart from IP addresses 
which are directly reachable via its own interfaces.

Is it required to advertise ALL IP networks that are learned 
from other system's L1 LSP's IP reachability entries?

 or 

is it enough if the IS  advetises(in its level2 LSP) ,only those networks 
which it considers reachable after the level1 SPF?

Thanks in advance
Aravind

---------------------------------
Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®

---

From: Tony Li <[email-masked]>
Date: Wed, 27 Mar 2002 00:02:17 -0800

| I am not  clear about, what other information 
 | should be included in IP reachability 
 | field of level 2 LSP by a L1L2 IS, apart from IP addresses 
 | which are directly reachable via its own interfaces.
 | 
 | Is it required to advertise ALL IP networks that are learned 
 | from other system's L1 LSP's IP reachability entries?
 | 
 |  or 
 | 
 | is it enough if the IS  advetises(in its level2 LSP) ,only those networks 
 | which it considers reachable after the level1 SPF?

My interpretation is that the L2 is only required to include all of its
local prefixes.  Additional route injection is an implementation decision.

Tony
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: "Rajesh Saluja"<[email-masked]>
Date: Wed, 27 Mar 2002 09:57:26 -0500

> which it considers reachable after the level1 SPF?

I think you should advertise the configured summary addresses and then
go through the networks reachable after the level1 SPF and if the
network is not covered by the summary address, you should advertise that
network as well.

Thanks,
Rajesh

>
>
>
> Thanks in advance
> Aravind
>
>
> -----------------------------------------------------------------------
> Do You Yahoo!?

--

-------------------------------------------------------------
Rajesh Saluja
Nortel Networks Inc 600 Technology Park Billerica, MA  01821
Ph: (978) 288-7791      Fax: (978) 670-8760
--------------------------------------------------------------

---

From: stefano previdi <[email-masked]>
Date: Wed, 27 Mar 2002 16:21:25 +0100

> network is not covered by the summary address, you should advertise that

I would suggest to advertise summary addresses only if you have 
more specific routes.

s.

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 27 Mar 2002 05:27:45 -0800

> network is not covered by the summary address, you should advertise that

Rajesh,

that's implementation advice which is ok to discuss on the list IMHO with big
disclaimers disclosing it as such and preferrably declining any liability ;-)

Now, giving questionable or wrong implementaiton advice as I think you're
doing here ;-) can be taken as sign of naivite or as subtle influence ...
This kind of stretches my judgement capability as of whether it's ok or not
since it has been done by major players within IETF as well ;-)

    thanks

    -- tony