Subject: [Isis-wg] Partition Designated L2 IS Election Problem

From: "zhijian qin" <[email-masked]>
Date: Thu, 14 Mar 2002 16:44:21 -0800

Hi,

I am a new guy on ISIS. When I was testing the Partition Repair Option, I
create 2 areas, the first area has 6 routers while the second area has 2
routers.

Area Addresses:
Area1        aa01
Area2        aa02

NSAPs:
R1            aa01000000000001
R2            aa01000000000002
R3            aa01000000000003
R4            aa01000000000004
R5            aa01000000000005
R6            aa01000000000006

R7            aa02000000000007
R8            aa02000000000008

Network Topology:

                _____
_____
                |          |
|          |
                |   R7
  | -----------------------------------------------------------|  R8   |
                |_____|
|_____|
                    |
|
                    |
|
                __|___
__|___
                |          |
|          |
                |   R3   |
|  R4   |
                |_____|
|_____|
                /        \
/           \
              /            \
/               \
            /                \
   /                 \
       __|___        __|___
__|___        __|___
      |          |        |          |
|          |        |          |
      |   R1   |-----|  R2
|-----------------------------------------------|   R6  |------|  R5   |
      |_____|        |_____|
|_____|        |_____|

(All links are point-to-point links).

I brought up all routers as L1L2 IS with partion repair capability (I am not
sure if I can do that).  Then I cut the connection between R2 and R6,
R1/R2/R3 became a partition of area1 and R4/R5/R6 became another partion.

Because every router in area1 can reach area2 directly or indirectly, every
router in area1 claims itself as attached. So based the "Election of
partition designated level 2 IS" (ISO10589 7.2.10.2), the Partition
designated IS for the partition is R1 which has the lowest ID, while the the
partion designated IS for the second partion is R4. R1 and R4 treat each
other as a virtual adjacency. Each Non-Partition-Designated Routers
(R2/R3/R5/R6) use the partition designated router as the next hop when they
want to reach the routers in another partiton.

The problem is R1, which is the partition designated router of the first
partion, use the R3 as the next hop for destination R4, then I got a route
loop, when R2 wants to talk to R4, R2 selects R1 as the next hop, then R3,
then R1 again, then R3 again,........... i am dead.

I did go though the ISO 10589 couple of times for help without any luck, but
I still don't believe the protocol itself has something wrong, so could any
experts out there can tell me what is wrong with my test envirionment or the
software stack I am using might be the bad guy?

Thanks a lot in advance,

Jackie Qin

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Les Ginsberg <[email-masked]>
Date: Thu, 14 Mar 2002 20:53:24 -0800

Defects in the route preference algorithm in the presence of virtual links
as defined by ISO 10589:1992 were identified a few years ago. The changes
were incorporated into ISO 10589:2001. I recommend you consult that to
resolve your dilemma. Pay particular attention to the changes in Section
7.2.10 and 7.4.3. 

ftp.cisco.com/pub/rfc/ISO/ISO10589v2-2001-07-04.pdf

   Les

> -----Original Message-----
> From: zhijian qin [mailto:[email-masked]]
> Sent: Thursday, March 14, 2002 4:44 PM
> To: [email-masked]
> Subject: [Isis-wg] Partition Designated L2 IS Election Problem
> 
> 
> Hi,
> 
> -----------------------------------------------------------|  R8   |
>                 |_____|
> |_____|
>                     |
> |
>                     |
> |
>                 __|___
> __|___
>                 |          |
> |          |
>                 |   R3   |
> |  R4   |
>                 |_____|
> |_____|
>                 /        \
> /           \
>               /            \
> /               \
>             /                \
>    /                 \
>        __|___        __|___
> __|___        __|___
>       |          |        |          |
> |          |        |          |
>       |   R1   |-----|  R2