Subject: [Isis-wg] Extended IP Reachability question

From: "Ravindra Sunkad" <[email-masked]>
Date: Thu, 14 Mar 2002 11:10:44 -0800

Hi,

In the following threads there is some talk about defining a sub-tlv for
the Extended IP Reachability TLV that could be used to differentiate
external route advertisements from internal route advertisements. Has
any work been done on this front?

http://spider.juniper.net/pipermail/isis-wg/1999/thread.html#31

[Isis-wg] IS-IS Extensions for Traffic Engineering

[Isis-wg] draft-ietf-isis-traffic-01.txt 

Thanks,

Ravi

---

From: "Martin, Christian" <[email-masked]>
Date: Mon, 18 Mar 2002 16:27:16 -0500

See
http://search.ietf.org/internet-drafts/draft-martin-neal-policy-isis-admin-t
ags-04.txt for this type of information.  How the vendor implements the
policy is up to the vendor, but matching internal vs external and tagging
shouldn't be an issue during LSP creation.

chris

-----Original Message-----
From: Ravindra Sunkad [mailto:[email-masked]]
Sent: Monday, March 18, 2002 1:10 PM
To: [email-masked]
Subject: RE: [Isis-wg] Extended IP Reachability question

I haven't seen any responses in regards to the following thread. So, I'm
assuming that no such sub-tlv has been defined so far.
I propose a color/tag sub-tlv for the Extended IP Reachability TLV. This
will be similar to the "Administrative group" sub-tlv defined 
for the Extended IS Reachability TLV. It contains a 4-octet bit mask. The
least significant bit is defined to indicate whether the IP prefix
is outside the IS-IS routing domain.
 
Please provide me your inputs.
 
Thanks,
Ravi
 
-----Original Message-----
From: Ravindra Sunkad 
Sent: Thursday, March 14, 2002 11:11 AM
To: [email-masked]
Subject: [Isis-wg] Extended IP Reachability question

Hi,
 
In the following threads there is some talk about defining a sub-tlv for the
Extended IP Reachability TLV that could be used to differentiate external
route advertisements from internal route advertisements. Has any work been
done on this front?

 
Thanks,
Ravi
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: "Ravindra Sunkad" <[email-masked]>
Date: Mon, 18 Mar 2002 14:15:53 -0800

Chris,

Thanks. This could work. But it would be good if everybody automatically
originates a predefined sub-tlv tagging prefixes as external. i.e. I
prefer this sub-tlv not be administrative.

Ravi

> From: Martin, Christian [mailto:[email-masked]] 
> Sent: Monday, March 18, 2002 1:27 PM
> To: Ravindra Sunkad; [email-masked]
> ags-04.txt for this type of information.  How the vendor 
> implements the policy is up to the vendor, but matching 
> internal vs external and tagging shouldn't be an issue during 
> LSP creation.
> 
> chris
> 
> 
> 
> I haven't seen any responses in regards to the following 
> thread. So, I'm assuming that no such sub-tlv has been 
> defined so far. I propose a color/tag sub-tlv for the 
> Extended IP Reachability TLV. This will be similar to the 
> "Administrative group" sub-tlv defined 
> for the Extended IS Reachability TLV. It contains a 4-octet 
> bit mask. The least significant bit is defined to indicate 
> whether the IP prefix is outside the IS-IS routing domain.
>  
> In the following threads there is some talk about defining a 
> sub-tlv for the Extended IP Reachability TLV that could be 
> used to differentiate external route advertisements from 
> internal route advertisements. Has any work been done on this front?
>  

Thanks,
Ravi

---

From: "Ravindra Sunkad" <[email-masked]>
Date: Mon, 18 Mar 2002 19:05:26 -0800

Perhaps there is no application in the real world that needs to
differentiate IS-IS internal routes from externals.
I was not sure if this was dropped purposefully from the isis-traffic
draft or dropped because it was not in the scope of the document as one
of the archived postings suggested. Since this is a shift from RFC-1195
is it worth mentioning the rationale in the traffic-eng draft?

Thanks for your responses.

Ravi

> From: Tony Li [mailto:[email-masked]] 
> Sent: Monday, March 18, 2002 4:38 PM
> To: Ravindra Sunkad
> Cc: Tony Li; [email-masked]
>  | When IS-IS routes are redistributed to other protocols 
> this piece of  | information can be useful and could serve as 
> an additional filter. Also,  | we might want to create LDP 
> LSPs only for internal prefixes.
> 
> 
> I believe that over the history of the Internet, it has been 
> shown to be generally a catastrophic event to ever put any 
> external prefixes into your IGP.  It seems an error to encourage that.
> 
> Similarly, unconstrained redistribution of prefixes from your 
> IGP into BGP can also result in unwanted exposure of your 
> internal topology to the outside world.
> 
> Thus, it would seem to me that the primary mechanism to 
> filtering routes redistributed into and out of IS-IS should 
> be a manually configured prefix filter.  Given that this 
> exists (if redistribution is even necessary -- which I begin 
> to doubt), I fail to see the overwhelming need for this 
> additional bit of data.
> 
> So again, why do we need this?
> 
> Tony
>

---

From: Jeff Learman <[email-masked]>
Date: Tue, 19 Mar 2002 13:32:19 -0500

>is it worth mentioning the rationale in the traffic-eng draft?

This sounds like be a good idea, because this question seems to pop up
with annoying regularity.