Subject: RE: [Isis-wg] Extended IP Reachability question

From: "Ravindra Sunkad" <[email-masked]>
Date: Mon, 18 Mar 2002 10:09:41 -0800

I haven't seen any responses in regards to the following thread. So, I'm
assuming that no such sub-tlv has been defined so far.
I propose a color/tag sub-tlv for the Extended IP Reachability TLV. This
will be similar to the "Administrative group" sub-tlv defined 
for the Extended IS Reachability TLV. It contains a 4-octet bit mask.
The least significant bit is defined to indicate whether the IP prefix
is outside the IS-IS routing domain.
 
Please provide me your inputs.
 
Thanks,
Ravi
 
-----Original Message-----
From: Ravindra Sunkad 
Sent: Thursday, March 14, 2002 11:11 AM
To: [email-masked]
Subject: [Isis-wg] Extended IP Reachability question

	Hi,

	In the following threads there is some talk about defining a
sub-tlv for the Extended IP Reachability TLV that could be used to
differentiate external route advertisements from internal route
advertisements. Has any work been done on this front?

	http://spider.juniper.net/pipermail/isis-wg/1999/thread.html#31

	[Isis-wg] IS-IS Extensions for Traffic Engineering

	[Isis-wg] draft-ietf-isis-traffic-01.txt 

	Thanks,

	Ravi

---

From: Tony Li <[email-masked]>
Date: Mon, 18 Mar 2002 13:03:05 -0800

Why?

Tony

Ravindra Sunkad writes:
 | I haven't seen any responses in regards to the following thread. So, I'm
 | assuming that no such sub-tlv has been defined so far.
 | I propose a color/tag sub-tlv for the Extended IP Reachability TLV. This
 | will be similar to the "Administrative group" sub-tlv defined 
 | for the Extended IS Reachability TLV. It contains a 4-octet bit mask.
 | The least significant bit is defined to indicate whether the IP prefix
 | is outside the IS-IS routing domain.
 |  
 | Please provide me your inputs.
 |  
 | Thanks,
 | Ravi
 |  
 | -----Original Message-----
 | From: Ravindra Sunkad 
 | Sent: Thursday, March 14, 2002 11:11 AM
 | To: [email-masked]
 | Subject: [Isis-wg] Extended IP Reachability question
 | 
 | 
 | 
 | 	Hi,
 | 
 | 	 
 | 
 | 	In the following threads there is some talk about defining a
 | sub-tlv for the Extended IP Reachability TLV that could be used to
 | differentiate external route advertisements from internal route
 | advertisements. Has any work been done on this front?
 | 
 | 	 
 | 
 | 	http://spider.juniper.net/pipermail/isis-wg/1999/thread.html#31
 | 
 | 	 
 | 
 | 	[Isis-wg] IS-IS Extensions for Traffic Engineering
 | 
 | 	[Isis-wg] draft-ietf-isis-traffic-01.txt 
 | 
 | 	 
 | 
 | 	Thanks,
 | 
 | 	Ravi
 | 
 | <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
 | <HTML><HEAD><TITLE>Message</TITLE>
 | <META http-equiv=Content-Type content="text/html; charset=us-ascii">
 | <META content="MSHTML 5.50.4807.2300" name=GENERATOR>
 | <STYLE>@page Section1 {size: 8.5in 11.0in; margin: 1.0in 1.25in 1.0in 1.25in; }
 | P.MsoNormal {
 | 	FONT-SIZE: 12pt; MARGIN: 0in 0in 0pt; FONT-FAMILY: "Times New Roman"
 | }
 | LI.MsoNormal {
 | 	FONT-SIZE: 12pt; MARGIN: 0in 0in 0pt; FONT-FAMILY: "Times New Roman"
 | }
 | DIV.MsoNormal {
 | 	FONT-SIZE: 12pt; MARGIN: 0in 0in 0pt; FONT-FAMILY: "Times New Roman"
 | }
 | A:link {
 | 	COLOR: blue; TEXT-DECORATION: underline
 | }
 | SPAN.MsoHyperlink {
 | 	COLOR: blue; TEXT-DECORATION: underline
 | }
 | A:visited {
 | 	COLOR: purple; TEXT-DECORATION: underline
 | }
 | SPAN.MsoHyperlinkFollowed {
 | 	COLOR: purple; TEXT-DECORATION: underline
 | }
 | SPAN.EmailStyle17 {
 | 	COLOR: windowtext; FONT-FAMILY: Arial
 | }
 | DIV.Section1 {
 | 	page: Section1
 | }
 | </STYLE>
 | </HEAD>
 | <BODY lang=EN-US vLink=purple link=blue>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN class=890335817-18032002>I 
 | haven't seen any responses in regards to the following thread. So, I'm assuming 
 | that no such sub-tlv has been defined so far.</SPAN></FONT></DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN class=890335817-18032002>I 
 | propose a color/tag sub-tlv for the Extended IP Reachability TLV.&nbsp;This will 
 | be similar to the "Administrative group" sub-tlv defined </SPAN></FONT></DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN class=890335817-18032002>for 
 | the Extended IS Reachability TLV. It contains a 4-octet bit mask. The least 
 | significant bit is defined to&nbsp;indicate whether the IP 
 | prefix</SPAN></FONT></DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN class=890335817-18032002>is 
 | outside the IS-IS routing domain.</SPAN></FONT></DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN 
 | class=890335817-18032002></SPAN></FONT>&nbsp;</DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN class=890335817-18032002>Please 
 | provide me your inputs.</SPAN></FONT></DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN 
 | class=890335817-18032002></SPAN></FONT>&nbsp;</DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN 
 | class=890335817-18032002>Thanks,</SPAN></FONT></DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN 
 | class=890335817-18032002>Ravi</SPAN></FONT></DIV>
 | <DIV><FONT face=Arial color=#0000ff size=2><SPAN 
 | class=890335817-18032002></SPAN></FONT>&nbsp;</DIV>
 | <DIV><FONT face=Tahoma size=2>-----Original Message-----<BR><B>From:</B> 
 | Ravindra Sunkad <BR><B>Sent:</B> Thursday, March 14, 2002 11:11 AM<BR><B>To:</B> 
 | [email-masked]<BR><B>Subject:</B> [Isis-wg] Extended IP Reachability 
 | question<BR><BR></FONT></DIV>
 | <BLOCKQUOTE dir=ltr 
 | style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px">
 |   <DIV class=Section1>
 |   <P class=MsoNormal><FONT face="Courier New" size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'">Hi,</SPAN></FONT></P>
 |   <P class=MsoNormal><FONT face="Courier New" size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'"></SPAN></FONT>&nbsp;</P>
 |   <P class=MsoNormal><FONT face="Courier New" size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'">In the following threads 
 |   there is some talk about defining a sub-tlv for the Extended IP Reachability 
 |   TLV that could be used to differentiate external route advertisements from 
 |   internal route advertisements. Has any work been done on this 
 |   front?</SPAN></FONT></P>
 |   <P class=MsoNormal><FONT face="Courier New" size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'"></SPAN></FONT>&nbsp;</P>
 |   <P class=MsoNormal><FONT face="Courier New" size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'"><A 
 |   href="http://spider.juniper.net/pipermail/isis-wg/1999/thread.html#31">http://spider.juniper.net/pipermail/isis-wg/1999/thread.html#31</A></SPAN></FONT></P>
 |   <P class=MsoNormal><FONT face="Courier New" size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'"></SPAN></FONT>&nbsp;</P>
 |   <P class=MsoNormal><FONT face="Courier New" size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'">[Isis-wg] IS-IS Extensions 
 |   for Traffic Engineering</SPAN></FONT></P>
 |   <P class=MsoNormal><FONT face="Courier New" size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: 'Courier New'">[Isis-wg] 
 |   draft-ietf-isis-traffic-01.txt </SPAN></FONT></P>
 |   <P class=MsoNormal><FONT face=Arial size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: Arial"></SPAN></FONT>&nbsp;</P>
 |   <P class=MsoNormal><FONT face=Arial size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Thanks,</SPAN></FONT></P>
 |   <P class=MsoNormal><FONT face=Arial size=2><SPAN 
 |   style="FONT-SIZE: 10pt; FONT-FAMILY: Arial">Ravi</SPAN></FONT></P></DIV></BLOCKQUOTE></BODY></HTML>
 | 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg