Subject: [Isis-wg] IS Adjacency table

From: "Ramalingam, Swaminathan" <[email-masked]>
Date: Fri, 15 Mar 2002 02:32:09 -0500

Hi Jeff,

Some suggestion on IS Adjacency Table

	In draft-ietf-isis-wg-mib-07.txt IS Adj table, there is no object
conveying the message what "type" of adjacency is that (either Level1 or
Level2), when isisISAdjUsage is "Level1and2" ? . It has to convey whether it
is "Level 1" or "Level 2"

i.e there can be another object before isisISAdjUsage like:

	isisISAdjType OBJECT-TYPE
         SYNTAX INTEGER {
             level1(1),
             level2(2),
             }
         MAX-ACCESS read-only
         STATUS current
         DESCRIPTION
             "An adjacency of type level1 is used for level 1
              traffic only. An adjacency of type level2 is used
              for level 2 traffic only. If this neighbor have 
		  another adjacency (at another level L1 or L2), 
		  then isisISAdjUsage should be 'levelland2'else
		  it should be same as at this level"
		  
         REFERENCE "{ISIS.aoi adjacencyUsage (82)}"
     ::= { isisISAdjEntry 6 }

Thanks,
Swami
         
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: "Ramalingam, Swaminathan" <[email-masked]>
Date: Fri, 15 Mar 2002 04:10:08 -0500

Also description for isisISAdjNeighPriority reads like:

isisISAdjNeighPriority OBJECT-TYPE
         SYNTAX ISPriority
         MAX-ACCESS read-only
         STATUS current
         DESCRIPTION
             "Priority of the neighboring Intermediate System for
             becoming the LAN Level 1 Designated Intermediate System
             if the value of isisISAdjNeighSysType is
             L1IntermediateSystem or LAN Level 2 Designated
             Intermediate System if the value of
             isisISAdjNeighSysType is L2IntermediateSystem."
         REFERENCE "{ISIS.aoi lANPriority (86)}"
     ::= { isisISAdjEntry 8 }

what it mean when isisISAdjNeighSysType is "l1l2IntermediateSystem"?. I
guess, it should be changed as 

         DESCRIPTION
             "Priority of the neighboring Intermediate System for
             becoming the LAN Level 1 Designated Intermediate System
             if the value of *isisISAdjType* is
             'Level1' or LAN Level 2 Designated
             Intermediate System if the value of
             *isisISAdjType* is 'level2'."

isisISAdjType is new suggested object in my previous mail..

Thanks,
Swami

-----Original Message-----
From: Ramalingam, Swaminathan 
Sent: Friday, March 15, 2002 1:02 PM
To: 'Jeff Parker'
Cc: [email-masked]'
Subject: IS Adjacency table 

Hi Jeff,

		  

Thanks,
Swami

---

From: Jeff Parker <[email-masked]>
Date: Mon, 25 Mar 2002 17:50:34 -0500

> what it mean when isisISAdjNeighSysType is 
> "l1l2IntermediateSystem"?.  

You are right.  It is confusing.  It is only relevant on a LAN,
where there will be an adjacency per level.  It may be simplest
to simplest to say

     isisISAdjNeighPriority OBJECT-TYPE
         SYNTAX ISPriority
         MAX-ACCESS read-only
         STATUS current
         DESCRIPTION
             "Priority of the neighboring Intermediate System for
             becoming the Designated Intermediate System."
         REFERENCE "{ISIS.aoi lANPriority (86)}"
     ::= { isisISAdjEntry 8 }

> Level2) 

I believe that the isisISAdjUsage variable conveys this information.

- jeff parker

---

From: "Ramalingam, Swaminathan" <[email-masked]>
Date: Tue, 26 Mar 2002 00:15:45 -0500

See Inline

> From: Jeff Parker [mailto:[email-masked]]
> Sent: Tuesday, March 26, 2002 4:21 AM
> To: 'Ramalingam, Swaminathan'
> Subject: RE: [Isis-wg] RE: IS Adjacency table
> 
> 
>  

This is true for Point-to-Point. But in broadcast network, We create two
adjacencies Level 1 and Level 2 separtely even the IS is configured as "L2
IS with manualL2Only false" i.e L1L2. 
In Sec 8.4.2 of ISO 10589, last paragraph reads like:

 "Level 2 Intermediate Systems (with manualL2onlyMode "False") shall perform
both of the above actions.Separate Level 1 and Level 2 LAN IIH PDUs shall be
sent to the multi-destination addresses AllL1ISs and AllL2ISs describing the
neighbor Intermediate systems for Level 1 and Level 2 respectively.Separate
Adjacencies shall be created by the receipt of Level 1 and Level 2 LAN IIH
PDUs".

It means even the IS is configured for L1L2, we create two Adjacencies with
"neighbourSystemType" with L1 and L2 separately. My Point is there is no
adjacencyUsage called "L1L2" in BROADCAST NETWORK. So any two "L1L2IS"  will
have 2 Adjacency separately for Level 1 & 2 respectively (as there are two
different hellos)

Also whenever we receive L1 IIH or L2 IIH, we need to set the
neighbourSystemType to 'L1 IS' or 'L2 IS' as per sec 8.4.2.2 & 8.4.2.3. It
will be easy to implement when one create two separate adjacency with L1 and
L2 as "Adjacency Type". 

Let me know if we are not in sync..

---

From: Jeff Parker <[email-masked]>
Date: Tue, 26 Mar 2002 09:42:01 -0500

We are not in sync.  

There are two variables for each adjacency: what the type 
(l1, l2, both) the other IS is, and how the adj is being 
used (l1 or l2 on LAN, one of l1, l2, or both on p2p).  

I think we have everything you need.  Perhaps you could
explain again what you need.

- jeff parker

---

From: "Ramalingam, Swaminathan" <[email-masked]>
Date: Tue, 26 Mar 2002 10:18:25 -0500

> Sent: Tuesday, March 26, 2002 8:12 PM

Yes.There can be *either* l1 or l2 on LAN. This is the one I need. I was
assuming that you meant for LAN, Usage can be l1, l2 or both. All the
confusion came to me when usage is "both"  in a broadcast network.

Thanks for the clarification.

-- Swaminathan

---

From: "Ramalingam, Swaminathan" <[email-masked]>
Date: Wed, 27 Mar 2002 00:46:54 -0500

> used (l1 or l2 on LAN, one of l1, l2, or both on p2p). 

I have a doubt when I look in to Circ Level Table Indices. It has only
'level1IS' and 'level2IS'. If we have l1l2 adjacency (in p2p), we need
l1l2IS Level Index, right?.

Pl. Clarify

Thanks,
~ Swaminathan