Subject: [Isis-wg] IS-IS metrics: in search for a sound way

From: "Nikos Leontsinis" <[email-masked]>
Date: Mon, 11 Mar 2002 22:09:47 +0000

ISO 10589 states in 7.2.2. that the following 4 isis metrics are defined:

1.Default: Each link is given a metric value based on its throughput
2.Delay metric . It measures the transit delay of the circuit. (pretty common-sensical higher value longer delay)
3. Expense metric. It measures the monetary cost of the network's utilsation-higher value larger expense-.(very unclear to me how this is done)

4 Error metric.It measures the residual (êáôÜëïéðï, õðüëïéðï) error probability of the asociated circuit (also unclear but makes sense as a concept).

If you look at the IS-IS  LSP format's analysis i.e. p.638 Doyle, Routing TCP/IP Volume1 you will see that IOS supports
only the default metric (bit 4) Bits 5-7  which are delay, expense & error are not supported and they will always be zero.
This is a major IOS caveat as bandwidth alone is by no means sufficient to account for metric assignment.
However, looking at the LSP format is not the only way to reach the above conclusion.
These 3 factors would be brought into consideration on a discussion on how to tune isis metrics by someone
who was building his/her argumentation on pure operational experience.
The main objective behind metric tuning is network performance improvement. Performance is an umbrella
which incorporates the configuration and measurement of distinct areas. It is not clear to me how the ietf engineers
calculate delay, expense and error as part of their (non Cisco supported) isis impl!
ementation. What it is indubitable is that
availability, response time, accuracy and utilisation will be key indicators for the performance of a network and these are the
ones that should also be added as key decision parameters in the metric assignment process.

In conclusion, I am looking for a good way to measeure metrics either based on bandwidth or geographical distance eventhough I don't think there is one formula which can be used as a panacea. My feeling is that this is a context based approach. One can come to an agreement on what issues to consider but the
decision should be taken on the individual links rather than make it matter of correct application of a specific formula.
For a more detailed analysis on these 4 areas of performance: availability, response time, accuracy and utilisation see
Performance and Fault Management  Della Magiora, et al p.74-85.

Best,

Nikos Leontsinis

Join the world’s largest e-mail service with MSN Hotmail. Click Here

_______________________________________________
Isis-wg mailing list - [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: [email-masked]
Date: Tue, 12 Mar 2002 10:33:16 -0600

Although ISO 10589 defines four different metric fields, I believe the
decision process still uses a single scalar metric because IS-IS combines
the four fields by simple addition paragraph 7.2.2, note 13.  It's up to the
network operator to weight these fields according to his own requirements.  

Point is, you can accomplish pretty much the same thing with a single
field--just define which link properties are important to you, weight them
according to their relative importance, add up the values and the result is
your combined metric, just like IS-IS would have done.

 +++The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential and/or privileged
material.  Any review, retransmission, dissemination or other use of, or
taking of any action in reliance upon, this information by persons or
entities other than the intended recipient is prohibited.   If you received
this in error, please contact the sender and destroy any copies of this
document.+++
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: "Nikos Leontsinis" <[email-masked]>
Date: Tue, 12 Mar 2002 23:47:55 +0000

No the network operator can only ammend the default cisco metric which is bandwith. The remaining metrics are not supported hence cannot be used what they rather do is to give a hint to the network administrator what to bear in mind when designing his/her network. I was looking for something more coherent  than that as I think metric assinment is by far the most challenging task for the network designer since Cisco together with the remaining implemeters are fairly inefficient in this direction. I am looking for a sound way to measure metrics.

document.+++

---

From: [email-masked]
Date: Tue, 12 Mar 2002 18:53:22 -0600

My point is that even if a platform lets you set all four metrics, the SPF
computation, as defined by 10589, just adds them up and uses the sum as a
single metric. I can only assume that the reason they are broken out
separately is for conceptual convenience. (?)
 
A human being can do this just as easily when a platform only supports a
single metric, or when using the new-style TLVs that only define one metric.
The only real difference is that the actual values of the individual link
properties are not reflected in the router's configuration state.
 
As far as a generalized metric-selection schema, I don't think there really
is one.  How I, as a network operator, assign link metrics will depend on
what link properties are interesting to me in my particular situation.  For
instance, if I can provision bandwidth quickly and have sufficient
confidence in my trending and planning efforts, bandwidth isn't interesting
to me as an IGP decision input.  Delay might be, though, if I have a network
of large geographic scope.  If I run a regional or metropolitan network, my
requirements may be quite different and I would define my metrics
accordingly.  

 -----Original Message-----
From: Nikos Leontsinis [mailto:[email-masked]]
Sent: Tuesday, March 12, 2002 5:48 PM
To: Neal, Brad (Broadwing); [email-masked]
Subject: RE: [Isis-wg] IS-IS metrics: in search for a sound way

No the network operator can only ammend the default cisco metric which is
bandwith. The remaining metrics are not supported hence cannot be used what
they rather do is to give a hint to the network administrator what to bear
in mind when designing his/her network. I was looking for something more
coherent  than that as I think metric assinment is by far the most
challenging task for the network designer since Cisco together with the
remaining implemeters are fairly inefficient in this direction. I am looking
for a sound way to measure metrics.

   _____  

Join the world's largest e-mail service with MSN Hotmail. Click
<http://g.msn.com/1HM300901/1W> Here

---

From: "Nikos Leontsinis" <[email-masked]>
Date: Wed, 13 Mar 2002 06:34:52 +0000

There must be some documentation about the metric assignment process we just don't know it. This is a topic for a book it should be written for the 3 main routing protocols.

Best Regards,

Nikos Leontsinis

From: [email-masked]

To: [email-masked], [email-masked]

Date: Tue, 12 Mar 2002 18:53:22 -0600

MIME-Version: 1.0

Received: from [216.140.57.101] by hotmail.com (3.2) with ESMTP id MHotMailBE57EE23006F4004374ED88C396555F60; Tue, 12 Mar 2002 16:53:56 -0800

Received: by ausmx1.ixc-comm.com with Internet Mail Service (5.5.2653.19)id ; Tue, 12 Mar 2002 18:53:32 -0600

From [email-masked] Tue, 12 Mar 2002 16:55:15 -0800

Message-ID: <[email-masked]>

X-Mailer: Internet Mail Service (5.5.2653.19)

accordingly.

-----Original Message-----

document.+++

_____

Here

document.+++

Send and receive Hotmail on your mobile device: Click Here

---

From: "Martin, Christian" <[email-masked]>
Date: Thu, 14 Mar 2002 23:22:26 -0500

Nikos,

There is no "documentation", per se.  However, the Operations Research folks
have been studying these types of problems for 50 years.  They vary in
complexity, from a 3-node single metric IP network to a worldwide
dispatching system such as that employed by FedEx.  Network optimization
problems are HARD at a large scale.  In fact, some linear programming models
are so difficult to compute, that they cannot be solved using today's
computers.  An example would be finding the fastest way from one street
corner to another in Manhattan given known variables like signal frequency,
speed limits, number of lanes, and average traffic patterns.  The optimal
solution is not solvable.  But, approximations to the optimal solution are.

I believe Brad is trying to convey that there is no simple rule of thumb.
Your needs may be different from mine.  The tools and methods are the same,
however.

If you need a quick fix that takes lots into consideration, you can use
EIGRPs method as a starting point.  As you can infer, the goal of EIGRP is
to optimize a path given constraints.  Usually, IP networks AIM to minimize
delay and maximize bandwidth.  If you need some help working this out, a
colleague and I have derived a formula that works well for IS-IS/OSPF
costing that aims to minimze the delay to transmit one 1500 byte packet.  If
you need to minimize financial cost, then it gets tougher.

If you are interested, try www.citeseer.org and search for things like qos
routing, link costs, etc.  You will likely find more information than you'll
ever need!  For more information, try "Network Optimization" by Bertsekas
and any reasonable text on Operations Research.

Regards,
chris

-----Original Message-----
From: Nikos Leontsinis [mailto:[email-masked]] 
Sent: Wednesday, March 13, 2002 1:35 AM
To: [email-masked]; [email-masked]
Subject: RE: [Isis-wg] IS-IS metrics: in search for a sound way

There must be some documentation about the metric assignment process we just
don't know it. This is a topic for a book it should be written for the 3
main routing protocols.
Best Regards,
 Nikos Leontsinis
 
From: [email-masked] 
To: [email-masked], [email-masked] 
Subject: RE: [Isis-wg] IS-IS metrics: in search for a sound way 
Date: Tue, 12 Mar 2002 18:53:22 -0600 
MIME-Version: 1.0 
Received: from [216.140.57.101] by hotmail.com (3.2) with ESMTP id
MHotMailBE57EE23006F4004374ED88C396555F60; Tue, 12 Mar 2002 16:53:56 -0800 
Received: by ausmx1.ixc-comm.com with Internet Mail Service (5.5.2653.19)id
; Tue, 12 Mar 2002 18:53:32 -0600

---

From: Les Ginsberg <[email-masked]>
Date: Thu, 14 Mar 2002 21:01:14 -0800

> the four fields by simple addition paragraph 7.2.2, note 13.  

No - this is not the correct interpretation.
Separate forwarding databases must be generated for each supported metric
(see 10589:1992 C.2.4).

The note Neal is referring to (Note 9 in the 1992 edition/Note 13 in the
2001 edition) is talking about how cost for a path is calculated for a
particular type of metric - it is not meant to suggest that metrics of
different types should be added together.

   Les