Subject: RE: [Isis-wg] few doubts on LSP purging

From: Laura Liu <[email-masked]>
Date: Mon, 25 Mar 2002 18:42:22 -0600

Hi All,
 
To add another situation: router A has multiple LSP fragments of router B,
when router B made some changes, purged it LSPs and the new lsp can fit into
one pdu (lsp #0), router A need to purge the old lsp fragments (lsp #1 and
above), those lsp headers should be retained in the database for MaxAge.
 
Am I right?
 
thanks in advance!
 
Laura

-----Original Message----- 
From: Aravind Ravikumar [mailto:[email-masked]]
Sent: Monday, March 25, 2002 1:13 AM
To: [email-masked]
Subject: [Isis-wg] few doubts on LSP purging

Hi All,

ISO 10589 section 7.3.16.4 says when we purge an LSP with zero remaining 
life time we should retain the header in  the database for ZeroAgeLifetime
and  if we are purging because of any other reson we have to retain the 
header in the database for MaxAge.

Am I correct in assuming that the purging of old Designated IS's pseudoNode
LSP by the new Designated system and the purging of local pseudonode LSP 
when the system is resigning as designated system are two such situations,
where we are purging eventhough the remaining life time has not become zero?

My doubts are as follows:

1. What exactly is the purpose of retaining the header for MaxAge ?

2. What are the things for which we should'nt use such an aged out LSP
retained
   in our database and what are the things for which the LSP  can be used?

3. Can we include it in CSNPs?

4. Can we consider them while doing look up in the database (for eg: while
   trying to add entry into database) . If we do consider and if the IS 
   becomes Designated IS again, before the pseudoNode LSPs from the earlier
   stint as Designated IS are removed from the LS database 

   A. What should be done, with the header of the aged out pseudonode LSPs
       retained in the database?

   B.Should we take the sequence number of the aged out LSP into
consideration
      while generating the new pseudonode LSP?

Thanks in advance.

Aravind

  _____  

Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®

----------------------------------------- (on rchss001)

This e-mail and any files transmitted with it are the property
of Chiaro Networks, Ltd., and may contain confidential and 
privileged material for the sole use of the intended recipient(s)
to whom this e-mail is addressed. If you are not one of the named
recipient(s), or otherwise have reason to believe that you have 
received this message in error, please notify the sender and 
delete all copies from your system.  Any other use, retention, 
dissemination, forwarding, printing or copying of this e-mail is 
strictly prohibited.

---------------------------------------------------------

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 25 Mar 2002 14:58:03 -0800

Laura Liu wrote:

>  Hi All,To add another situation: router A has multiple LSP fragments of router B, when router
> B made some changes, purged it LSPs and the new lsp can fit into one pdu (lsp #0), router A
> need to purge the old lsp fragments (lsp #1 and above), those lsp headers should be retained
> in the database for MaxAge.
>
> you do not 'compact' fragments into a single fragment again.  That would make the semantics of
> information
> deletion/addition within fragments hard to track and would lead to extensive flapping of e.g.
> prefixes if you're
> unlucky.
>
>
> Each fragment is basically an independent entity when it comes to flooding and purging
>
>     thanks
>
>
>
>     -- tony

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Li <[email-masked]>
Date: Mon, 25 Mar 2002 21:17:59 -0800

| >  Hi All,To add another situation: router A has multiple LSP fragments of router B, when router
 | > B made some changes, purged it LSPs and the new lsp can fit into one pdu (lsp #0), router A
 | > need to purge the old lsp fragments (lsp #1 and above), those lsp headers should be retained
 | > in the database for MaxAge.
 | >
 | > you do not 'compact' fragments into a single fragment again.  That would make the semantics of
 | > information
 | > deletion/addition within fragments hard to track and would lead to extensive flapping of e.g.
 | > prefixes if you're
 | > unlucky.
 | >
 | >
 | > Each fragment is basically an independent entity when it comes to flooding and purging

Further....  if a IS does decide to regenerate its LSP, then it should
simply bump the sequence number and flood the new version.  The IS should
NEVER purge an LSP with just the intent of replacing it with another
subsequent verison.

Tony