Subject: RE: [Isis-wg] question on draft-ietf-isis-wg-multi-topology-03.tx t

From: "Martin, Christian" <[email-masked]>
Date: Wed, 15 May 2002 12:56:10 -0400

Was this TLV designed to identify a particular MT?  I suppose this may be
used by an implementation to indicate which MT a prefix belongs to, but it
must be consistent across the domain for it to be useful, which means, IMO,
that it should be identified _not_ by prefix, but by MT itself.  Unless I am
reading this incorrectly.

Otherwise, there appears to be some overlap between SubTLV 1 and 117 wrt a
prefix.

chris

>-----Original Message-----
>From: stefano previdi [mailto:[email-masked]] 
>Sent: Wednesday, May 15, 2002 11:18 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [Isis-wg] question on draft-ietf-isis-wg-multi-topology-03.txt
>
>
>Naiming,
>
>in draft-ietf-isis-wg-multi-topology-03.txt  I see:
>
>-------------------------------------------------------------------
>8.3.  Multi-Topology Reachable IPv4 Prefixes TLV
>
>    TLV number of this TLV is 235.  It is aligned with extended IS
>    reachability TLV type 135 beside an additional two bytes in front.
>
>         2 bytes of MT membership
>                  4 bits (most significant) are reserved
>                 12 least significant bits are the MT ID
>         0-251 octets of structures used in TLV type 135.
>
>    This TLV can occur multiple times.
>    A new sub-TLV for this MT Reachable IPv4 Prefixes TLV is proposed:
>
>         Sub-TLV type    117
>         Length          4 octets
>         Name            MT IPv4 Prefix Color
>
>         The value of 1 of this sub-TLV is reserved for MT Management
>         Prefix color.
>
>    If the MT Management Prefix color is present in this TLV, 
>a MT based
>    SPF computation MAY also need to install this prefix into the
>    ``standard'' or ``management'' RIB. This MAY be necessary for
>    example in the case of MT based network management.
>---------------------------------------------------------------------
>
>In draft-martin-neal-policy-isis-admin-tags we specified 
>admin tag sub-TLV for both TLV 135 and 235. Not sure about
>the real purpose of sub-TLV 117 but I believe we could just 
>reserve an admin tag value of 1 of for "MT Management".
>
>         
>
>
>
>
>s.
>
>
>_______________________________________________
>Isis-wg mailing list  -  [email-masked] 
>http://spider.juniper.net/mailman/listinfo/isis>-wg
>
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Wed, 15 May 2002 12:14:53 -0700

Stefano and Christian,

 ] Was this TLV designed to identify a particular MT?  I suppose this may be
 ] used by an implementation to indicate which MT a prefix belongs to, but it
 ] must be consistent across the domain for it to be useful, which means, IMO,
 ] that it should be identified _not_ by prefix, but by MT itself.  Unless I am
 ] reading this incorrectly.

this should be per prefix based. imagine the network consists of multiple
topologies using M-ISIS, and router connected to the management LAN
may not be in all those topologies. this particular tlv 117 value of 1
indicate the option of installing this prefix into the "normal" unicast
RIB, so the management traffic has a path to reach those routers.

 ] 
 ] Otherwise, there appears to be some overlap between SubTLV 1 and 117 wrt a
 ] prefix.

I would think there is no need to mention "MT Management" in subtlv 1.
the subtlv 1 will be used for general ISIS prefix things. But the
subtlv 117 can be used for MT related prefix things.

thanks.

 ] 
 ] chris
 ] 
 ] >-----Original Message-----
 ] >From: stefano previdi [mailto:[email-masked]] 
 ] >Sent: Wednesday, May 15, 2002 11:18 AM
 ] >To: [email-masked]
 ] >Cc: [email-masked]
 ] >Subject: [Isis-wg] question on draft-ietf-isis-wg-multi-topology-03.txt
 ] >
 ] >
 ] >Naiming,
 ] >
 ] >in draft-ietf-isis-wg-multi-topology-03.txt  I see:
 ] >
 ] >-------------------------------------------------------------------
 ] >8.3.  Multi-Topology Reachable IPv4 Prefixes TLV
 ] >
 ] >    TLV number of this TLV is 235.  It is aligned with extended IS
 ] >    reachability TLV type 135 beside an additional two bytes in front.
 ] >
 ] >         2 bytes of MT membership
 ] >                  4 bits (most significant) are reserved
 ] >                 12 least significant bits are the MT ID
 ] >         0-251 octets of structures used in TLV type 135.
 ] >
 ] >    This TLV can occur multiple times.
 ] >    A new sub-TLV for this MT Reachable IPv4 Prefixes TLV is proposed:
 ] >
 ] >         Sub-TLV type    117
 ] >         Length          4 octets
 ] >         Name            MT IPv4 Prefix Color
 ] >
 ] >         The value of 1 of this sub-TLV is reserved for MT Management
 ] >         Prefix color.
 ] >
 ] >    If the MT Management Prefix color is present in this TLV, 
 ] >a MT based
 ] >    SPF computation MAY also need to install this prefix into the
 ] >    ``standard'' or ``management'' RIB. This MAY be necessary for
 ] >    example in the case of MT based network management.
 ] >---------------------------------------------------------------------
 ] >
 ] >In draft-martin-neal-policy-isis-admin-tags we specified 
 ] >admin tag sub-TLV for both TLV 135 and 235. Not sure about
 ] >the real purpose of sub-TLV 117 but I believe we could just 
 ] >reserve an admin tag value of 1 of for "MT Management".
 ] >
 ] >         
 ] >
 ] >
 ] >
 ] >
 ] >s.
 ] >
 ] >
 ] >_______________________________________________
 ] >Isis-wg mailing list  -  [email-masked] 
 ] >http://spider.juniper.net/mailman/listinfo/isis>-wg
 ] >
 ] _______________________________________________
 ] Isis-wg mailing list  -  [email-masked]
 ] http://spider.juniper.net/mailman/listinfo/isis-wg

- Naiming