Subject: RE: [Isis-wg] Message from the ITU

From: "Philip Christian"<[email-masked]>
Date: Fri, 17 May 2002 11:08:00 +0100

Mike is quite right.

In order to refer in a normative way to an RFC, it must be a standards track
RFC.
The ITU-T can make non-normative references to Informationals, such as "For
more information see RFC..."
But 3-way-handshake doesn't even have an RFC number.
I don't think that an ITU-T document can refer to an Internet Draft at all,
after all, six months later the the doc will deleted off of the server and
it will be a dead URL.
You cannot just take the text from an IETF doc and paste it in, as that
would be against copyright laws.

So that left me with just one option: I had to re-write the thing in my own
words, and what a pain it was.

That is the reason why I had to go through a major learning curve a few
months back to understand extactly how the 3-way-handshake worked. Some of
you will probably remember the stupid questions I kept asking about it :)

I will certainly propose to put the RFC number in when 3-way gets one.
In the mean time, yes, I suggest people have a good read of the
3-way-handshake and make sure I didn't mess up.

Philip

-----Original Message-----
From: Mike Truskowski [mailto:[email-masked]]
Sent: Thursday, May 16, 2002 11:17 PM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: Re: [Isis-wg] Message from the ITU

Tony,
This is why I requested Q14 to send a liaison to you.  

You have it correct....  In order to get the 3way handshake
pointed at.. it must be on standard track or a STD.  Same 
with everything else.

I thought there was an agreement between the IETF and ITU so
we didn't have to duplicate... but it seems it's only good at
the STD level.

Mike

> 
> 
> Hi Jonathan,
> 
> 
>  | Since the work in the IETF on IS-IS is limited to achiving
Informational
>  | status, the ITU will never be able to use an IETF RFC as a normative
>  | reference.  
> 
> 
> This comment struck me as curious.  Are you saying that if IETF claimed to
> pass standards on IS-IS and put these RFCs on the standards track, that
the
> ITU would be willing to reference them as Normative?
> 
> What is the reason for not referencing Informational RFC's as normative?
> They are fixed, published documents.
> 
> Would it help if the IETF (and the authors of the RFC's) granted ITU
> rights of replication?
> 
> Tony
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://spider.juniper.net/mailman/listinfo/isis-wg
> 

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Przygienda <[email-masked]>
Date: Fri, 17 May 2002 06:12:02 -0700

Philip Christian wrote:

>
>
> Mike is quite right.
>
> In order to refer in a normative way to an RFC, it must be a standards track RFC.
> The ITU-T can make non-normative references to Informationals, such as "For more information
> see RFC..."

will have, things are on their way fine ...

> The IESG has received a request from the IS-IS for IP Internets Working
> Group to consider Three-Way Handshake for IS-IS Point-to-Point
> Adjacencies  as an Informational RFC.
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send any comments to the
> [email-masked] or [email-masked] mailing lists by May 20, 2002.
>

> You cannot just take the text from an IETF doc and paste it in, as that would be against
> copyright laws.

touchy point

     thanks

    -- tony