Subject: RE: [Isis-wg] I-D ACTION:draft-kini-traf-restore-nsp-00.txt

From: Sriganesh Kini <[email-masked]>
Date: Wed, 1 May 2002 12:45:25 -0700

At A for destination B, node C is not downstream. But there is NSP from A to
B thru C.

                 +---+ 
                 | C |                                             
                 +---+                                             
             5  /     \  51                                          
               /        \                                             
          +---+          +---+  
          | A |----------| B |         
          +---+   50     +---+     

===
Sriganesh Kini

707 283 1257

-----Original Message-----
From: mike shand [mailto:[email-masked]]
Sent: Wednesday, May 01, 2002 5:23 AM
To: [email-masked]
Subject: Re: [Isis-wg] I-D ACTION:draft-kini-traf-restore-nsp-00.txt

How does this differ from "downstream routes" as described in clause 
7.2.6.2 (c) of ISO/IEC 10589?

         Mike

At 07:25 01/05/2002 -0400, you wrote:
>A New Internet-Draft is available from the on-line Internet-Drafts 
>directories.
>
>
>         Title           : Traffic restoration in link state protocols
using
>                           neighbor's shortest path
>         Author(s)       : S. Kini, Y. Yang
>         Filename        : draft-kini-traf-restore-nsp-00.txt
>         Pages           : 8
>         Date            : 30-Apr-02
>
>Traffic recovery time when a link (or node) fails is typically in the
>order of tens of seconds for a link state IGP. The recovery time is
>governed by factors like the time it takes to detect an adjacency
>down, the time taken to propagate link state database changes
>throughout the network and the time it takes to run the SPF algorithm
>and install the new routes in the FIB. Till this entire process is
>complete, traffic in the network can be blackholed. This draft
>describes a technique to reduce the time for which traffic is
>blackholed by routing the traffic through a neighbor's shortest path.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-kini-traf-restore-nsp-00.txt
>
>To remove yourself from the IETF Announcement list, send a message to
>ietf-announce-request with the word unsubscribe in the body of the message.
>
>Internet-Drafts are also available by anonymous FTP. Login with the
username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
>         "get draft-kini-traf-restore-nsp-00.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>         [email-masked].
>In the body type:
>         "FILE /internet-drafts/draft-kini-traf-restore-nsp-00.txt".
>
>NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail
readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
>
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-kini-traf-restore-nsp-00.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-kini-traf-restore-nsp-00.txt>

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Jon Berger <[email-masked]>
Date: Thu, 2 May 2002 16:47:38 +0100

But, if the BC cost is 60, don't you have a loop?

Jon

-----Original Message-----
From: Sriganesh Kini [mailto:[email-masked]]
Sent: 01 May 2002 20:45
To: [email-masked]
Subject: RE: [Isis-wg] I-D ACTION:draft-kini-traf-restore-nsp-00.txt

                 +---+ 
                 | C |                                             
                 +---+                                             
             5  /     \  51                                          
               /        \                                             
          +---+          +---+  
          | A |----------| B |         
          +---+   50     +---+     

===
Sriganesh Kini

707 283 1257

-----Original Message-----
From: mike shand [mailto:[email-masked]]
Sent: Wednesday, May 01, 2002 5:23 AM
To: [email-masked]
Subject: Re: [Isis-wg] I-D ACTION:draft-kini-traf-restore-nsp-00.txt

         Mike

using
username
readers

---

From: Sriganesh Kini <[email-masked]>
Date: Thu, 2 May 2002 14:34:29 -0700

If the cost of BC is 60 then there is no NSP from A to B through C.

===
Sriganesh Kini

707 283 1257

> From: Jon Berger [mailto:[email-masked]]
> Sent: Thursday, May 02, 2002 8:48 AM
> To: Sriganesh Kini; [email-masked]
username
readers