Subject: RE: [Isis-wg] Proprietary / Private TLV numbers?

From: mike shand <[email-masked]>
Date: Mon, 10 Jun 2002 14:05:20 +0100

At 13:43 10/06/2002 +0100, Philip Christian wrote:

>I suppose that we could define different sub-TLVs, a sub-TLV if the 
>identifier is an IPv4 address, a different sub-TLV if it is a MAC address, etc
>
>Then folks could use whichever mechanism they prefer, as long as it is a 
>globally unique identifier.
>
>Or is that too complex?

Yes! That's how NSAP addresses got to be so awful :-)

         Mike

>Philip
>
> > -----Original Message-----
> > From: mike shand [<mailto:[email-masked]>mailto:[email-masked]]
> > Sent: Monday, June 10, 2002 12:24 PM
> > To: Christian, Philip [HAL02:GI50:EXCH]
> > Cc: [email-masked]
> > Subject: Re: [Isis-wg] Proprietary / Private TLV numbers?
> >
> >
> > At 11:29 10/06/2002 +0100, Philip Christian wrote:
> > >Looking at draft-ietf-isis-wg-tlv-codepoints-02.txt I notice
> > that there is
> > >not really any mechanism for private or proprietary use of a TLV.
> > >
> > >Thus various companies (including my own) have just pcked
> > one and used it
> > >for their own purpose.  Eventually this will create an
> > interop problem,
> > >but what else is a company to do?
> > >
> > >Is there a way that we could define that a certain TLV number is for
> > >private / proprietary / experimental purposes?
> > >
> > >This would then stop people just picking one.
> > >
> > >I am thinking that there would have to be some sort of
> > entity identifier
> > >in there so that when you see this TLV you know whether it
> > is yours or not.
> > >
> > >Maybe we could define that the first four bytes are an IP
> > address for
> > >example.  Any entity large enough to want to use a
> > proprietary TLV would
> > >have a public IP address to put in there, I would have
> > thought. After the
> > >first for bytes then the rest would be free.
> > >
> > >Or maybe there is a better way to identify a particular
> > company / entity
> > >(like a MAC address)?  Maybe ISO 8348?
> > >
> > >What do people think?
> > >
> > >Philip
> > >
> >
> > This has been suggested before, but never came to anything. I
> > think if it
> > WERE to be done then using something link the MAC OUI would
> > probably work.
> > What do you mean by ISO 8348? Do you mean ISO 6523? I hope not :-)
> >
> >          Mike
> >

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Mike Truskowski <[email-masked]>
Date: Mon, 10 Jun 2002 06:41:44 -0700 (PDT)

Why not just do the following?

+-------------------------------------------------+
| Type   |  Length  |       Value                 |
+-------------------------------------------------+
| TLV #  |  Length  |  vendor code  |   "value"   |
+-------------------------------------------------+

Where the vendor code is a fixed 3-4 octets?

I guess one could do this on their own... couldn't they?

The major problem I see here is what Philip said he wanted to fix...

If vendors are doing this already and this is trying to avoid interoperability
problems... then it would seem reasonable that the carrier would go back and
install new images or force the vendor to fix the embedded base..  but they 
won't do either.. thus leaving the problem to stumble over some day...

Mike