Subject: [Isis-wg] RE: index of isisISAdjIPAddrEntry

From: Jeff Parker <[email-masked]>
Date: Mon, 26 Aug 2002 20:00:12 -0400

> 	My point is the consistency between those three.
> 
> 	- isisSummAddrEntry
> 	- isisRedistributeEntry
> 	- isisISAdjIPAddrEntry
> 
> 	The Upper two use *AddressType, *Address and 
> *AddrPrefixlen as an index and the last one uses *IPAddrIndex.
> 
> > > 
> > > And let's omit isisISAdjIPAddrIndex itself like below.

Kay -
	You have a good point.  In the first two tables, the
index is an IP address.  In the third, an index was
introduced to spare the user from having to deal with
an IP address as an index.  
	In the third table there are multiple indexes, 
while in the first two the address is (almost) the only
index.  I've had more than one request to avoid using
addresses as indicies.  Using an IP address as an index
seems more difficult to deal with with when there are many
indicies.  
	I will file your request away for the next version.

- jeff parker
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Noguchi Kay <[email-masked]>
Date: Mon, 26 Aug 2002 19:01:24 -0700

Hi Jeff,

# I didn't read the old mail that pointed out the difficulties
# to use the IP address as an index, but...

> an IP address as an index.  

	I prefer to use IP address or area address for the index because
	those indexes are permanent for the configure/unconfigure event.

	It's a little bit hard to make the special index value, in this case,
	isisISAdjIPAddrIndex, permanent during the IP address add, delete and
	add event.

# I know it's depend on the generation and reception process for the
# IP Interface Address TLV but that's different topic.

> seems more difficult to deal with with when there are many

	Again I don't agree this point that the differencies between
	one to three another indexes, isisSummAddrEntry has one another
	index and isisISAdjIPaddrEntry has three other indexes.

# I've attached draft-ietf-isis-wg-mib-09.txt's isisSummAddrEntry and
# isisISAdjIPAddrEntry for reference.

> 	I will file your request away for the next version.

	Okay, I prefer to use IP address as an index but I more prefer
	to the consistency between those three entries.

	So if you want to keep isisISAdjIPAddrIndex, then you can pick
	isisSummAddrIndex and isisRedistributeIndex as the index for
	other two entries, I don't like this though. ;P

	So please make a good decision.

Thank you,

								kay
    isisSummAddrEntry OBJECT-TYPE
        SYNTAX IsisSummAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one IP summary address."

        INDEX { isisSysInstance,
                isisSummAddressType,
                isisSummAddress,
                isisSummAddrPrefixLen }
    ::= { isisSummAddrTable 1 }

   isisISAdjIPAddrEntry OBJECT-TYPE
        SYNTAX IsisISAdjIPAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one IP Address reported by a
             neighboring Intermediate System in its IIH PDUs."
        INDEX { isisSysInstance,
                isisCircIndex,
                isisISAdjIndex,
                isisISAdjIPAddrIndex
                }
    ::= { isisISAdjIPAddrTable 1 }