Subject: [Isis-wg] RE: index of isisISAdjEntry

From: Jeff Parker <[email-masked]>
Date: Mon, 26 Aug 2002 19:29:29 -0400

> I have a question about isisISAdjIndex in isisISAdjEntry.
> 
> You discribed isisISAdjIndex like below but I don't understand what
> the adjacencies itself.
> 
>     isisISAdjIndex OBJECT-TYPE
>         SYNTAX Integer32 (1..2000000000)
>         MAX-ACCESS not-accessible
>         STATUS current
>         DESCRIPTION
>             "A unique value identifying the IS adjacency from all
>              other such adjacencies on this circuit. This value is
>              assigned by the system when the adjacency is created
>              automatically."
>     ::= { isisISAdjEntry 1 }
> 
> Okay, I'm gonna use the example. If you have one L1L2 
> neighbor instance,
> how many adjacencies do you have?
> 
> 	a) Only one adjacency.
> 	b) Two adjacencies, one for L1 adjacency and one for L2 
> adjacency.

On P2P circuits, there would be one adjacency.
On a LAN there would be two.  

> I think you mean b) because we have some entries which have 
> different value
> for L1 and L2 adjacencies in the isisISAdjEntry shown below.
> 
> 	isisISAdjState
> 	isisISAdjHoldTimer
> 	isisISAdjNeighPriority
> 	isisISAdjUpTime

I agree in the case of a LAN.
On a p2p, we create the adjacency at one instant,
so these would be the same for the two levels.  
 
>     isisISAdjEntry OBJECT-TYPE
>         SYNTAX IsisISAdjEntry
>         MAX-ACCESS not-accessible
>         STATUS current
>         DESCRIPTION
>             "Each entry corresponds to one adjacency to an
>              Intermediate System on this system."
>         INDEX { isisSysInstance,
>                 isisCircIndex,
>                 isisISAdjIndex
>                 isisISAdjLevelIndex }
>     ::= { isisISAdjTable 1 }
 
I think this is taken from a prior version.  Take a look 
at the 09 version of the MIB and see if your issue remains.  
There are certainly issues that arrise with the two 
formats of adjacency.  

- jeff parker
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Noguchi Kay <[email-masked]>
Date: Mon, 26 Aug 2002 16:54:47 -0700

Hi Jeff,

> so these would be the same for the two levels.  

	Then, how about to use isisCircuitType in the isisCircuitCounterEntry
	as the isisISAdjLevelIndex like below.

    isisISAdjLevelIndex OBJECT-TYPE
        SYNTAX INTEGER
            {
                lanlevel1(1),
                lanlevel2(2),
                p2pcircuit(3)
            }
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "What type of level these adjacency is?

             The point to point Hello PDU includes
             both L1 and L2, and ISs form a single
             adjacency on point to point links.
             Thus we combine counts on
             point to point links into one group."
    ::= { isisISAdjEntry 2 }

> There are certainly issues that arrise with the two 

	I didn't see any old draft instead of -08 so that maight exist
	in the previous draft or not. But based on the current -09 draft,
	we have a problem to express the adjacent neighbor in the
	isisAdj*Entry.

	Here is the current -09 version's isisAdjEntry which doesn't have
	level information in the index.

                isisISAdjIndex }
    ::= { isisISAdjTable 1 }

								kay