Subject: [Isis-wg] RE: index of isisISAdjIPAddrEntry

From: Jeff Parker <[email-masked]>
Date: Wed, 28 Aug 2002 13:46:30 -0400

> > > 	My point is the consistency between those three.
> > > 
> > > 	- isisSummAddrEntry
> > > 	- isisRedistributeEntry
> > > 	- isisISAdjIPAddrEntry
> >
> > Kay -
> > 	You have a good point.  In the first two tables, the
> > index is an IP address.  In the third, an index was
> > introduced to spare the user from having to deal with
> > an IP address as an index.  
> 
> 	I prefer to use IP address or area address for the index because
> 	those indexes are permanent for the configure/unconfigure event.
> 
> 	It's a little bit hard to make the special index value, 
>     in this case, isisISAdjIPAddrIndex, permanent during 
>     the IP address add, delete and add event.

Kay -
	Excellent point: thanks for bringing this up.

	However, does this apply to the case you bring
up, the isisISAdjIPAddrEntry?  This is the IP address
advertised by a neighbor.  We should not need to 
configure or unconfigure these items.  
 
> > 	In the third table there are multiple indexes, 
> > while in the first two the address is (almost) the only
> > index.  I've had more than one request to avoid using
> > addresses as indicies.  Using an IP address as an index
> > seems more difficult to deal with with when there are many
> > indicies.  
> 
> 	Again I don't agree this point that the differencies between
> 	one to three another indexes, isisSummAddrEntry has one another
> 	index and isisISAdjIPaddrEntry has three other indexes.

There is a system instance, but it has never been clear
to me how much this will vary.  It seems to provide 
for virtual routers, but within an implementation,
sysInstance may well be a virtual constant.  This 
is the only MIB I know with this variable, which 
suggests that it never caught on as a useful idea.  

To restate my point, the third table is different because
it has multiple non-trivial indicies, making a traverse
more onerous with a multi-part index such as an IP address.
 
> 	So if you want to keep isisISAdjIPAddrIndex, then you can pick
> 	isisSummAddrIndex and isisRedistributeIndex as the index for
> 	other two entries, I don't like this though. ;P
> 
> 	So please make a good decision.
 
I think Emerson said something about foolish 
consistency, but that probably just proves 
that he wasn't a programmer.

Any opinions from the list?  Is dealing with 
Addresses routine enough that we can drop the
index from isisISAdjIPAddrEntry?  Or difficult
enough that we should add it to the other two?
Or is the current version with both in place
reasonable.  

- jeff parker
- axiowave networks
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Noguchi Kay <[email-masked]>
Date: Wed, 28 Aug 2002 11:09:04 -0700

Hi Jeff, Tony and Tony,

# I added the working group chairs, Tony and Tony, to report ml problem.

At Wed, 28 Aug 2002 13:46:30 -0400,
> Or is the current version with both in place

	Yes, I want to know other guys opinions and, of course, I vote
	for the change of isisISAdjIPAddrIndex to isisISAdjIPAddress.

	But right now, we have a problem with [email-masked] mailing list
	so nobody except me and Jeff receives this discussions.

	Tony, could you check and fix the [email-masked] mailing list
	configuration? As I reported before to Tony Przygienda, my
	MTA, exim, claims no errors in the transactions show below.

2002-08-28 10:54:52 17k71o-0002A4-00 <= [email-masked] H=titanium (titanium.
ipinfusion.com) [127.0.0.1] P=esmtp S=2186 id=[email-masked]
2002-08-28 10:54:58 17k71o-0002A4-00 => [email-masked] R=lookuphost T=remo
te_smtp H=mail.axiowave.com [64.115.125.242]
2002-08-28 10:54:58 17k71o-0002A4-00 => [email-masked] R=lookuphost T=remote
_smtp H=mail.ipinfusion.com [65.223.109.2]
2002-08-28 10:55:00 17k71o-0002A4-00 => [email-masked] R=lookuphost T=remote_s
mtp H=odin.ietf.org [132.151.1.176]
2002-08-28 10:55:00 17k71o-0002A4-00 Completed

	And we can't see any discussion after Aug. 04 in the archive. 

http://www1.ietf.org/mail-archive/working-groups/isis-wg/current/threads.html

Thank you,

---

From: Noguchi Kay <[email-masked]>
Date: Wed, 04 Sep 2002 11:49:56 -0700

Hi Tony,

> We're at it

	Was that fixed already?
	I didn't see any update in the mailing list archive, though.

https://www1.ietf.org/mail-archive/working-groups/isis-wg/current/maillist.html

Thank you,

								kay