Subject: RE: [Isis-wg] isisISAdjState

From: Jeff Parker <[email-masked]>
Date: Mon, 9 Sep 2002 19:51:45 -0400

> Hi Jeff,
> 
> One question about isisISAdjState.
> 
> What is the intention of '0' as 'up' state like below in -09 draft.
> 
>     isisISAdjState OBJECT-TYPE
>         SYNTAX INTEGER
>             {
>                  up (0),
>                  initializing (1),
>                  down (2),
>                  failed (3)
>             }
....
>     ::= { isisISAdjEntry 2 }
> 
> For me, '0' as down is reasonable because usually the state 
> is changing
> from down(0), initializing(1) and then up(2).

Kay -
	That would seem like a natural order.  I recently
(two or three drafts ago) changed the values to match 
those in <draft-ietf-isis-3way>, shown below.  It was
thought that that would make it simpler for implementors
and observers to match the bits on the wire with the bits
in the MIB.

- jeff parker
- axiowave networks

   Adjacency Three-Way State
      The adjacency three-way state of the point-to-point adjacency. The
      following values are defined:
            0  - Up
            1 -  Initializing
            2 -  Down
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Noguchi Kay <[email-masked]>
Date: Mon, 09 Sep 2002 17:07:22 -0700

Hi Dave and Jeff,

>       following values are defined:

	Okay, then Dave, what is the intention of the '0' as 'up' state
	in the Adjacency three-way state?

	Maybe we can't change this point because of backward compatibility
	but please tell me the intention.

								kay

---

From: Dave Katz <[email-masked]>
Date: Mon, 9 Sep 2002 19:42:46 -0700 (PDT)

The choice of 0 as "up" is lost in the haze;  I think this goes back to
when I was at my previous employer, so it's probably close to six years
now (!).

My suspicion is that I used these code points because it was compatible
with NLSP (the IPX ISIS lookalike) from which the three-way handshake was
stolen in the first place.  NLSP in turn used these code points because
(if memory serves) Neal used a couple of unused bits in the IIH header
and making 0 = up provided backward compatibility.  Such are the twisted
paths of protocol history.

(A much better one is why IPX delays are in units of 55 msec, but you
have to be of a certain age to know the answer.)

See the "six years" comment above.  Can't exactly change it now.

--Dave