Subject: [Isis-wg] Re: index of isisISAdjEntry

From: Noguchi Kay <[email-masked]>
Date: Wed, 28 Aug 2002 10:54:51 -0700

Hi Jeff,

> Kay -
> 	The isisISAdjUsage should tell you what you need
> to know here: it would be 3 for a L1L2 p2p adjacency, 
> and 1 or 2 for L1 or L2 adjacencies on a LAN.

	Cool, thank you for your clarification.

> 	If the Description clause is unclear let's fix it.

	Then why don't you put "L1L2(3) is for p2p L1L2 adjacency only"
	clause like you said. That makes more clear to me that "3" is only
	for p2p, not for broadcast adjacency.
 
	As you can see, I thought we should use "3" for broadcast L1/L2
	adjacecy also and that made me confused and I thought we need
	isisISAdjLevelIndex.

Thank you,

								kay

> 	If the Description clause is unclear let's fix it.
> 
> - jeff parker
>  
>      isisISAdjUsage OBJECT-TYPE
>         SYNTAX INTEGER
>             {
>                 level1(1),
>                 level2(2),
>                 level1and2(3)
>             }
>         MAX-ACCESS read-only
>         STATUS current
>         DESCRIPTION
>             "An adjacency of type level1 is used for level 1
>              traffic only. An adjacency of type level2 is used
>              for level 2 traffic only. An adjacency of type level1and2
>              is used for both level 1 and level 2 traffic. There
>              may be two adjacencies (of types level1 and level2)
>              between the same pair of Intermediate Systems."
>         REFERENCE "{ISIS.aoi adjacencyUsage (82)}"
>     ::= { isisISAdjEntry 6 } 
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Wed, 28 Aug 2002 13:42:19 -0400

> > >     isisISAdjEntry OBJECT-TYPE
> > >         SYNTAX IsisISAdjEntry
> > >         MAX-ACCESS not-accessible
> > >         STATUS current
> > >         DESCRIPTION
> > >             "Each entry corresponds to one adjacency to an
> > >              Intermediate System on this system."
> > >         INDEX { isisSysInstance,
> > >                 isisCircIndex,
> > >                 isisISAdjIndex }
> > >     ::= { isisISAdjTable 1 }
> 
> 	You have two IS L1/L2 routers(IS1, IS2) on the LAN and those two
> 	are L1L2 adjacent.
> 
> 	We can assign isisISAdjIndex one for L1 adjacency and two for
> 	L2 adjacency and vice versa because there is no information for
> 	level in the isisAdjEntry indexes.
> 
> 	Then if IS2's priority is set differently for L1 and L2, say
> 	63 and 64, then how do you know which one is for which level?
> 
> 	And there is no entry for the level information in the 
>     isisISAdjEntry ieself.
> 
> 	isisISAdjNeighSysType and isisISAdjNeighUsage just returns "3",
> 	l1L2IntermediateSystem for isisISAdjNeighSysType and 
>     level1and2 for isisISAdjNeighUsage, in this case.
> 
> Thank you,
> 
> 								kay

Kay -

- jeff parker