Subject: [Isis-wg] Re: index of isisISAdjIPAddrEntry

From: Noguchi Kay <[email-masked]>
Date: Wed, 21 Aug 2002 18:41:46 -0700

Hi Jeff,

# I didn't receive previous mail and those mail is not in the archive itself.
# Do you know what's going on in the mailing list itself? ;P

> This time is the index of isisISAdjIPAddrEntry.
> 
> Like other entries, isisSummAddrEntry and isisRedistributeEntry, let's
> use isisISAdjIPAddressType and isisISAdjIPAddress instead of
> isisISAdjIPAddrIndex as the index of isisISAdjIPAddrEntry.

	I saw the mailing list archive and I'm the guy who suggested to
	remove the isisISAdjIPAddress itself. Sorry for the back and
	forth comments.

	But the point is the consistency between those three entries.

	- isisSummAddrEntry
	- isisRedistributeEntry
	- isisISAdjIPAddrEntry

	Top two have the InetAddress type index and the bottom one doesn't.
	This makes a confusion to me.

	Could you clarify that point, Jeff?

    isisSummAddrEntry OBJECT-TYPE
        SYNTAX IsisSummAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one IP summary address."

        INDEX { isisSysInstance,
                isisSummAddressType,
                isisSummAddress,
                isisSummAddrPrefixLen }
    ::= { isisSummAddrTable 1 }

    isisRedistributeAddrEntry OBJECT-TYPE
        SYNTAX IsisRedistributeAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one IP summary address to
             manage leaking L2 addresses into L1."
        INDEX { isisSysInstance,
                isisRedistributeAddrType,
                isisRedistributeAddrAddress,
                isisRedistributeAddrPrefixLen }
    ::= { isisRedistributeAddrTable 1 }

    isisISAdjIPAddrEntry OBJECT-TYPE
        SYNTAX IsisISAdjIPAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one IP Address reported by a
             neighboring Intermediate System in its IIH PDUs."
        INDEX { isisSysInstance,
                isisCircIndex,
                isisISAdjIndex,
                isisISAdjIPAddrIndex
                }
    ::= { isisISAdjIPAddrTable 1 }

> And let's omit isisISAdjIPAddrIndex itself like below.
> 
>     isisISAdjIPAddrEntry OBJECT-TYPE
>         SYNTAX IsisISAdjIPAddrEntry
>         MAX-ACCESS not-accessible
>         STATUS current
>         DESCRIPTION
>             "Each entry contains one IP Address reported by a
>              neighboring Intermediate System in its IIH PDUs."
>         INDEX { isisSysInstance,
>                 isisCircIndex,
>                 isisISAdjIndex,
>                 isisISAdjIPAddressType
>                 isisISAdjIPAddress }
>     ::= { isisISAdjIPAddrTable 1 }
> 
>     IsisISAdjIPAddrEntry ::=
>         SEQUENCE {
>             isisISAdjIPAddressType
>                  InetAddressType,
>             isisISAdjIPAddress
>                 InetAddress
>         }
> 
> Thank you,
> 
> 								kay
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Laura Liu <[email-masked]>
Date: Thu, 5 Sep 2002 14:16:29 -0500

I agree with Kay on "use IP address or area address for the index because
those indexes are permanent for the configure/unconfigure event". 

Laura

-----Original Message-----
From: Noguchi Kay [mailto:[email-masked]]
Sent: Wednesday, August 28, 2002 1:09 PM
To: Jeff Parker
Cc: 'Noguchi Kay'; [email-masked]; [email-masked]; [email-masked]
Subject: [Isis-wg] Re: index of isisISAdjIPAddrEntry

Hi Jeff, Tony and Tony,

# I added the working group chairs, Tony and Tony, to report ml problem.

At Wed, 28 Aug 2002 13:46:30 -0400,
Jeff Parker wrote:
> 
> Any opinions from the list?  Is dealing with 
> Addresses routine enough that we can drop the
> index from isisISAdjIPAddrEntry?  Or difficult
> enough that we should add it to the other two?
> Or is the current version with both in place
> reasonable.  

	Yes, I want to know other guys opinions and, of course, I vote
	for the change of isisISAdjIPAddrIndex to isisISAdjIPAddress.

	But right now, we have a problem with [email-masked] mailing list
	so nobody except me and Jeff receives this discussions.

	Tony, could you check and fix the [email-masked] mailing list
	configuration? As I reported before to Tony Przygienda, my
	MTA, exim, claims no errors in the transactions show below.

2002-08-28 10:54:52 17k71o-0002A4-00 <= [email-masked] H=titanium
(titanium.
ipinfusion.com) [127.0.0.1] P=esmtp S=2186 id=[email-masked]
2002-08-28 10:54:58 17k71o-0002A4-00 => [email-masked] R=lookuphost
T=remo
te_smtp H=mail.axiowave.com [64.115.125.242]
2002-08-28 10:54:58 17k71o-0002A4-00 => [email-masked] R=lookuphost
T=remote
_smtp H=mail.ipinfusion.com [65.223.109.2]
2002-08-28 10:55:00 17k71o-0002A4-00 => [email-masked] R=lookuphost
T=remote_s
mtp H=odin.ietf.org [132.151.1.176]
2002-08-28 10:55:00 17k71o-0002A4-00 Completed

	And we can't see any discussion after Aug. 04 in the archive. 

http://www1.ietf.org/mail-archive/working-groups/isis-wg/current/threads.htm
l

Thank you,

> - jeff parker
> - axiowave networks

----------------------------------------- (on rchss001)

This e-mail and any files transmitted with it are the property
of Chiaro Networks, Ltd., and may contain confidential and 
privileged material for the sole use of the intended recipient(s)
to whom this e-mail is addressed. If you are not one of the named
recipient(s), or otherwise have reason to believe that you have 
received this message in error, please notify the sender and 
delete all copies from your system.  Any other use, retention, 
dissemination, forwarding, printing or copying of this e-mail is 
strictly prohibited.

---------------------------------------------------------