Subject: RE: [Isis-wg] doubts

From: ramanathan rams <[email-masked]>
Date: Thu, 26 Sep 2002 13:25:10 -0700

Hi,

     for point to point straight forward reason( for acking SRM flag will 
be set,  if we don't clear it, again LSP will be sent ) is there, so it's 
fine.

For Lan,  consider the following situation :

     Machine A, B are in LAN.  A is the DIS. B is connected to C via PP 
circuit.

    B is having an old copy of an LSP.  now B is getting the new copy of 
the same LSP from  C via PP. so SRM flag will be set for that LSP in B to 
transmitt that LSP in LAN. By then B is getting the CSNP from the DIS, 
which has a latest version of that LSP, so B will set SSN flag for 
requesting that LSP and according to the specification won't clear the SRM 
flag for that LSP in the Broadcast circuit. so  B will flood the old LSP in 
the broadcast circuit, even though it will converge soon, this seems to be 
unnecessary operation right? if i am wrong please correct me.

thanks
rams.

-----Original Message-----
From:	Jeff Parker [SMTP:[email-masked]]
Sent:	Thursday, September 26, 2002 12:29 PM
To:	[email-masked]'; [email-masked]'
Subject:	RE: [Isis-wg] doubts

> *   In section 7.3.15.2 - Action on receipt of sequence
> number PDU, under
> it says if C is non broadcast circuit clear SRMflag.
>  why don't we clear it for broadcast circuit[?]

The SRM flag is used to control an IS's acknowledgement
of a packet.  Acknowledgements on a LAN are handled
by the DIS sending CSNPs.

> *   In ISIS 3 way handshake while mentioning  the first
> problem which will occur if we don't support 3 way
> handshake if the datalink protocol used is
> unrelaible, they say it may take full complete LSP refresh
> period upto eighteen hours. how do they get this 18 hours?

In 16 bits, you can encode 18 hours worth of seconds.
There are ISPs that demand (and craven implementors
who provide) the ability to increase the LSP Lifetime.

> *   Do u have any idea on DDRP based on ISIS and any
> reference to DDRP materials?

Sorry, I'm having a jargon cache miss.  Do you
mean the National Guard Drug Demand Reduction
Policy?  I know of no mention of ISIS in their
material.

- jeff parker

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Thu, 26 Sep 2002 13:48:38 -0700

you example being there are only A and B on a LAN. what if there are
C and D. B does not know C and D has it or not. why not just send
it instead of waiting for C and D both send PSNP asking for it.

 ] Hi,
 ] 
 ]      for point to point straight forward reason( for acking SRM flag will 
 ] be set,  if we don't clear it, again LSP will be sent ) is there, so it's 
 ] fine.
 ] 
 ] For Lan,  consider the following situation :
 ] 
 ]      Machine A, B are in LAN.  A is the DIS. B is connected to C via PP 
 ] circuit.
 ] 
 ]     B is having an old copy of an LSP.  now B is getting the new copy of 
 ] the same LSP from  C via PP. so SRM flag will be set for that LSP in B to 
 ] transmitt that LSP in LAN. By then B is getting the CSNP from the DIS, 
 ] which has a latest version of that LSP, so B will set SSN flag for 
 ] requesting that LSP and according to the specification won't clear the SRM 
 ] flag for that LSP in the Broadcast circuit. so  B will flood the old LSP in 
 ] the broadcast circuit, even though it will converge soon, this seems to be 
 ] unnecessary operation right? if i am wrong please correct me.
 ] 
 ] thanks
 ] rams.
 ] 
 ] 
 ] 
 ] 
 ] 
 ] 
 ] -----Original Message-----
 ] From:	Jeff Parker [SMTP:[email-masked]]
 ] Sent:	Thursday, September 26, 2002 12:29 PM
 ] To:	[email-masked]'; [email-masked]'
 ] Subject:	RE: [Isis-wg] doubts
 ] 
 ] > *   In section 7.3.15.2 - Action on receipt of sequence
 ] > number PDU, under
 ] > it says if C is non broadcast circuit clear SRMflag.
 ] >  why don't we clear it for broadcast circuit[?]
 ] 
 ] The SRM flag is used to control an IS's acknowledgement
 ] of a packet.  Acknowledgements on a LAN are handled
 ] by the DIS sending CSNPs.
 ] 
 ] > *   In ISIS 3 way handshake while mentioning  the first
 ] > problem which will occur if we don't support 3 way
 ] > handshake if the datalink protocol used is
 ] > unrelaible, they say it may take full complete LSP refresh
 ] > period upto eighteen hours. how do they get this 18 hours?
 ] 
 ] In 16 bits, you can encode 18 hours worth of seconds.
 ] There are ISPs that demand (and craven implementors
 ] who provide) the ability to increase the LSP Lifetime.
 ] 
 ] > *   Do u have any idea on DDRP based on ISIS and any
 ] > reference to DDRP materials?
 ] 
 ] Sorry, I'm having a jargon cache miss.  Do you
 ] mean the National Guard Drug Demand Reduction
 ] Policy?  I know of no mention of ISIS in their
 ] material.
 ] 
 ] - jeff parker
 ] 
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming