Subject: RE: [Isis-wg] FW: IS-IS MIB (metric comments)

From: stefano previdi <[email-masked]>
Date: Mon, 14 Oct 2002 22:49:09 +0200

At 06:17 PM 10/14/2002, Jeff Parker wrote:
>> what I try to understand is why "reporting" a 0-metric in a 
>> mib is a problem. 
>> Taking the statement below:
> 
>Stephano -
>        We don't split passive interfaces from other interfaces
>in the MIB.  Thus, given the current design, if we allow a 0 
>metric on a passive circuit, we are allowing a 0 metric on
>any circuit, and thus allowing a 0-cost path to a neighbor.  
>        We can add a warning that 0 should only be used when the
>interface is passive, but it is not enforceable.  

but what are you going to do with implementations that 
already assign 0-metric to (passive)interfaces ? I think 
you should accept them.

Again, I don't believe it's the role of a MIB/SNMP agent 
to handle these issues.

s.

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Mon, 14 Oct 2002 15:34:33 -0700

] >        We don't split passive interfaces from other interfaces
 ] >in the MIB.  Thus, given the current design, if we allow a 0 
 ] >metric on a passive circuit, we are allowing a 0 metric on
 ] >any circuit, and thus allowing a 0-cost path to a neighbor.  

I think we should allow 0 to be inside the range. It's up to the
implementation to block certain MIB settings. The MIB can give a
union of all the possible configures exist/possible-to-have, if it
does not want to specify the each specific cases. It's a local
implementation issue to honor such a MIB request. The reverse approach,
take a common dominate, does not sound right.

 ] >        We can add a warning that 0 should only be used when the
 ] >interface is passive, but it is not enforceable.  
 ] 
 ] 
 ] but what are you going to do with implementations that 
 ] already assign 0-metric to (passive)interfaces ? I think 
 ] you should accept them.
 ] 
 ] Again, I don't believe it's the role of a MIB/SNMP agent 
 ] to handle these issues.
 ] 
 ] s.
 ] 
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming

---

From: Naiming Shen <[email-masked]>
Date: Mon, 14 Oct 2002 15:37:18 -0700

]  ] >        We don't split passive interfaces from other interfaces
 ]  ] >in the MIB.  Thus, given the current design, if we allow a 0 
 ]  ] >metric on a passive circuit, we are allowing a 0 metric on
 ]  ] >any circuit, and thus allowing a 0-cost path to a neighbor.  
 ] 
 ] I think we should allow 0 to be inside the range. It's up to the
 ] implementation to block certain MIB settings. The MIB can give a
 ] union of all the possible configures exist/possible-to-have, if it
 ] does not want to specify the each specific cases. It's a local
 ] implementation issue to honor such a MIB request. The reverse approach,
 ] take a common dominate, does not sound right.
                ^^^^^^^^^ denominator.
 ] 
 ]  ] >        We can add a warning that 0 should only be used when the
 ]  ] >interface is passive, but it is not enforceable.  
 ]  ] 
 ]  ] 
 ]  ] but what are you going to do with implementations that 
 ]  ] already assign 0-metric to (passive)interfaces ? I think 
 ]  ] you should accept them.
 ]  ] 
 ]  ] Again, I don't believe it's the role of a MIB/SNMP agent 
 ]  ] to handle these issues.
 ]  ] 
 ]  ] s.
 ]  ] 
 ]  ] _______________________________________________
 ]  ] Isis-wg mailing list
 ]  ] [email-masked]
 ]  ] https://www1.ietf.org/mailman/listinfo/isis-wg
 ] 
 ] - Naiming

- Naiming

---

From: Satish Dattatri <[email-masked]>
Date: Mon, 14 Oct 2002 19:39:14 -0700 (PDT)

The metric configured does not matter when an interface is passive,
IP prefix advertisement will always be with zero cost. At a later
point if the interface is made non-passive, the IP prefix advertisement
will have the metric of the interface. Since, the configured value is
not considered anyways for the advertisement of the IP prefix when
passive, I think MIB range need not start with 0.

Satish

- Naiming

__________________________________________________
Do you Yahoo!?
Faith Hill - Exclusive Performances, Videos & More
http://faith.yahoo.com
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Mon, 14 Oct 2002 20:23:03 -0700

] The metric configured does not matter when an interface is passive,

changing passive interface metric(thus the metric of it's prefix)
to control the inter-as traffic is a well-known technique used by ISPs.

 ] IP prefix advertisement will always be with zero cost. At a later
 ] point if the interface is made non-passive, the IP prefix advertisement
 ] will have the metric of the interface. Since, the configured value is
 ] not considered anyways for the advertisement of the IP prefix when
 ] passive, I think MIB range need not start with 0.
 ] 
 ] Satish
 ] 
 ]  ]  ] >        We don't split passive interfaces from other interfaces
 ]  ]  ] >in the MIB.  Thus, given the current design, if we allow a 0 
 ]  ]  ] >metric on a passive circuit, we are allowing a 0 metric on
 ]  ]  ] >any circuit, and thus allowing a 0-cost path to a neighbor.  
 ]  ] 
 ]  ] I think we should allow 0 to be inside the range. It's up to the
 ]  ] implementation to block certain MIB settings. The MIB can give a
 ]  ] union of all the possible configures exist/possible-to-have, if it
 ]  ] does not want to specify the each specific cases. It's a local
 ]  ] implementation issue to honor such a MIB request. The reverse approach,
 ]  ] take a common dominate, does not sound right.
 ]                 ^^^^^^^^^ denominator.
 ]  ] 
 ]  ]  ] >        We can add a warning that 0 should only be used when the
 ]  ]  ] >interface is passive, but it is not enforceable.  
 ]  ]  ] 
 ]  ]  ] 
 ]  ]  ] but what are you going to do with implementations that 
 ]  ]  ] already assign 0-metric to (passive)interfaces ? I think 
 ]  ]  ] you should accept them.
 ]  ]  ] 
 ]  ]  ] Again, I don't believe it's the role of a MIB/SNMP agent 
 ]  ]  ] to handle these issues.
 ]  ]  ] 
 ]  ]  ] s.
 ]  ]  ] 
 ]  ]  ] _______________________________________________
 ]  ]  ] Isis-wg mailing list
 ]  ]  ] [email-masked]
 ]  ]  ] https://www1.ietf.org/mailman/listinfo/isis-wg
 ]  ] 
 ]  ] - Naiming
 ] 
 ] - Naiming
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg
 ] 
 ] 
 ] 
 ] __________________________________________________
 ] Do you Yahoo!?
 ] Faith Hill - Exclusive Performances, Videos & More
 ] http://faith.yahoo.com
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 15 Oct 2002 07:22:48 -0700

>take a common dominate, does not sound right.
tend to agree, goes into the discussion I encouraged as 'good topic' on 
what the right
range of MIB values should be. I don't think enforcing strict ranges 
except brain-dead values
buys much and causes trouble later (when an implementation for some 
valid reason allows
values outside the range)

    thanks

    -- tony