Subject: [Isis-wg] MIB: re-index isisIPRATable to be in line with othe r I P tables

From: Jeff Parker <[email-masked]>
Date: Tue, 8 Oct 2002 16:28:56 -0400

> I think it would make more sense to use isisIPRADestNextHop 
> as attribute
> instead of isisIPRASNPAAddress as index. 
> 
> Laura
 
I've tossed SNPA, and replaced with IP Next hop.  
If there is need to retain of next hop types other
than IPV4 and IPV6, drop me a line.

- jeff parker

    isisIPRAEntry OBJECT-TYPE
        SYNTAX IsisIPRAEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry defines an IP Reachable Address to a network,
             subnetwork or host."
        INDEX {  isisSysInstance,
                 isisIPRAIndex,
                 isisIPRADestType,
                 isisIPRADest,
                 isisIPRADestPrefixLen }
    ::= { isisIPRATable 1 }

    IsisIPRAEntry ::=
        SEQUENCE {
            isisIPRAIndex
                Integer32,
            isisIPRADestType
                InetAddressType,
            isisIPRADest
                InetAddress,
            isisIPRADestPrefixLen
                InetAddressPrefixLength,
            isisIPRANextHopType
                InetAddressType,
            isisIPRANextHop
                InetAddress,
            isisIPRAType
                INTEGER,
            isisIPRAExistState
                RowStatus,
            isisIPRAAdminState
                AdminState,
            isisIPRAMetric
                DefaultMetric,
            isisIPRAMetricType
                MetricType,
            isisIPRAFullMetric
                FullMetric
        }
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Don Goodspeed" <[email-masked]>
Date: Tue, 8 Oct 2002 18:43:21 -0400 (EDT)

Jeff,

We may want to keep SNPAAddress in the table, just not as
an INDEX to the table.

But I do prefer the indexing by NextHop IP address.

Thanks,
Don

 --- On Tue 10/08, Jeff Parker  wrote:
From: Jeff Parker [mailto: [email-masked]]
To: [email-masked], [email-masked], [email-masked]
Date: Tue, 8 Oct 2002 16:28:56 -0400
Subject: [Isis-wg] MIB: re-index isisIPRATable to be in line with othe r I P tables

>             "Each entry defines an IP Reachable Address to a

------------------------------------------------
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Wed, 9 Oct 2002 10:13:21 -0400

> We may want to keep SNPAAddress in the table, just not as
 
Done.  

- jdp

    IsisIPRAEntry ::=
        SEQUENCE {
            isisIPRAIndex
                Integer32,
            isisIPRADestType
                InetAddressType,
            isisIPRADest
                InetAddress,
            isisIPRADestPrefixLen
                InetAddressPrefixLength,
            isisIPRANextHopType
                InetAddressType,
            isisIPRANextHop
                InetAddress,
            isisIPRAType
                INTEGER,
            isisIPRAExistState
                RowStatus,
            isisIPRAAdminState
                AdminState,
            isisIPRAMetric
                DefaultMetric,
            isisIPRAMetricType
                MetricType,
            isisIPRAFullMetric
                FullMetric,
            isisIPRASNPAAddress
                OSINSAddress
        }