Subject: [Isis-wg] RE: isisRedistributeAddrTable in mib09

From: "Don Goodspeed" <[email-masked]>
Date: Mon, 7 Oct 2002 21:35:59 -0400 (EDT)

Jeff,

The problem is that this is one table for which platform
independence cannot probably be achieved.  Every vendor
usually has leaking tied into route policies since
route ranges can come into play as well as only leaking
internal vs external ISIS routes, etc.

I don't know that we can create one table in the ISIS
MIB that replaces all of this functionality.

My 2 cents,
Don

 --- On Wed 09/25, Jeff Parker  wrote:
From: Jeff Parker [mailto: [email-masked]]
To: [email-masked], [email-masked]
Date: Wed, 25 Sep 2002 13:18:47 -0400
Subject: [Isis-wg] RE: isisRedistributeAddrTable in mib09

>  
> > Jeff,
> > 
> > My question was triggered by the discussion on the mailing 
> > list a while ago
> > about up/down bit referring to "IS-IS extensions for Traffic 
> > Engineering"
> > draft v.04 section 5.1:
> > 
> > "If a prefix is advertised from an area to another area at 
> > the same level,
> > then the up/down bit shall be set to 1. This situation can 
> > arise when a
> > router implements multiple virtual routers at the same level, but in
> > different areas.".
> > 
> > Can we use isisRedistributeAddrTable for all the up/down bit set to
> 1
> > routes? 
> > 
> > regards,
> > Laura 
>  
> Laura -
> 	The goal is to have a platform independent way to specify
> which routes can be leaked down from L2 to L1.
> 
> - jeff parker
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg
> 

------------------------------------------------
Changed your e-mail?  Keep your contacts!  Use this free e-mail change of address service from Return Path.  Register now!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Noguchi Kay <[email-masked]>
Date: Tue, 29 Oct 2002 14:19:46 -0800

Hi Jeff,

Some tiny editorial comments to -10 draft.

1, isisRedistributeAddr and isisSysLevel info should be there in Section 4
   like below

  - isisSummAddr

       This table holds summary addresses configured for each Level 2
       instance of the IS-IS protocol running on a router.

  - isisRedistributeAddr

       This table holds redistributed addresses which is leaked from L2
       to L1.

  - isisSysLevel

       This table contains information specific to a domain(Level-2) or
       an area(Level-1) of the IS-IS protocol.

2, isisSysLevelTable mibs should be placed after isisRedistributeAddrTable.

3, isisLSPTTLVType should be isisLSPTLVType

4, isisLSPId should be isisLSPID to sync with isisTrapLSPID, isisSysID,
   CircuitID...

Thank you,

								kay