Subject: [Isis-wg] MIB: Need for isisRedistributeAddrTable

From: "Don Goodspeed" <[email-masked]>
Date: Tue, 8 Oct 2002 20:20:22 -0400 (EDT)

Jeff and all,

I think I can clarify the usefulness of this table.  We can use
the table to show what routes "are" being leaked based on policies
for leaking that are defined elsewhere.  We can keep the ExistState
attribute, although some implementation may not allow it to be
controlled via SNMP.

We should also include an isisRedistributeType attribute (not part
of the index) for controlling whether this route prefix is automatic
or manual.  Some implementation will not allow this to be set via
SNMP either (they'll always have only automatic routes in this table).

Finally, we should dual-purpose the table and also show which routes are
being leaked from L1 into L2 as well.  Since a route can be leaked in
only one direction, this does not need to be part of the index, and it's
only two values would be leakL1ToL2(1) or leakL2ToL1(2).  It would
also be read-create, and have the same caveat that some implementations
may implement this as read-only.

I hope this will work for everyone
-don

 --- On Tue 10/08, Jeff Parker  wrote:
From: Jeff Parker [mailto: [email-masked]]
To: [email-masked]
Date: Tue, 8 Oct 2002 14:54:41 -0400
Subject: [Isis-wg] Don's MIB ToDo list

> 4)  isisRedistributeAddrTable - platform
> > independence cannot probably be achieved.  
> > Every vendor
> > usually has leaking tied into route policies since
> > route ranges can come into play as well as only leaking
> > internal vs external ISIS routes, etc.
> 
> I see Don's point, though I would like to think
> we could retain something.  Any suggestions?  Here
> is a snapshot of the contents.  
> 
> -- The Redistribution table defines addresses that should be leaked from
> -- L2 to L1 if isisSysL2toL1Leaking is enabled.
> 
>     isisRedistributeAddrTable OBJECT-TYPE
>         SYNTAX SEQUENCE OF IsisRedistributeAddrEntry
>         MAX-ACCESS not-accessible
>         STATUS current
>         DESCRIPTION
>             "This table provides criteria to decide if a route
> should
>              be leaked from L2 to L1 when Domain Wide Prefix leaking is
>              enabled.
> 
>              Addresses that match the summary mask in the table will
>              be announced at L1 by routers when isisSysL2toL1Leaking
>              is enabled.  Routes that fall into the ranges specified
>              are are announced as is, without being summarized."
>     ::= { isisSystem 6 }
>     ....
>     IsisRedistributeAddrEntry ::=
>         SEQUENCE {
>             isisRedistributeAddrType
>                 InetAddressType,
>             isisRedistributeAddrAddress
>                 InetAddress,
>             isisRedistributeAddrPrefixLen
>                 InetAddressPrefixLength,
>             isisRedistributeAddrExistState
>                 RowStatus
>         }

------------------------------------------------
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Laura Liu <[email-masked]>
Date: Wed, 9 Oct 2002 09:25:59 -0500

Don,

It seems to me that you want to keep isisRedistributeAddrTable for the
routes leaking between ISIS levels; and use isisIPRATable for OTHER prefixes
that are redistributed into ISIS. Those prefixes could be manually
configured or learned from other routing protocols like OSPF and BGP etc.
This makes sense to prevent the same prefix being monitored in both tables.
I think we only need a new attribute isisLeakDirection in
isisRedistributeAddrTable and keep the isisIPRAType in isisIPRATable.
isisRedistributeAddrTable does not need isisRedistributeType attribute.

Laura

> -----Original Message-----
> From: Don Goodspeed [mailto:[email-masked]]
> Sent: Tuesday, October 08, 2002 7:20 PM
> To: [email-masked]; [email-masked]
> Subject: [Isis-wg] MIB: Need for isisRedistributeAddrTable
> 
> 
> 
> Jeff and all,
> 

----------------------------------------- (on rchss001)

This e-mail and any files transmitted with it are the property
of Chiaro Networks, Ltd., and may contain confidential and 
privileged material for the sole use of the intended recipient(s)
to whom this e-mail is addressed. If you are not one of the named
recipient(s), or otherwise have reason to believe that you have 
received this message in error, please notify the sender and 
delete all copies from your system.  Any other use, retention, 
dissemination, forwarding, printing or copying of this e-mail is 
strictly prohibited.

---------------------------------------------------------

---

From: "Don Goodspeed" <[email-masked]>
Date: Wed, 9 Oct 2002 15:56:07 -0400 (EDT)

I agree.

On a separate note, I still wonder if we should just make this table
completely read-only.

-don

 --- On Wed 10/09, Laura Liu  wrote:
From: Laura Liu [mailto: [email-masked]]
To: [email-masked], [email-masked], [email-masked]
Date: Wed, 9 Oct 2002 09:25:59 -0500
Subject: RE: [Isis-wg] MIB: Need for isisRedistributeAddrTable