Subject: [Isis-wg] Don's MIB ToDo list

From: Jeff Parker <[email-masked]>
Date: Tue, 8 Oct 2002 14:54:41 -0400

For those keeping score at home, what is left from Don's 
suggestions today.  There are a half-dozen remaining 
points, with some thoughts on each.  

1) isisLSPTable - On the todo list.  May not make it into 
version 10 of mib.  

2) isisSysOverloadTimeLeft - I think I had this once, and I'm
trying to remember why it disappeared.   

3) OperStatus is in the isisSys table and isisCircTable.
Again, I think we had this once, and I wonder why
it isn't there now.  

4)  isisRedistributeAddrTable - platform
> independence cannot probably be achieved.  
> Every vendor
> usually has leaking tied into route policies since
> route ranges can come into play as well as only leaking
> internal vs external ISIS routes, etc.

I see Don's point, though I would like to think
we could retain something.  Any suggestions?  Here
is a snapshot of the contents.  

-- The Redistribution table defines addresses that should be leaked from
-- L2 to L1 if isisSysL2toL1Leaking is enabled.

    isisRedistributeAddrTable OBJECT-TYPE
        SYNTAX SEQUENCE OF IsisRedistributeAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "This table provides criteria to decide if a route should
             be leaked from L2 to L1 when Domain Wide Prefix leaking is
             enabled.

             Addresses that match the summary mask in the table will
             be announced at L1 by routers when isisSysL2toL1Leaking
             is enabled.  Routes that fall into the ranges specified
             are are announced as is, without being summarized."
    ::= { isisSystem 6 }
    ....
    IsisRedistributeAddrEntry ::=
        SEQUENCE {
            isisRedistributeAddrType
                InetAddressType,
            isisRedistributeAddrAddress
                InetAddress,
            isisRedistributeAddrPrefixLen
                InetAddressPrefixLength,
            isisRedistributeAddrExistState
                RowStatus
        }

5) Add 3WayAdjState as well as isisISAdjState.
I had hoped this could be combined.  Will re-read RFC. 

- jeff parker
- axiowave networks
- echo
'[q]sa[ln0=aln256%Pln256/snlbx]sb3135071790101768542287578439snlbxq'|dc

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Rajesh Saluja <[email-masked]>
Date: Wed, 9 Oct 2002 04:49:57 +0100 (BST)

Jeff Parker <[email-masked]> wrote: 

Jeff,

3 way state is different from 10589 adjacency state.

Thanks,

Rajesh

 Yahoo! Properties Special  Buy, sell, rent...your flat, or even post an ad