Subject: RE: [Isis-wg] Autoencap and Re: Last Call: Routing IPv6 with IS-I S to Informational

From: Jeff Parker <[email-masked]>
Date: Tue, 3 Jun 2003 09:53:24 -0400

>  - to share the same DR within the level, always setup adjacency
>    with everyone on the LAN to elect a stable DR, but label the
>    adjacency useable or unusable base on the address-family and/or
>    topology sets. announce or don't announce the adjacency in LSP
>    accordingly. as long as a system performs backlink checks in
>    spf computation, this scheme should work just fine.
 
Sharing my ignorance again, I'm not sure I understand this.

Assume that we have three routers: 

	A	IPv4 & IP v6
	B	IPv4
	C	IPv6

Assume A winds up being DIS.
B forms adjacency with only A.  Advertises link to PNode
A forms adjacency with B and C.  A's PNode shows link to A, B, C.  
C forms adjacency with only A.  Advertises link to PNode

Running the SPF, it isn't enough to look at links: they
should all be there.  Don't I need to check the protocol
supported bits in the LSPs as well?

- jeff parker
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Philip Christian <[email-masked]>
Date: Tue, 3 Jun 2003 15:04:23 +0100 (BST)

Autoencap only works because SPF doesn't consider
protocol supported.  Some people don't agree with
this, but hey, I didn't write RFC 1195.  I just took
advantage of that clause.

The example you cite works because the dual node is
the highest priority.  If the dual node is the lowest
priority it also works.  If it is between the two then
things mess up.

Philip

 --- Jeff Parker <[email-masked]> wrote: >  
> supported bits in the LSPs as well?

__________________________________________________
Yahoo! Plus - For a better Internet experience
http://uk.promotions.yahoo.com/yplus/yoffer.html
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg