Subject: [Isis-wg] CSNPs in draft-ietf-isis-restart-03.txt

From: Jeff Parker <[email-masked]>
Date: Sat, 21 Jun 2003 14:28:14 -0400

Since I opened this can of worms, I should try to get the worms back in the
can.  Thanks to Mike and Les for sorting this out for me.

> what would be the "right" mechanism to track down a missing CSNP ? 
> i.e. if i send the following CSNPs 
> 
> e.g. CNSP #1 0000.0000.0000.00-00 -> 1111.1111.1111.00-00
>      CSNP #2 2222.2222.2222.00-00 -> 3333.3333.3333.00-00
>      CSNP #3 4444.4444.4444.00-00 -> ffff.ffff.ffff.00-00

As you noted, this does not cover the range from 00....00 to FF.....FF.  If
there is a LAN client X that is not the DIS is holding LSP
1111.1111.1112.0000, X would not be forced to flood the missing LSP. 
 
> one way of solving that is to "chain" the CSNPs i.e. the end-LSP-id is
> the start LSP-id of the next CSNP;
> 
> e.g. CNSP #1 0000.0000.0000.00-00 -> 1111.1111.1111.00-00
>      CSNP #2 1111.1111.1111.00-00 -> 3333.3333.3333.00-00
>      CSNP #3 3333.3333.3333.00-00 -> ffff.ffff.ffff.00-00
> 
> /hannes

This meets the requirements from 7.3.15.3:

	A complete set of CSNPs is a set whose Start 
	LSPID and End LSPID ranges cover the complete 
	possible range of LSPIDs. (i.e. there is no 
	possible LSPID value which does not appear 
	within the range of one of the CSNPs in the set).  

However, it is possible to meet this condition without repeating an LSP ID,
so receivers cannot depend on seeing the overlaps to decide if the sequence
is complete.  

One such abutting sequence increments the last LSPID in the previous CSNP
fragment, as below.  

CNSP #1 0000.0000.0000.00-00 -> 1111.1111.1111.00-00
CSNP #2 1111.1111.1111.00-01 -> 3333.3333.3333.00-00
CSNP #3 3333.3333.3333.00-01 -> ffff.ffff.ffff.ff-ff

- jeff parker

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Tony Przygienda <[email-masked]>
Date: Sun, 22 Jun 2003 14:40:37 +0200

>so receivers cannot depend on seeing the overlaps to decide if the sequence
and of course there is no guarantee that  (or rather requirement) that
you receive the CSNPs
in the same order they have been sent which could put you into hot water
anyway if you start
to rely on an overlap.
   
    thanks

    - tony