Subject: Re: [Isis-wg] Strange p2p adjacencies

From: Hannes Gredler <[email-masked]>
Date: Fri, 7 Jan 2005 09:42:52 +0100

On Tue, Dec 28, 2004 at 04:36:20PM +0530, Abhishek Verma wrote:
| Hi,
| 
| In broadcast media by default we form both L1 and L2 adjacencies and
| never one L1/L2 adjacency. So we can have 2 kinds of adjacencies in
| broadcast media - L1 only and L2 only. Two routers can either have any
| one of these or both of these.
| 
| But why in point-to-point do we have either (i) L1 only (ii) L2 only
| and (iii) L1/L2.
| 
| Why dont we have two adjacencies L1 and L2 between two p2p links? Why
| do we have just one L1/L2 adjacency?

on p2p links there is just one IIH codepoint (17) shared for
L1/L2 hellos - contrary to bcast media where there is 
a dedicated codepoint per Level (15,16);

/hannes

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Fri, 7 Jan 2005 09:46:35 +0100

On Tue, Dec 28, 2004 at 06:26:52PM +0530, Abhishek Verma wrote:
| Hemanth,
| 
| This tells me why we can have only one kind of adjacency in P2P links.
| And thanks for that!
| 
| But why is this so? Why has ISIS been so designed? Why do we then have
| 2 kinds of adjacencies in Broadcast media?
| 
| Any clues?

the original idea was to save bandwidth on low-bandwidth links;

given that most IS-IS adjacencies these days run on fat pipes
and control-plane processors have suffiecient CPU 
IMHO the once optimization does more harm (e.g. confusion about
per-Level passwords etc.) than good.

/hannes

---

From: Abhishek Verma <[email-masked]>
Date: Fri, 7 Jan 2005 17:03:15 +0530

Hi Hannes,

> the original idea was to save bandwidth on low-bandwidth links;

I fail to understand as to how this can result in saving the bandwidth
on low-bandwidth links? In fact it now makes things even worse. With
having two kinds of adjacecnies in broadcast networks arent we
utilizing more bandwidth.

Or did you mean that having an L1/L2 adjacency was because of lower
bandwidth requirements!

-- 

--
Class of 2004
Institute of Technology, BHU
Varanasi, India