Subject: Re: [ipwave] 802.11 Data vs 802.11 QoS Data in IPv6-over-802.11-OCB-implementations

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 7 Dec 2018 08:43:29 +0100

Re: [ipwave] 802.11 Data vs 802.11 QoS Data in 
IPv6-over-802.11-OCB-implementations

Hi IPWAVErs,

I need to let you know the following.

Recently programmers from router manufacturer informed me that a Cohda 
simulator does use QoS Data headers to transport BSM messages, and not 
Data headers.

Our agreed Internet Draft IP/OCB says that IP should use QoS Data 
headers (and not Data headers).  So Cohda simulator could easily agree 
to this Internet Draft.

For information, the headers of a BSM generated by a Cohda simulator and 
displayed by a wireshark tool are like this:

Ethernet
IPv4
UDP
CohdaWireless(proprietary)
802.11-QoSData
LLC
1609.3
1609.2(certificate, signature)
BSM(2016)

The precise packet dump is not available upon any request, because I do 
not know the precise licensing conditions from router manufacturer and 
from Cohda.

Alex

Le 15/07/2018 à 18:03, [email-masked] a écrit :
>
>
>> On Jul 15, 2018, at 7:14 AM, Alexandre Petrescu 
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> In return, as a side point, I would ask whether or not a car with IPv6
>> with "Data" headers talks to an RSU which implements IPv6 "QoS Data"
>> headers?  The answer to this would be a good information point in 
>> deciding.
>
>
> Some device drivers may choose to parse both.  Some may choose to 
> parse only one.
>
> I don’t see how this helps in deciding.
>
> Tony
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 10 Dec 2018 15:58:25 +0100

This is all good and nice, but should IP use it QoS.  The agreement in 
the group seems to be yes, and the draft reflects that agreement.

(deployed implementations vary)

Alex

Le 07/12/2018 à 20:34, Dick Roy a écrit :
> QoS is used because DCF is used (aka EDCA).  If by “LLC” below you mean 
> anything other than “EPD”, and if it doesn’t precede the 02.11 MAC 
> header, then the Cohda implementation is not standards conformant, and I 
> believe it to be.
> 
> RR
> 
> ------------------------------------------------------------------------
> 
> *From:*its [mailto:[email-masked]] *On Behalf Of *Alexandre Petrescu
> *Sent:* Thursday, December 6, 2018 11:43 PM
> *Cc:* [email-masked]; its; Abdussalam Baryun
> *Subject:* Re: [ipwave] 802.11 Data vs 802.11 QoS Data in 
> Le 15/07/2018 à 18:03, [email-masked] <mailto:[email-masked]> a écrit :
> 
>>
>>