Subject: [ipwave] Route Information Options in IPv6 Neighbor Discovery

From: "Templin (US), Fred L" <[email-masked]>
Date: Sun, 23 Dec 2018 16:23:52 +0000

Here is a draft on including Route Information Options in IPv6 Neighbor
Discovery Messages:

https://datatracker.ietf.org/doc/draft-templin-6man-rio-redirect/

It allows for including Route Information Options (RIOs) in IPv6 ND
messages other than RAs. This is useful for vehicular nodes when the
node needs to inform neighbors of its delegated prefixes using NS
and NA messages (and sometimes also RS and Redirect). With this
method, an established IPv6 ND option is used for carrying routing
information without having to define a new IPv6 ND option type.
The draft also allows for the inclusion of "attributes" with the route
in case the RIO needs to include ancillary information besides just
prefix and prefix length.

We use this for our AERO proposal which has been discussed
widely for use in Unmanned Aerial Vehicles but also have
obvious implications for other vehicular applications. Please
review the draft and post any comments or insights.

Thanks - Fred

---

From: Alexandre Petrescu <[email-masked]>
Date: Sun, 23 Dec 2018 17:30:47 +0100

Fred, I will read this.
We implement something like RIO ND options in vehicle-to-vehicle 
communications.  The first trial in cars on dedicated track is on 
January 8th.

> node needs to inform neighbors of its delegated prefixes using NS

I will look at it.

I have a doubt why they are called 'delegated' prefixes, because the 
prefixes we put in RIOs are not delegated: they are hardcoded in cars. 
(they dont pre-arrive by DHCPv6PD).

Alex

> _______________________________________________
> its mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/its
>

---

From: [email-masked]
Date: Sun, 23 Dec 2018 12:02:22 -0800

> 
> I have a doubt why they are called 'delegated' prefixes, because the prefixes we put in RIOs are not delegated: they are hardcoded in cars. (they dont pre-arrive by DHCPv6PD).

It will be interesting to see how this works with the Internet routing and addressing architecture. Is this documented somewhere?

Tony

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 24 Dec 2018 22:06:57 +0000

Hi Alex,

> -----Original Message-----
> From: its [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
> Sent: Sunday, December 23, 2018 8:31 AM
> To: [email-masked]
> Subject: Re: [ipwave] Route Information Options in IPv6 Neighbor Discovery
> 
> Fred, I will read this.

OK. It would be good to use an established IPv6 ND option if we can and
RIO is already available. That is the basis of the draft.

We are also using the option for aerial vehicles (manned and unmanned);
so far in Boeing-internal trials, but we are starting to talk about it in the
broader industry.

> (they dont pre-arrive by DHCPv6PD).

It is the same way for airplanes and unmanned air vehicles. The vehicle
has a prefix that has been pre-assigned before first use. For manned
aircraft, the proposal is to use a /32 IPv6 prefix followed by a 24-bit
aircraft serial number that is assigned to the aircraft by ICAO. So,
each aircraft has a /56 prefix that is pre-assigned.

We call it a "delegated prefix" though because it has been assigned
to the aircraft (i.e., delegated) and must be injected into the routing
system the same way that a DHCPv6 delegated prefix would be. But,
there is no requirement to use DHCPv6 PD in all scenarios. You might
also be interested to read 'draft-templin-v6ops-pdhost' and also
draft-templin-6man-dhcpv6-ndopt' which talk about prefix delegation
services other than DHCPv6 (including pre-assigned administratively
configured).

Happy Holidays, everyone.

Fred

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 24 Dec 2018 22:10:40 +0000

Hi Tony,

The vehicles (be they manned or unmanned; ground-based or aerial) need to
somehow convince the network to inject their IPv6 mobile network prefixes into
the routing system. About documentation, it works the same way as for DHCPv6
Prefix Delegation which is admittedly sparsely documented in documents such
as RFC3633.

Thanks - Fred

From: its [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Sunday, December 23, 2018 12:02 PM
To: Alexandre Petrescu <[email-masked]>
Cc: [email-masked]
Subject: Re: [ipwave] Route Information Options in IPv6 Neighbor Discovery

Tony

---

From: [email-masked]
Date: Mon, 24 Dec 2018 23:39:58 -0800

> Prefix Delegation which is admittedly sparsely documented in documents such

Fred,

Have you considered the impact on the routing system with a bunch of /56’s flying around?

I’ll just point out that most ISP’s will not accept anything longer than a /24 today.

The routing architecture scales because of prefix aggregation.

Tony

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Wed, 26 Dec 2018 15:59:40 +0000

Hi Tony,

Yes, I am not suggesting to inject the /56’s into the ISP’s network. I am
suggesting an overlay network where the /56’s are only tracked in the
overlay. See the following RTGWG document for more information:

https://datatracker.ietf.org/doc/draft-ietf-rtgwg-atn-bgp/

Thanks - Fred

From: its [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 24, 2018 11:40 PM
To: Templin (US), Fred L <[email-masked]>
Cc: Alexandre Petrescu <[email-masked]>; [email-masked]
Subject: Re: [ipwave] Route Information Options in IPv6 Neighbor Discovery

Fred,

Tony

---

From: Tony Li <[email-masked]>
Date: Wed, 26 Dec 2018 08:32:41 -0800

Happy, happy, joy, joy!

Thanks Fred!

Tony

On Wed, Dec 26, 2018 at 8:00 AM Templin (US), Fred L <
[email-masked]> wrote:

> *From:* its [mailto:[email-masked]] *On Behalf Of [email-masked]
> *Sent:* Monday, December 24, 2018 11:40 PM
> *To:* Templin (US), Fred L <[email-masked]>
> *Cc:* Alexandre Petrescu <[email-masked]>; [email-masked]
>
>
> *Subject:* Re: [ipwave] Route Information Options in IPv6 Neighbor
> Discovery
>
>
>
>
>
>
>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Fri, 28 Dec 2018 16:40:56 +0000

I take it you approve, then. Thank you also for giving us BGP; I don’t
think most people realize how versatile a service it really is, and our
draft is just one example.

Thanks - Fred

From: Tony Li [mailto:[email-masked]]
Sent: Wednesday, December 26, 2018 8:33 AM
To: Templin (US), Fred L <[email-masked]>
Cc: Alexandre Petrescu <[email-masked]>; [email-masked]
Subject: Re: [ipwave] Route Information Options in IPv6 Neighbor Discovery

Happy, happy, joy, joy!

Thanks Fred!

Tony

On Wed, Dec 26, 2018 at 8:00 AM Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
Hi Tony,

Thanks - Fred

From: its [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Monday, December 24, 2018 11:40 PM
To: Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>
Cc: Alexandre Petrescu <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Fred,

Tony