Subject: [Jmap] Publication has been requested for draft-ietf-jmap-smime-07

From: Bron Gondwana via Datatracker <[email-masked]>
Date: Thu, 19 Aug 2021 05:22:48 -0700

Bron Gondwana has requested publication of draft-ietf-jmap-smime-07 as Proposed Standard on behalf of the JMAP working group.

Please verify the document's state at https://datatracker.ietf.org/doc/draft-ietf-jmap-smime/

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sat, 21 Aug 2021 15:24:32 -0700

Hi all, here's my AD review for this short document:

Please use the correct boilerplate text for BCP 14.  You've got the old
version here.

I suggest using "specification" rather than "spec" (e.g., in Section 3).
And while I'm at it, it might be helpful to identify RFC 8620 as JMAP at
its first use in Section 2, because then in Section 3 you refer to "the
JMAP spec" but it's not clear which one that is.

In Section 4, for "smimeStatus", mapping unrecognized values to
"signal/failed" seems a curious choice.  Why not allow only "unknown"?

For Section 4, I suggest (but you don't have to) giving each property a
separate subsection.

Otherwise this is in good shape.  The above things are minor enough that
you can just handle them as Last Call comments, and I'll go request that
now.

-MSK

On Thu, Aug 19, 2021 at 5:22 AM Bron Gondwana via Datatracker <
[email-masked]> wrote:

> Bron Gondwana has requested publication of draft-ietf-jmap-smime-07 as
> Proposed Standard on behalf of the JMAP working group.
>
> Please verify the document's state at
> https://datatracker.ietf.org/doc/draft-ietf-jmap-smime/
>
>
>

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 23 Aug 2021 12:22:57 +0100

Hi Murray,

Thank you for your review.

On 21/08/2021 23:24, Murray S. Kucherawy wrote:
> Please use the correct boilerplate text for BCP 14.  You've got the 
> old version here.
Fixed in my copy.
> I suggest using "specification" rather than "spec" (e.g., in Section 3).
Changed.
> And while I'm at it, it might be helpful to identify RFC 8620 as JMAP 
> at its first use in Section 2, because then in Section 3 you refer to 
> "the JMAP spec" but it's not clear which one that is.
Good point. I corrected that.
> "signal/failed" seems a curious choice.  Why not allow only "unknown"?
I think it depends on the application. If one wants to enforce presence 
of valid S/MIME signatures, anything which is unrecognized is 
"signed/failed" in a way. But I don't have a strong feeling and can 
change this.
> For Section 4, I suggest (but you don't have to) giving each property 
> a separate subsection.
I will have a look how much work this is. I might ask RFC Editor ;-).

Best Regards,

Alexey

> Otherwise this is in good shape.  The above things are minor enough 
> that you can just handle them as Last Call comments, and I'll go 
> request that now.
>
> -MSK
>
>
>
> On Thu, Aug 19, 2021 at 5:22 AM Bron Gondwana via Datatracker 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Bron Gondwana has requested publication of
>     draft-ietf-jmap-smime-07 as Proposed Standard on behalf of the
>     JMAP working group.
>
>     <https://datatracker.ietf.org/doc/draft-ietf-jmap-smime/>
>
>
>
> _______________________________________________
> Jmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jmap