Subject: [jose] Initial Versions of JOSE Specs submitted

From: Mike Jones <[email-masked]>
Date: Tue, 17 Jan 2012 08:50:24 +0000

I've submitted initial IETF versions of the JOSE<http://datatracker.ietf.org/wg/jose/> specs.  Once the postings are approved by the chairs, they'll appear as IETF -00 drafts.  These specs are:

*        JSON Web Signature (JWS) - Digital signature/HMAC specification

*        JSON Web Encryption (JWE) - Encryption specification

*        JSON Web Key (JWK) - Public key specification

*        JSON Web Algorithms (JWA) - Algorithms and identifiers specification

They are refactored from the previous individual submission versions to move algorithms and identifiers into a separate specification, per the working group charter<http://datatracker.ietf.org/wg/jose/charter/>.  Also, per the working group's input, the terminology usage has been changed to no longer call both digital signatures and HMACs "signatures".  The JOSE versions contain no normative changes from the individual submission versions.

I've also posted submitted drafts at these locations:

*        http://self-issued.info/docs/draft-ietf-jose-json-web-signature-00.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-encryption-00.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-key-00.html

*        http://self-issued.info/docs/draft-ietf-jose-json-web-algorithms-00.html

                                                            -- Mike

---

From: Mike Jones <[email-masked]>
Date: Wed, 18 Jan 2012 21:49:46 +0000

FYI, the posted IETF versions are now available at these locations:

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-signature-00

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-encryption-00

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-key-00

*        http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-00

                                                            -- Mike

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Mike Jones
Sent: Tuesday, January 17, 2012 12:50 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [jose] Initial Versions of JOSE Specs submitted

                                                            -- Mike