Subject: [jose] JWE and the Initialisation Vector (iv)

From: "Vladimir Dzhuvinov / NimbusDS" <[email-masked]>
Date: Tue, 03 Apr 2012 02:11:30 -0700

Hi guys,

http://tools.ietf.org/html/draft-ietf-jose-json-web-encryption-01#section-8.2

says "for GCM, the random 64-bit IV is prepended to the ciphertext."

Isn't the JWE "iv" header parameter meant to store the IV bytes?

Vladimir
--
Vladimir Dzhuvinov : www.NimbusDS.com : [email-masked]

---

From: Mike Jones <[email-masked]>
Date: Thu, 5 Apr 2012 15:07:28 +0000

Yes, the language about "prepended" is in error, and will be removed in the next draft.

Thanks for the comments based upon your implementation work!

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vladimir Dzhuvinov / NimbusDS
Sent: Tuesday, April 03, 2012 2:12 AM
To: [email-masked]
Subject: [jose] JWE and the Initialisation Vector (iv)

Hi guys,

Vladimir

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose