Subject: Re: [jose] ECDH-ES in Java for JWE

From: "Vladimir Dzhuvinov / NimbusDS" <[email-masked]>
Date: Fri, 01 Jun 2012 05:25:54 -0700

Thank you Axel. I had a quick look at the code to see what it would take
to incorporate it into Nimbus-JWT and looks OK.

I suppose we don't have any normative test vectors for ECDH-ES yet?

Vladimir

--
Vladimir Dzhuvinov : www.NimbusDS.com : [email-masked]

-------- Original Message --------
Subject: ECDH-ES in Java for JWE
From: <[email-masked]>
Date: Thu, May 31, 2012 4:06 pm
To: <[email-masked]>, <[email-masked]>

I whipped something up that I think is not completely bogus.

Encryption:
https://code.google.com/p/openinfocard/source/browse/trunk/src/org/xmldap/json/WebToken.java#699

Decryption:
https://code.google.com/p/openinfocard/source/browse/trunk/src/org/xmldap/json/WebToken.java#644

KDFConcatGenerator:
https://code.google.com/p/openinfocard/source/browse/trunk/src/org/xmldap/crypto/KDFConcatGenerator.java

JUNIT test cases:
https://code.google.com/p/openinfocard/source/browse/trunk/testsrc/org/xmldap/json/WebTokenTest.java#723

I know the code needs more work to make it adhere to the spec. Currently
I am not using the epk field but x and y but the semantic should be the
same I hope.

Have fun
Axel

---

From: <[email-masked]>
Date: Fri, 1 Jun 2012 15:49:57 +0200

Just posted this http://ignisvulpis.blogspot.de/2012/06/ecdh-es-for-json-web-encryption.html which contains more details and some test values.
Although I would not call them normative.
Would be good to have another implementation to verify my interpretation of the spec.

-----Original Message-----
From: Vladimir Dzhuvinov / NimbusDS [mailto:[email-masked]] 
Sent: Friday, June 01, 2012 2:26 PM
To: Nennker, Axel; [email-masked]
Subject: RE: ECDH-ES in Java for JWE

Thank you Axel. I had a quick look at the code to see what it would take to incorporate it into Nimbus-JWT and looks OK.

Vladimir

-------- Original Message --------
Subject: ECDH-ES in Java for JWE
From: <[email-masked]>
Date: Thu, May 31, 2012 4:06 pm
To: <[email-masked]>, <[email-masked]>

Encryption:

Decryption:

KDFConcatGenerator:

JUNIT test cases:

I know the code needs more work to make it adhere to the spec. Currently I am not using the epk field but x and y but the semantic should be the same I hope.

Have fun
Axel