Subject: [jose] JWK kid spec

From: "Vladimir Dzhuvinov / NimbusDS" <[email-masked]>
Date: Mon, 17 Sep 2012 23:58:40 -0700

Hi guys,

I'm currently updating the Nimbus-JWT library to the new spec set and
been going through the recent revisions.

Regarding JWK-05, section 4.3 on "kid".

***
The "kid" (key ID) member can be used to match a specific key.  This
can be used, for instance, to choose among a set of keys within the
JWK during key rollover.
***

Wouldn't be more correct to say 

***
The "kid" (key ID) member can be used to match a specific key.  This
can be used, for instance, to choose a key within a JWK Set during 
key rollover.
***

I suppose this is a remainder from when JWK used to refer to the whole
set.

Cheers,

Vladimir

--
Vladimir Dzhuvinov : www.NimbusDS.com : [email-masked]

---

From: Mike Jones <[email-masked]>
Date: Tue, 18 Sep 2012 16:02:35 +0000

Yes - thanks.  I'll update the language as you suggest in the current round of edits.

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vladimir Dzhuvinov / NimbusDS
Sent: Monday, September 17, 2012 11:59 PM
To: [email-masked]
Subject: [jose] JWK kid spec

Hi guys,

I'm currently updating the Nimbus-JWT library to the new spec set and been going through the recent revisions.

***
The "kid" (key ID) member can be used to match a specific key.  This can be used, for instance, to choose among a set of keys within the JWK during key rollover.
***

***
The "kid" (key ID) member can be used to match a specific key.  This can be used, for instance, to choose a key within a JWK Set during key rollover.
***

I suppose this is a remainder from when JWK used to refer to the whole set.

Cheers,

Vladimir

--
Vladimir Dzhuvinov : www.NimbusDS.com : [email-masked] _______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose