Subject: [jose] JWE -06: Terminology - JWE IV and integrity value

From: "Vladimir Dzhuvinov / NimbusDS" <[email-masked]>
Date: Tue, 16 Oct 2012 02:33:24 -0700

Thank you guys for pushing the updates specs out.

Regarding JWE -06 section 2. Terminology:

It could be helpful to mention for "JWE Initialization Vector" and "JWE
Integrity Values" that these can also be empty, like said for "JWE
Encrypted Key".

Vladimir

--
Vladimir Dzhuvinov : www.NimbusDS.com : [email-masked]

---

From: Mike Jones <[email-masked]>
Date: Tue, 16 Oct 2012 16:13:30 +0000

There's currently no actual case where the JWE Initialization Vector or JWE Integrity Value can be empty, because an Initialization Vector is used for all the defined "enc" algorithms - (CBC, GCM) and all of them have an integrity value.

However, this could be true for future algorithms.  Is that what you're thinking?

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vladimir Dzhuvinov / NimbusDS
Sent: Tuesday, October 16, 2012 2:33 AM
To: [email-masked]
Subject: [jose] JWE -06: Terminology - JWE IV and integrity value

It could be helpful to mention for "JWE Initialization Vector" and "JWE Integrity Values" that these can also be empty, like said for "JWE Encrypted Key".

Vladimir

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose