Subject: [jose] #81: Section 5. String Comparison Rules

From: "jose issue tracker" <[email-masked]>
Date: Sun, 18 Aug 2013 19:55:30 -0000

#81: Section 5. String Comparison Rules

 A. JSON mailing list has been arguing this out.  If we don't refer to the
 updated document, then we should at least get the updated language from
 them about how to do the comparisons.

 B. Point to JWS for a single location about how to do string comparisons

 C. Is this an issue for comparing values as well as names?  If so then it
 should be said so.

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-ietf-jose-json-web-
  [email-masked] |  [email-masked]
     Type:  defect       |     Status:  new
 Priority:  major        |  Milestone:
Component:  json-web-    |    Version:
  key                    |   Keywords:
 Severity:  -            |
-------------------------+-------------------------------------------------

Ticket URL: <https://grenache.tools.ietf.org/wg/jose/trac/ticket/81>
jose <http://tools.ietf.org/jose/>

---

From: "jose issue tracker" <[email-masked]>
Date: Wed, 21 Aug 2013 22:13:18 -0000

Comment (by [email-masked]):

 What is the updated JSON string comparison language that should be used?

  key                    |  Resolution:
 Keywords:               |

Ticket URL: <http://trac.tools.ietf.org/wg/jose/trac/ticket/81#comment:1>
jose <http://tools.ietf.org/jose/>

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 21 Aug 2013 17:18:31 -0700

I cannot find the final resolution on the JSON list, but this was the list
of options that were given

**********

There are four proposals for establishing name equality:

0) Leave the current draft as-is, not discussing name equality

1) In Section 2.5 ("Strings"), immediately before the ABNF add:
   For purpose of establishing name equality, comparisons MUST be conducted,
after all unescaping
   is done, by comparing numeric character code points. There is to be no
modification of any
   kind to the characters in names, including case-changing or
combining-form normalization.
   For example, the following four names MUST be considered equivalent:
    * "\u002F"
    * "\u002f"
    * "\/"
    * "/"

2) In Section 2.5 ("Strings"), immediately before the ABNF add:
   For purpose of establishing name equality, comparisons MUST be conducted,
after all unescaping
   is done, by comparing numeric character code points. There MUST NOT be
any modification of any
   kind to the characters in names, including change of case or change
between precomposed and
   decomposed forms.
   For example, the following four names MUST be considered equivalent:
    * "\u002F"
    * "\u002f"
    * "\/"
    * "/"

3) In Section 2.5 ("Strings"), immediately before the ABNF add:
   For purpose of establishing name equality, implementations MUST first do
all unescaping and
   then MUST compare numeric character code points. There is to be no
modification of any kind to
   the characters in names, including case-changing or combining-form
normalization.
   For example, the following four names MUST be considered equivalent:
    * "\u002F"
    * "\u002f"
    * "\/"
    * "/"

Please respond to this message with a list of proposals you could accept,
ordered from highest to lowest. Do not list proposals you cannot live with.
If you cannot accept any of the proposals, please respond and say why.

Based on the responses we receive, we will try to judge the consensus of the
WG.

-- The JSON WG co-chairs

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> jose issue tracker
> Sent: Wednesday, August 21, 2013 3:13 PM
> To: [email-masked];
> [email-masked]
> Cc: [email-masked]
> Subject: Re: [jose] #81: Section 5. String Comparison Rules
> 
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose