Subject: Re: [jose] #53: Use "SEC1" format for elliptic curve keys

From: Mike Jones <[email-masked]>
Date: Tue, 1 Oct 2013 23:51:46 +0000

That makes sense.  I'm fine with adding a note saying that point compression isn't supported.

				-- Mike

-----Original Message-----
From: Jim Schaad [mailto:[email-masked]] 
Sent: Tuesday, October 1, 2013 4:17 PM
To: Mike Jones; [email-masked]; Richard Barnes
Cc: [email-masked]
Subject: RE: [jose] #53: Use "SEC1" format for elliptic curve keys

I would agree this is a true statement for the zero point - because it is not a valid thing to have for a point.  However I think it might be useful to state that we don't support point compression because people know it exists and most formats that deal with point representation do support it.  This means we are different from the expected and stating so is useful.

Jim

> -----Original Message-----
> From: Mike Jones [mailto:[email-masked]]
> Sent: Monday, September 30, 2013 12:34 AM
> To: jose issue tracker; 
> [email-masked];
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [jose] #53: Use "SEC1" format for elliptic curve keys
> 
> The text says what the content of the fields must be.  There's no need 
> to enumerate all the things that do not conform to the requirements 
> stated in the spec.
> 
> 				-- Mike
> 
> -----Original Message-----
> From: jose issue tracker [mailto:[email-masked]]
> Sent: Sunday, September 29, 2013 7:36 PM
> To: [email-masked];
> [email-masked]
> Cc: [email-masked]
> Subject: Re: [jose] #53: Use "SEC1" format for elliptic curve keys
> 
> #53: Use "SEC1" format for elliptic curve keys
> 
> 
> Comment (by [email-masked]):
> 
>  Applied patch does not include the text for compressed points or for 
> the zero point being unacceptable.  Need to validate with Richard that 
> this is not a problem.
> 
> --
> -------------------------+--------------------------------------------
> -------------------------+--
> -------------------------+---
>  Reporter:  [email-masked]   |       Owner:  draft-ietf-jose-json-web-
>      Type:  defect       |  [email-masked]
>  Priority:  major        |      Status:  new
> Component:  json-web-    |   Milestone:
>   algorithms             |     Version:
>  Severity:  -            |  Resolution:
>  Keywords:               |
> -------------------------+--------------------------------------------
> -------------------------+--
> -------------------------+---
> 
> Ticket URL: 
> <http://trac.tools.ietf.org/wg/jose/trac/ticket/53#comment:1>
> jose <http://tools.ietf.org/jose/>

---

From: "jose issue tracker" <[email-masked]>
Date: Mon, 14 Oct 2013 14:17:09 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

Comment:

 States compression is not allowed - so this is now all done

-- 
-------------------------+-------------------------------------------------
 Reporter:  [email-masked]   |       Owner:  draft-ietf-jose-json-web-
     Type:  defect       |  [email-masked]
 Priority:  major        |      Status:  closed
Component:  json-web-    |   Milestone:
  algorithms             |     Version:
 Severity:  -            |  Resolution:  fixed
 Keywords:               |
-------------------------+-------------------------------------------------

Ticket URL: <http://tools.ietf.org/wg/jose/trac/ticket/53#comment:2>
jose <http://tools.ietf.org/jose/>