Subject: Re: [jose] I-D Action: draft-ietf-jose-use-cases-05.txt

From: Richard Barnes <[email-masked]>
Date: Fri, 4 Oct 2013 13:14:13 -0400

Chairs/AD: Should I go ahead and rev this, or handle these along with IETF
LC comments?

On Thu, Sep 12, 2013 at 8:16 PM, Sean Turner <[email-masked]> wrote:

> I'm just nitting for now:
>
> 1) s2
>
> OLD:
>
> The JOSE working group charter calls for the group to define three basic
> JSON object formats:
>
> NEW:
>
> Three basic JSON object formats are initially defined, with more possibly
> defined later:
>
> 2) s2
>
> OLD:
>
> The JOSE working group items intended to describe these formats are JSON
> Web Signature (JWS), JSON Web Encryption (JWE), and JSON Web Key (JWK),
> respectively [I-D.ietf-jose-json-web-**signature] [I-D.ietf-jose-json-web-
> **encryption] [I-D.ietf-jose-json-web-key].
>
> NEW:
>
> The JSON Web Signature (JWS), JSON Web Encryption (JWE), and JSON Web Key
> (JWK) specifications, respectively [I-D.ietf-jose-json-web-**signature]
> [I-D.ietf-jose-json-web-**encryption] [I-D.ietf-jose-json-web-key],
> define these formats.
>
> 3) s3: Not sure the following is entirely correct for DH-based algs:
>
>  o  The JOSE encrypted object format must support object encryption in
>     the case where the sender has only a public key for the receiver.
>
> Shouldn't this also include the case where the sender has their own public
> key and the receiver's public key.
>
> spt
>
>
>
> ______________________________**_________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/jose<https://www.ietf.org/mailman/listinfo/jose>
>

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 4 Oct 2013 13:50:56 -0700

I have already responded on item 3.   1 & 2 should be deal with as part of
either AD comments or IETF last comments.  Id on't see these as blocking
right now.

Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Richard Barnes
Sent: Friday, October 04, 2013 10:14 AM
To: Sean Turner
Cc: [email-masked]
Subject: Re: [jose] I-D Action: draft-ietf-jose-use-cases-05.txt

1) s2

OLD:

NEW:

2) s2

OLD:

The JOSE working group items intended to describe these formats are JSON Web
Signature (JWS), JSON Web Encryption (JWE), and JSON Web Key (JWK),
respectively [I-D.ietf-jose-json-web-signature]
[I-D.ietf-jose-json-web-encryption] [I-D.ietf-jose-json-web-key].

NEW:

The JSON Web Signature (JWS), JSON Web Encryption (JWE), and JSON Web Key
(JWK) specifications, respectively [I-D.ietf-jose-json-web-signature]
[I-D.ietf-jose-json-web-encryption] [I-D.ietf-jose-json-web-key], define
these formats.

spt

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose

---

From: Richard Barnes <[email-masked]>
Date: Mon, 7 Oct 2013 15:37:18 -0400

OK, I'm going to plan to handle these along with IETF LC comments, and not
take any action right now.
--Richard

On Fri, Oct 4, 2013 at 4:50 PM, Jim Schaad <[email-masked]> wrote:

> either AD comments or IETF last comments.  Id on’t see these as blocking
> right now.****
>
> ** **
>
> Jim****
>
> ** **
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Richard Barnes
> *Sent:* Friday, October 04, 2013 10:14 AM
> *To:* Sean Turner
> *Cc:* [email-masked]
>
> *Subject:* Re: [jose] I-D Action: draft-ietf-jose-use-cases-05.txt****
>
> ** **
>
> LC comments?****
> ** **
> On Thu, Sep 12, 2013 at 8:16 PM, Sean Turner <[email-masked]> wrote:****
>
> spt****
> https://www.ietf.org/mailman/listinfo/jose****
>
> ** **
>