Subject: [jose] typo in jwe spec

From: Antonio Sanso <[email-masked]>
Date: Mon, 31 Mar 2014 13:02:43 +0000

hi *,

section A3 of the JWE [0] spec has a typo.
The name of the section is A.3.  Example JWE using AES Key Wrap and AES_128_CBC_HMAC_SHA_256 and the content is

This example encrypts the plaintext "Live long and prosper." to the
   recipient using AES Key Wrap for key encryption and AES GCM for
   content encryption.

I think AES GCM should be replaced with AES_128_CBC_HMAC_SHA_256

regards

antonio

[0] http://tools.ietf.org/html/draft-ietf-jose-json-web-encryption-24#page-36

---

From: Mike Jones <[email-masked]>
Date: Tue, 1 Apr 2014 03:54:38 +0000

This typo has been corrected in the JOSE -25 specs.  Thanks for bringing it to our attention.

                                                                -- Mike

From: jose [mailto:[email-masked]] On Behalf Of Antonio Sanso
Sent: Monday, March 31, 2014 6:03 AM
To: [email-masked]
Subject: [jose] typo in jwe spec

hi *,

   content encryption.

regards

antonio