Subject: Re: [jose] Document Action: 'Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)' to Informational RFC (draft-ietf-jose-use-cases-06.txt)

From: Mike Jones <[email-masked]>
Date: Thu, 13 Mar 2014 18:54:32 +0000

I'd meant to ask about the status of the JOSE Use Cases document during IETF 89 and the JOSE meeting went so quickly and smoothly, it slipped my mind then to ask! :-)

Do we have any sense how close we are to having a JOSE Use Cases RFC?

Also, have the issues identified in http://www.ietf.org/mail-archive/web/jose/current/msg03817.html been addressed in the current RFC Editor draft?  If so, could someone please point us to it so that the working group can review the changes?

				Thanks,
				-- Mike

-----Original Message-----
From: Sean Turner [mailto:[email-masked]] 
Sent: Thursday, January 23, 2014 7:34 AM
To: Mike Jones
Cc: Richard Barnes; jose chair; jose mailing list; RFC Editor
Subject: Re: [jose] Document Action: 'Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)' to Informational RFC (draft-ietf-jose-use-cases-06.txt)

These are pretty minor and can be fixed during AUTH48.  Between the chairs and I we'll remember to get this edited.

spt

On Jan 15, 2014, at 07:58, Mike Jones <[email-masked]> wrote:

> Are the issues identified in http://www.ietf.org/mail-archive/web/jose/current/msg03817.html being addressed as RFC Editor notes?  If so, can you please point the working group to the editing instructions, so they can be reviewed by the working group?
> 
> 				Thanks,
> 				-- Mike
> 
> -----Original Message-----
> From: jose [mailto:[email-masked]] On Behalf Of The IESG
> Sent: Tuesday, January 14, 2014 9:32 AM
> To: IETF-Announce
> Cc: jose chair; jose mailing list; RFC Editor
> Subject: [jose] Document Action: 'Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)' to Informational RFC (draft-ietf-jose-use-cases-06.txt)
> 
> The IESG has approved the following document:
> - 'Use Cases and Requirements for JSON Object Signing and Encryption
>   (JOSE)'
>  (draft-ietf-jose-use-cases-06.txt) as Informational RFC
> 
> This document is the product of the Javascript Object Signing and Encryption Working Group.
> 
> The IESG contact persons are Sean Turner and Stephen Farrell.
> 
> A URL of this Internet Draft is:
> http://datatracker.ietf.org/doc/draft-ietf-jose-use-cases/
> 
> 
> 
> 
> Technical Summary
> 
>   This document defines a set of use cases and requirements
>   for a secure object format encoded using JavaScript Object Notation
>   (JSON), drawn from a variety of application security mechanisms
>   currently in development.
> 
> Working Group Summary
> 
>   The document represents the consuses of the working group.
>   The document was not controversial during the working group
>   discussions.
> 
> Document Quality
> 
>  The document has not had a large amount of review outside of
>  the JOSE working group.  As such it is possible that the group
>  has missed or mis-represented the set of use cases that the
>  JOSE working group needs to address when generating the
>  specifications in the group.  The OAUTH working group views
>  are well presented, but it does not have sufficient apps area review.
> 
> Personnel
> 
>   Document Shepherd is Jim Schaad
>   Area Director is Sean Turner
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: "Jim Schaad" <[email-masked]>
Date: Thu, 13 Mar 2014 14:27:12 -0700

The document is in RFC-EDITOR state.  This means that we have not yet
reached the AUTH48 state discussed below.

The document will appear when it appears.  Worrying about things until this
is not really a productive use of time.  It is even possible that it will
stick there until the rest of the JOSE documents move forward if that is a
judgment call somebody makes.  I don't expect that to happen but it is
always possible.

Jim

> From: Mike Jones [mailto:[email-masked]]
> Sent: Thursday, March 13, 2014 11:55 AM
> To: Richard Barnes
> Cc: Sean Turner; jose chair; jose mailing list; RFC Editor
> Subject: RE: [jose] Document Action: 'Use Cases and Requirements for JSON
> Object Signing and Encryption (JOSE)' to Informational RFC
(draft-ietf-jose-
> use-cases-06.txt)
> 
> I'd meant to ask about the status of the JOSE Use Cases document during
> IETF 89 and the JOSE meeting went so quickly and smoothly, it slipped my
> mind then to ask! :-)
> 
> Also, have the issues identified in http://www.ietf.org/mail-
> archive/web/jose/current/msg03817.html been addressed in the current
> RFC Editor draft?  If so, could someone please point us to it so that the
> working group can review the changes?
> 
> 				Thanks,
> 				-- Mike
> 
> Subject: Re: [jose] Document Action: 'Use Cases and Requirements for JSON
> Object Signing and Encryption (JOSE)' to Informational RFC
(draft-ietf-jose-
> use-cases-06.txt)
> > Are the issues identified in http://www.ietf.org/mail-
> archive/web/jose/current/msg03817.html being addressed as RFC Editor
> notes?  If so, can you please point the working group to the editing
> instructions, so they can be reviewed by the working group?
> >
> > 				Thanks,
> > 				-- Mike
> >
> > Subject: [jose] Document Action: 'Use Cases and Requirements for JSON
> > Object Signing and Encryption (JOSE)' to Informational RFC
> > (draft-ietf-jose-use-cases-06.txt)
> >
> >  The document has not had a large amount of review outside of  the
> > JOSE working group.  As such it is possible that the group  has missed
> > or mis-represented the set of use cases that the  JOSE working group
> > needs to address when generating the  specifications in the group.
> > The OAUTH working group views  are well presented, but it does not
> > have sufficient apps area review.
> >
> > Personnel
> >

---

From: Mike Jones <[email-masked]>
Date: Thu, 13 Mar 2014 21:30:27 +0000

My specific concern was having a window of opportunity to review the revised text before it is frozen in stone.  Specifically, I was wondering whether Richard had produced the updates addressing the identified issues, and whether he could send them to the list.

				-- Mike

-----Original Message-----
From: Jim Schaad [mailto:[email-masked]] 
Sent: Thursday, March 13, 2014 2:27 PM
To: Mike Jones
Cc: 'jose mailing list'; 'RFC Editor'
Subject: RE: [jose] Document Action: 'Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)' to Informational RFC (draft-ietf-jose-use-cases-06.txt)

The document is in RFC-EDITOR state.  This means that we have not yet reached the AUTH48 state discussed below.

The document will appear when it appears.  Worrying about things until this is not really a productive use of time.  It is even possible that it will stick there until the rest of the JOSE documents move forward if that is a judgment call somebody makes.  I don't expect that to happen but it is always possible.

Jim

> Subject: RE: [jose] Document Action: 'Use Cases and Requirements for 
> JSON Object Signing and Encryption (JOSE)' to Informational RFC
(draft-ietf-jose-
> use-cases-06.txt)
> 
> I'd meant to ask about the status of the JOSE Use Cases document 
> during IETF 89 and the JOSE meeting went so quickly and smoothly, it 
> slipped my mind then to ask! :-)
> 
> RFC Editor draft?  If so, could someone please point us to it so that 
> the working group can review the changes?
> 
> 				Thanks,
> 				-- Mike
> 
> Subject: Re: [jose] Document Action: 'Use Cases and Requirements for 
> JSON Object Signing and Encryption (JOSE)' to Informational RFC
(draft-ietf-jose-
> use-cases-06.txt)
> 
> These are pretty minor and can be fixed during AUTH48.  Between the 
> chairs and I we'll remember to get this edited.
> 
> spt
> 
> > Subject: [jose] Document Action: 'Use Cases and Requirements for 
> > JSON Object Signing and Encryption (JOSE)' to Informational RFC
> > JOSE working group.  As such it is possible that the group  has 
> > missed or mis-represented the set of use cases that the  JOSE 
> > working group needs to address when generating the  specifications in the group.

---

From: "Jim Schaad" <[email-masked]>
Date: Thu, 13 Mar 2014 16:00:31 -0700

As stated below - they will be done as part of the AUTH48 state.  Once a
document goes to the RFC Editor, authors do not produce new draft documents
to be processed.

Jim

> Sent: Thursday, March 13, 2014 2:30 PM
> To: Jim Schaad
(draft-ietf-jose-
> use-cases-06.txt)
> 
> My specific concern was having a window of opportunity to review the
> revised text before it is frozen in stone.  Specifically, I was wondering
> whether Richard had produced the updates addressing the identified issues,
> and whether he could send them to the list.
> 
> 				-- Mike
> 
(draft-ietf-jose-
> is not really a productive use of time.  It is even possible that it will
stick there
> until the rest of the JOSE documents move forward if that is a judgment
call
> somebody makes.  I don't expect that to happen but it is always possible.
> 
> Jim
> 
>