Subject: [jose] Coalescing additional duplicative terminology definitions

From: Mike Jones <[email-masked]>
Date: Thu, 19 Jun 2014 01:18:56 +0000

Dear Kathleen and JOSE working group,

The current drafts already addressed JOSE issue #58 (Remove repeated, ephemeral, or obvious terminology) to a sufficient degree that Jim closed the issue in November.  However, looking at this again with possibly fresher eyes, there's one remaining area of duplication that we may want to address.  Specifically, these related term definitions are all present:

In JWS: JWS Header, Header Parameter
In JWE: JWE Header, Header Parameter
In JWA: Header Parameter
In JWT: JWT Header, Header Parameter

It would be possible editorially to coalesce the terms JWS Header, JWE Header, and JWT header to a single JOSE Header term defined in one place.  And having done that, it would then also be possible to also replace the multiple Header Parameter definitions with a single one.

Some had expressed an interest in doing this in the past, especially when observing how having the multiple related definitions adds text to the JWT draft, and how it could similarly add such text to other specs that use both signed and encrypted JOSE objects.  Having thought about it for a while, and taking a fresh look at it, I now agree that this would be feasible, non-invasive, non-breaking, and result in improved editorial clarity.  But given how far along we are with the drafts, I didn't want to presume that I should make this change without explicitly asking if people agree with it.

Are people OK with this proposed editorial simplification, or would people prefer to leave the terminology as-is?

                                                            -- Mike

---

From: Mike Jones <[email-masked]>
Date: Fri, 20 Jun 2014 19:19:01 +0000

Based on past comments, I had expected support for this editorial action from James Manger, Richard Barnes, and probably Jim Schaad.  But all I've heard are the crickets chirping. :)

Any working group feedback, yea or nay?

From: jose [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Wednesday, June 18, 2014 6:19 PM
To: Kathleen Moriarty; [email-masked]
Subject: [jose] Coalescing additional duplicative terminology definitions

                                                            -- Mike

---

From: John Bradley <[email-masked]>
Date: Fri, 20 Jun 2014 15:54:54 -0400

I am OK with the change less duplication == more good.

On Jun 20, 2014, at 3:19 PM, Mike Jones <[email-masked]> wrote:

> Based on past comments, I had expected support for this editorial action from James Manger, Richard Barnes, and probably Jim Schaad.  But all I’ve heard are the crickets chirping. J
>  
> The current drafts already addressed JOSE issue #58 (Remove repeated, ephemeral, or obvious terminology) to a sufficient degree that Jim closed the issue in November.  However, looking at this again with possibly fresher eyes, there’s one remaining area of duplication that we may want to address.  Specifically, these related term definitions are all present:
>  
> Some had expressed an interest in doing this in the past, especially when observing how having the multiple related definitions adds text to the JWT draft, and how it could similarly add such text to other specs that use both signed and encrypted JOSE objects.  Having thought about it for a while, and taking a fresh look at it, I now agree that this would be feasible, non-invasive, non-breaking, and result in improved editorial clarity.  But given how far along we are with the drafts, I didn’t want to presume that I should make this change without explicitly asking if people agree with it.
>  
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: Nat Sakimura <[email-masked]>
Date: Fri, 20 Jun 2014 21:56:27 +0200

Are you suggesting to pull out the definitions into a separate document? 

=nat via iPhone

> On Jun 20, 2014, at 21:54, John Bradley <[email-masked]> wrote:
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 20 Jun 2014 20:13:03 +0000

No - they would be in JWS and used by JWE and JWT.  This parallels other definitions, such as the common header parameters that are already defined in JWS and referenced elsewhere.
________________________________
From: Nat Sakimura<mailto:[email-masked]>
Sent: ‎6/‎20/‎2014 12:56 PM
To: John Bradley<mailto:[email-masked]>
Cc: Mike Jones<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [jose] Coalescing additional duplicative terminology definitions

=nat via iPhone

On Jun 20, 2014, at 21:54, John Bradley <[email-masked]<mailto:[email-masked]>> wrote:

On Jun 20, 2014, at 3:19 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:

Based on past comments, I had expected support for this editorial action from James Manger, Richard Barnes, and probably Jim Schaad.  But all I’ve heard are the crickets chirping. :)

From: jose [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Wednesday, June 18, 2014 6:19 PM
To: Kathleen Moriarty; [email-masked]<mailto:[email-masked]>
Subject: [jose] Coalescing additional duplicative terminology definitions

                                                            -- Mike

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose

_______________________________________________
jose mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jose