Subject: [jose] Does A128GCMKW qualify as key wrap or encryption algorithm

From: Sergey Beryozkin <[email-masked]>
Date: Tue, 02 Sep 2014 21:47:04 +0100

Hi

JWA spec refers to the AES GCM KW family of algorithms as key encryption 
algorithms [1], in the section title. Key Wrapping with AES is referred 
to as is, Key Wrapping [2].
I replaced a test I had where Aes Key Wrap is used with AES GCM KW 
(using Java Cipher wrap internally) and it works.

I wonder is there some subtle meaning hidden in referring to [1] as the 
'key encryption' and [2] as the "key wrapping" ? Or both terms can be 
used in a context of managing the content encryption keys with either 
[1] or [2] ?

Thanks, Sergey

[1] 
https://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-31#section-4.7
[2] 
https://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-31#section-4.4.

---

From: Mike Jones <[email-masked]>
Date: Tue, 2 Sep 2014 21:01:53 +0000

Key wrapping and key encryption are the same thing.

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of Sergey Beryozkin
Sent: Tuesday, September 02, 2014 1:47 PM
To: [email-masked]
Subject: [jose] Does A128GCMKW qualify as key wrap or encryption algorithm

Hi

JWA spec refers to the AES GCM KW family of algorithms as key encryption algorithms [1], in the section title. Key Wrapping with AES is referred to as is, Key Wrapping [2].
I replaced a test I had where Aes Key Wrap is used with AES GCM KW (using Java Cipher wrap internally) and it works.

I wonder is there some subtle meaning hidden in referring to [1] as the 'key encryption' and [2] as the "key wrapping" ? Or both terms can be used in a context of managing the content encryption keys with either [1] or [2] ?

Thanks, Sergey

[1]

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose