Subject: [jose] question regarding JWE header "kid"' attribute

From: "Andrew Biggs (adb)" <[email-masked]>
Date: Tue, 7 Oct 2014 03:43:17 +0000

Section 4.1.6 of the JWE draft describes the “kid” attribute of the JWE header as a "hint [that] references the public key to which the JWE was encrypted”.  If the JWE were encrypted in direct key agreement mode, would it be incorrect for the “kid” attribute to reference the CEK used in the JWE?

Thanks,
Andrew

---

From: Mike Jones <[email-masked]>
Date: Tue, 7 Oct 2014 05:22:58 +0000

Yes, the "kid" would refer to the CEK in that case.

From: jose [mailto:[email-masked]] On Behalf Of Andrew Biggs (adb)
Sent: Monday, October 06, 2014 8:43 PM
To: [email-masked]
Subject: [jose] question regarding JWE header "kid"' attribute

Section 4.1.6 of the JWE draft describes the "kid" attribute of the JWE header as a "hint [that] references the public key to which the JWE was encrypted".  If the JWE were encrypted in direct key agreement mode, would it be incorrect for the "kid" attribute to reference the CEK used in the JWE?

Thanks,
Andrew

---

From: "Andrew Biggs (adb)" <[email-masked]>
Date: Tue, 7 Oct 2014 15:05:20 +0000

Thanks Mike!

For the sake of clarity, would it make sense to strike the word “public” from the quoted sentence, since it may potentially be a symmetric key that is being referenced?

Andrew

On 10/6/14, 11:22 PM, "Mike Jones" <[email-masked]<mailto:[email-masked]>> wrote:

Yes, the “kid” would refer to the CEK in that case.

From: jose [mailto:[email-masked]] On Behalf Of Andrew Biggs (adb)
Sent: Monday, October 06, 2014 8:43 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [jose] question regarding JWE header "kid"' attribute

Thanks,
Andrew