Subject: Re: [jose] Stephen Farrell's No Objection on draft-ietf-jose-json-web-encryption-33: (with COMMENT)

From: Mike Jones <[email-masked]>
Date: Mon, 6 Oct 2014 07:54:10 +0000

Thanks for your review, Stephen.  I've added the working group to the thread so they're aware of your comment.

> -----Original Message-----
> From: Stephen Farrell [mailto:[email-masked]]
> Sent: Thursday, October 02, 2014 3:56 AM
> To: The IESG
> Cc: [email-masked]; draft-ietf-jose-json-web-
> [email-masked]
> Subject: Stephen Farrell's No Objection on draft-ietf-jose-json-web-encryption-
> 33: (with COMMENT)
> 
> Stephen Farrell has entered the following ballot position for
> draft-ietf-jose-json-web-encryption-33: No Objection
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> http://datatracker.ietf.org/doc/draft-ietf-jose-json-web-encryption/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> 
> 1.1/3.1/7.1: I think you should define BASE64URL(null) as null so that one knows
> that one can see ".." in compact representations, e.g if there this is no AAD or
> IV. Adding an example of such would be good too. Or, if ".." is not allowed, then
> you need to say that clearly.  (This could be clarified loads of ways, I don't care
> which you pick.)

Good idea.  I'll try to figure out an appropriate place to editorially do this - maybe right at the definition.  This is definitely used in practice.

				Thanks again,
				-- Mike

---

From: Mike Jones <[email-masked]>
Date: Tue, 14 Oct 2014 12:52:24 +0000

This clarification has been applied to the -34 drafts.

				Thanks again,
				-- Mike

> From: Mike Jones [mailto:[email-masked]]
> Sent: Monday, October 06, 2014 12:54 AM
> To: Stephen Farrell; The IESG
> [email-masked]; [email-masked]
> Subject: RE: Stephen Farrell's No Objection on draft-ietf-jose-json-web-
> encryption-33: (with COMMENT)
> 
> > When responding, please keep the subject line intact and reply to all
> > email addresses included in the To and CC lines. (Feel free to cut
> > this introductory paragraph, however.)
> >
> >
> > Please refer to
> > http://www.ietf.org/iesg/statement/discuss-criteria.html
> > 1.1/3.1/7.1: I think you should define BASE64URL(null) as null so that
> > one knows that one can see ".." in compact representations, e.g if
> > there this is no AAD or IV. Adding an example of such would be good
> > too. Or, if ".." is not allowed, then you need to say that clearly.
> > (This could be clarified loads of ways, I don't care which you pick.)
> 
> Good idea.  I'll try to figure out an appropriate place to editorially do this -
> maybe right at the definition.  This is definitely used in practice.
> 
> 				Thanks again,
> 				-- Mike
>