Subject: Re: [jose] Pete Resnick's Discuss on draft-ietf-jose-json-web-signature-33: (with DISCUSS and COMMENT)

From: Mike Jones <[email-masked]>
Date: Thu, 2 Oct 2014 15:38:11 +0000

From: Kathleen Moriarty [mailto:[email-masked]]
Sent: Thursday, October 02, 2014 8:34 AM
To: Richard Barnes
Cc: Pete Resnick; Ted Lemon; John Bradley; [email-masked]; The IESG; [email-masked]
Subject: Re: Pete Resnick's Discuss on draft-ietf-jose-json-web-signature-33: (with DISCUSS and COMMENT)

On Thu, Oct 2, 2014 at 11:29 AM, Richard Barnes <[email-masked]<mailto:[email-masked]>> wrote:
On Thu, Oct 2, 2014 at 11:25 AM, Pete Resnick <[email-masked]<mailto:[email-masked]>> wrote:
On 10/2/14 10:18 AM, Ted Lemon wrote:
On Oct 2, 2014, at 11:05 AM, Pete Resnick<[email-masked]<mailto:[email-masked]>>  wrote:

If I use a instant messaging protocol that uses JWS as a payload format for signed instant messages, and in my client, when I receive a message with a broken signature, I display the message to the user but put a big red box around the message with a flashing title in the margin in 7 point Helvetica  that says, "Invalid Signature", will I have violated the JWS spec? This isn't as part of "error processing and display"; I'm displaying the text of the message to the user, but I'm marking it as invalid.

That seems like the wrong thing to do, unless you like to get a lot of nicely highlighted spam in your instant messaging client.

Very much depends on the environment and the purpose. Which is an implementation decision. "MUST reject" is, in fact, not right.

Look, the signature verification process has two outcomes:
1. This is a valid signed object
2. This is not a valid signed object
The common names for these are "accept" and "reject".  No further semantics apply.

I agree with Richard here.  If we go down the path of changing the language, then we'll have to explore qualifiers to make sure we are not introducing security risks as well.

+1 from me.  We can explore adding language saying that “reject” does not imply that error processing can’t occur, but I don’t see a compelling case for changing the accept/reject language throughout.

                                                            -- Mike

--Richard

pr

--
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478<tel:%2B1%20%28858%29651-4478>

--

Best regards,
Kathleen

---

From: Mike Jones <[email-masked]>
Date: Thu, 2 Oct 2014 17:09:07 +0000

Replies prefixed by "Mike>".

From: Pete Resnick [mailto:[email-masked]]
Sent: Thursday, October 02, 2014 9:57 AM
To: Mike Jones
Cc: Kathleen Moriarty; [email-masked]; The IESG; [email-masked]
Subject: Re: Pete Resnick's Discuss on draft-ietf-jose-json-web-signature-33: (with DISCUSS and COMMENT)

On 10/2/14 11:42 AM, Mike Jones wrote:

On 10/2/14 9:37 AM, Kathleen Moriarty wrote:

On Thu, Oct 2, 2014 at 9:20 AM, Pete Resnick <[email-masked]<mailto:[email-masked]>> wrote:

If there's anything in Section 8 that is not in 4.1.2 and needs to be, fine, move that information into 4.1.2. But TLS is not required globally. It is only required for jku. Section 8 says that TLS is required globally. AFAICT, that's not a requirement.

It is also needed for "x5u" (X.509 URL), at least in some cases.  It's more efficient editorially to have common text about TLS requirements for these multiple uses than to duplicate the text into multiple subsections.

On the telechat, we left this one as needing the WG's help here to figure out exactly where TLS is needed and making sure the requirements are clear rather than a blanket statement.  jku is one spot where it is required and the other is when there is privacy related data .  Can the WG figure out the full list and then we'll update the draft as such?

We could cite Section 8 from all the places that TLS is used, if you believe that that would help implementers pay attention, Pete.

So long as section 8 says, "Where TLS is used, it MUST do X Y Z", and the "MUST use TLS; see section 8 for how" is in the section with jky (and x5u if needed), that's cool. Just don't say "MUST use TLS" in section 8.

Mike> Sounds good.  Thanks, Pete.

                                                            -- Mike

pr

--

Pete Resnick <http://www.qualcomm.com/~presnick/><http://www.qualcomm.com/~presnick/>

Qualcomm Technologies, Inc. - +1 (858)651-4478