Subject: [jose] Fwd: New Version Notification for draft-liusvaara-jose-cfrg-curves-00.txt

From: Ilari Liusvaara <[email-masked]>
Date: Wed, 9 Dec 2015 16:42:28 +0200

Submitted this...

Regarding JOSE vs. CURDLE, I believe JOSE has priority (being existant
primary WG).

(Changes from last circulated version include note about possible
change (using just one signature algo for all OKP) and adding draft
number in order for submission to go through).

----- Forwarded message from [email-masked] -----

Date: Wed, 09 Dec 2015 05:58:08 -0800
From: [email-masked]
To: Ilari Liusvaara <[email-masked]>
Subject: New Version Notification for draft-liusvaara-jose-cfrg-curves-00.txt

A new version of I-D, draft-liusvaara-jose-cfrg-curves-00.txt
has been successfully submitted by Ilari Liusvaara and posted to the
IETF repository.

Name:		draft-liusvaara-jose-cfrg-curves
Revision:	00
Title:		CFRG curves and signatures in JOSE 
Document date:	2015-12-09
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-liusvaara-jose-cfrg-curves-00.txt
Status:         https://datatracker.ietf.org/doc/draft-liusvaara-jose-cfrg-curves/
Htmlized:       https://tools.ietf.org/html/draft-liusvaara-jose-cfrg-curves-00

Abstract:
   This document defines how to use curves and algorithms from IRTF CFRG
   elliptic curves work (Diffie-Hellman and signatures) in JOSE.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

----- End forwarded message -----

-Ilari

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 9 Dec 2015 11:51:04 -0800

The chairs and AD have not yet had a discussion about this draft.   I would
like to get some input from the group before we do so.

We have been trying to shut the group down for some time, but drafts keep
slowly dribbling in.  As long as the group believes it has the energy to
deal with these drafts we can keep the WG open to deal with them.  However,
for this document there is a second option that can be used for this
document.  There is a new CURDLES group which is designed to deal with this
group (the group should finish forming by the end of the year).  We could
finishing closing the JOSE group and punt this over to that group to work
on.

The input I would like to get would be:

1.  Do you believe that, if this document is provided, you would be
implementing this in the near future?

2.  Do you plan to participate in the CURDLES group if this document is
moved from here to there?

3.  If we are going to adopt this document, would you intend to review and
comment on the draft?

4.  Do you have a preference between JOSE and CRUDLES for dealing  with this
document?

Jim

> -----Original Message-----
> From: jose [mailto:[email-masked]] On Behalf Of Ilari Liusvaara
> Sent: Wednesday, December 09, 2015 6:42 AM
> To: [email-masked]
> Subject: [jose] Fwd: New Version Notification for
draft-liusvaara-jose-cfrg-
> curves-00.txt
primary
> WG).
> 
> (Changes from last circulated version include note about possible change
(using
> just one signature algo for all OKP) and adding draft number in order for
> submission to go through).
> 
> has been successfully submitted by Ilari Liusvaara and posted to the IETF
> repository.
> 
> URL:
https://www.ietf.org/internet-drafts/draft-liusvaara-jose-cfrg-
> curves-00.txt
> Status:
https://datatracker.ietf.org/doc/draft-liusvaara-jose-cfrg-curves/
> Htmlized:
https://tools.ietf.org/html/draft-liusvaara-jose-cfrg-curves-00
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose

---

From: John Bradley <[email-masked]>
Date: Wed, 9 Dec 2015 17:05:41 -0300

> On Dec 9, 2015, at 4:51 PM, Jim Schaad <[email-masked]> wrote:
> 
This would depend on if others implement it.  Probably it would go into the que under nice to have crypto agility if everything goes to hell with the NIST curves.
> moved from here to there?
Yes
> 3.  If we are going to adopt this document, would you intend to review and
Yes
> 4.  Do you have a preference between JOSE and CRUDLES for dealing  with this
I have a slight preference for JOSE, but would need to look more closely at the mandate of CRUDLES

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 9 Dec 2015 15:17:39 -0500

I'll just note that the new group is CURDLE and I think should be a WG
after the next telechat - Thursday of next week.  A benefit, should
the WG choose to go in that direction, is that the draft may get wider
review as it would be grouped with similar drafts for other protocols.

Kathleen

-- 

Best regards,
Kathleen

---

From: Mike Jones <[email-masked]>
Date: Thu, 10 Dec 2015 03:23:34 +0000

Replies inline below...

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Wednesday, December 9, 2015 11:51 AM
To: [email-masked]
Subject: [jose] FW: Fwd: New Version Notification for draft-liusvaara-jose-cfrg-curves-00.txt

We have been trying to shut the group down for some time, but drafts keep slowly dribbling in.  As long as the group believes it has the energy to deal with these drafts we can keep the WG open to deal with them.  However, for this document there is a second option that can be used for this document.  There is a new CURDLES group which is designed to deal with this group (the group should finish forming by the end of the year).  We could finishing closing the JOSE group and punt this over to that group to work on.

1.  Do you believe that, if this document is provided, you would be implementing this in the near future?

It would depend upon application demand for these curves when used with JOSE, which is yet to be determined.

2.  Do you plan to participate in the CURDLES group if this document is moved from here to there?

Yes, if necessary

3.  If we are going to adopt this document, would you intend to review and comment on the draft?

Yes - definitely.  I already have reviewed and commented on previously drafts.

4.  Do you have a preference between JOSE and CRUDLES for dealing with this document?

I prefer JOSE, since there is already an existing set of highly engaged experts in this group who are familiar with the reasons for the choices made in the JOSE specs.  Doing this in JOSE will help ensure that the result is consistent with the rest of the choices made in JWA [RFC 7518].

Jim

                                                          Thanks,

                                                          -- Mike

> To: [email-masked]<mailto:[email-masked]>

primary

> change

(using

> just one signature algo for all OKP) and adding draft number in order

> for submission to go through).

> ----- Forwarded message from [email-masked]<mailto:[email-masked]> -----

> From: [email-masked]<mailto:[email-masked]>

> To: Ilari Liusvaara <[email-masked]<mailto:[email-masked]>>

> Subject: New Version Notification for

draft-liusvaara-jose-cfrg-curves-00.txt

> Please note that it may take a couple of minutes from the time of

submission

> [email-masked]<mailto:[email-masked]>

jose mailing list

[email-masked]<mailto:[email-masked]>

---

From: <[email-masked]>
Date: Mon, 21 Dec 2015 15:50:04 +0100

Participating in new groups is not always easy for employees of large companies.
JOSE and CURDLE are needed on a different level.
JOSE is more practical, while CURDLE is more fundamental...

Ad 4) I prefer to keep this in JOSE.

From: jose [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Donnerstag, 10. Dezember 2015 04:24
To: Jim Schaad; [email-masked]<mailto:[email-masked]>
Subject: Re: [jose] FW: Fwd: New Version Notification for draft-liusvaara-jose-cfrg-curves-00.txt

Replies inline below...

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Wednesday, December 9, 2015 11:51 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [jose] FW: Fwd: New Version Notification for draft-liusvaara-jose-cfrg-curves-00.txt

Yes, if necessary

Jim

                                                          Thanks,

                                                          -- Mike

primary

(using

submission

jose mailing list

---

From: Mike Jones <[email-masked]>
Date: Mon, 21 Dec 2015 15:24:26 +0000

Let me second this important point that Axel made.  It's far from free for people in many companies to be able to join a new working group.  I know, for instance, that the Microsoft process to do so involves business, legal, and organizational reviews involving many people and a substantial amount of time.

In this case, given that draft-liusvaara-jose-cfrg-curves is producing a JOSE-specific result, I would far prefer that it be done in the JOSE working group, both for consistency reasons and to expedite people's participation, and thus the end result.

                                                          Thanks,
                                                         -- Mike

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, December 21, 2015 6:50 AM
To: Mike Jones <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: [jose] FW: Fwd: New Version Notification for draft-liusvaara-jose-cfrg-curves-00.txt

Replies inline below...

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Wednesday, December 9, 2015 11:51 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [jose] FW: Fwd: New Version Notification for draft-liusvaara-jose-cfrg-curves-00.txt

Yes, if necessary

Jim

                                                          Thanks,

                                                          -- Mike

primary

(using

submission

jose mailing list

---

From: Vladimir Dzhuvinov <[email-masked]>
Date: Mon, 21 Dec 2015 21:56:41 +0200

+1

Apparently we have a case where a suitable JOSE representation is sought
for a new spec of elliptic curves. So JOSE looks like the natural place
to do this.

Thanks,

Vladimir

-- 
Vladimir Dzhuvinov :: [email-masked]