Subject: [jose] Security Evaluation Request

From: Anders Rundgren <[email-masked]>
Date: Mon, 9 Jul 2018 14:17:17 +0200

If there is anybody out there interested in Web security schemes relying on OOB channels, I would very much appreciate a review or just comments:
https://github.com/cyberphone/qr-replacement#a-better-qr

If you wonder who actually use such schemes, they currently involve a billion users or so although most of them are about payments rather than user authentication.

This posting is also meant to serve as a defensive publication.

thanx,
Anders

---

From: "Manger, James" <[email-masked]>
Date: Tue, 10 Jul 2018 00:28:16 +0000

Hi Anders,

Isn't FIDO2 (aka W3C Web Authentication + CTAP) with an NFC authenticator a more thorough version of your site-PC-NFC-mobile scheme?
Both have communications from a site to the PC/browser then over NFC to a mobile that has a crypto key. FIDO assumes the browser checks the web site authentication; your scheme has a "Web NFC driver" to do this task.
The communication channels in the reverse direction are different: FIDO re-uses the same NFC channel; your scheme uses the mobile's own network. But as the security comes from the mobile's private key, there seems to be little benefit from having a separate channel - only a downside if it isn't available.

[1] DRAFT W3C Web Authentication; https://w3c.github.io/webauthn/
[2] DRAFT FIDO 2.0 Client to Authenticator Protocol (CTAP): NFC; https://fidoalliance.org/specs/fido-v2.0-id-20180227/fido-client-to-authenticator-protocol-v2.0-id-20180227.html#nfc

--
James Manger

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of Anders Rundgren
Sent: Monday, 9 July 2018 10:17 PM
To: [email-masked]
Subject: [jose] Security Evaluation Request

thanx,
Anders

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose

---

From: Anders Rundgren <[email-masked]>
Date: Tue, 10 Jul 2018 07:58:53 +0200

Hi James,

Thank you very much for looking into this!

To begin with neither mine nor FIDO/W3C's scheme actually work for the simple reason that NFC in PCs died due to "malnutrition".  For FIDO a somewhat less convenient but workable alternative ought to be using BLE or USB cable.

The W3C/FIDO scheme does indeed not have the same [potential] security issues as my [1] scheme since it builds on "in-line" authentication, so why would anybody in their right mind bother with an OOB scheme?

Well, believe it or not, there are still people out there using client side PKI.  Most of these schemes build on a rather different model compared to FIDO where the entire security operation (including UI) is delegated to the mobile device, creating a unified system [2] for Mobile Web and Mobile+PC Web interactions.

This GUI "emulator" of a system in the workings, should give you an idea of what I'm talking about: https://cyberphone.github.io/doc/mobile-id/ui-demo/

The OOB scheme and associated unified UI would obviously work (assuming it isn't broken NB...), for FIDO as well since it was designed to be "neutral".

Cheers,
Anders

1] NFC version of schemes already deployed on a massive scale in for example Scandinavia.

2] The Saturn payment authorization scheme (https://cyberphone.github.io/doc/saturn/) is another example, making POS payments and Web payments identical through the use of high-level protocols rather than ISO 7816 based card protocols.