Subject: Re: [karp] Stephen Farrell's No Objection on draft-ietf-karp-threats-reqs-05: (with COMMENT)

From: Gregory Lebovitz <[email-masked]>
Date: Mon, 24 Sep 2012 13:04:22 -0700

Hey Stephen,
We are trying to close out draft-ietf-karp-threats-reqs asap. Responses are
inline below Please let us know what you think...

On Thu, Jul 19, 2012 at 8:22 AM, Stephen Farrell
<[email-masked]>wrote:

> Stephen Farrell has entered the following ballot position for
> draft-ietf-karp-threats-reqs-05: No Objection
>

-- SNIP --

>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
>
> - Are there any weird cases where a lack of address
> aggregtaion (esp for IPv6) could create a privacy
> issue that would mean that a confidentiality service
> might be needed? (Just checking)
>

G> Possibly, but the KARP charter is very clear that confidentiality is
out-of-scope at this time.

>
> - s/privacy/confidentiality/ please
>

G> Done in upcoming v06.

>
> - the language telling secdir reviewers what to do ought
> be less presecriptive
>

G> OLD:
G> Security Area reviewers of routing area documents - These
            people are tasked by the Security Area Directors to perform
            reviews on routing protocol specifications as they pass through
            working group last call or IESG review. They will pay particular
            attention to the use of cryptographic authentication and newly
            specified security mechanisms for the routing protocols. They
            should ensure that incremental security improvements are being
            made, in line with this roadmap.

G> NEW:
G> Security Area reviewers of routing area documents - These
            people are tasked by the Security Area Directors to perform
            reviews on routing protocol specifications as they pass through
            working group last call or IESG review. Their particular
            attention to the use of cryptographic authentication and newly
            specified security mechanisms for the routing protocols is
appreciated. They
            also help to ensure that incremental security improvements are
being
            made, in line with this roadmap.

 G> Does that help? If I'm still not addressing your concern, would you be
so kind as to propose text?

> - I agree with Sean's discuss
>

G> Being addressed in upcoming -06.

G> Thanks for the review!!
-- 
----
IETF related email from
Gregory M. Lebovitz

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 25 Sep 2012 01:30:14 +0100

On 09/24/2012 09:04 PM, Gregory Lebovitz wrote:
> Hey Stephen,
> We are trying to close out draft-ietf-karp-threats-reqs asap. 

Great. My comments were from July 19th, but I understand how
asap and summer work;-)

> Responses are

It was a comment, and I don't recall the context now, but
if e.g. the draft said "no privacy issues exist" then your
"Possibly" above would seem to invalidate that claim. If
no such claim is made, probably no change is needed. (I've
not re-read -05 to check.)

>> - s/privacy/confidentiality/ please

Great.

> so kind as to propose text?

Works for me.

Thanks,
S.

---

From: Gregory Lebovitz <[email-masked]>
Date: Mon, 24 Sep 2012 19:31:24 -0700

> Great. My comments were from July 19th, but I understand how

G> Point taken ;-)

> not re-read -05 to check.)

G> No such comment in the draft. So we are closed on this one.

> > so kind as to propose text?

G> Great. Thanks for the quick reply,
G> Gregory

-- 
----
IETF related email from
Gregory M. Lebovitz