Subject: [karp] WG Last-Call Comments on "Database of Long-Lived Symmetric Cryptographic Keys"

From: Acee Lindem <[email-masked]>
Date: Mon, 5 Nov 2012 07:35:54 -0500

Comments: 

Peer Field - Remove "For example, this might name a routing area for a multicast routing protocol." This is a very bad example as the area would more likely be in the abstract interface identifier. 

SendNotBefore, SendNotAfter, RecvNotBefore and RcvNotAfter - There are already several implementations that use the term SendLifetimeStart, SendLifeTimeEnd, AcceptLifeTimeStart, and AcceptLifeTimeEnd in their keychain implementations - why can't you use these terms?  Note that this is, at least, the second time I've raised this comment.

---

From: Acee Lindem <[email-masked]>
Date: Mon, 5 Nov 2012 10:41:08 -0500

Also, the "KARP Operational Key" draft reminded me of the issue of multiple VRFs (aka, router contexts or Virtual Routers). Since this is common to all the protocols, should this be a field in the database? 
On Nov 5, 2012, at 7:35 AM, Acee Lindem wrote:

> _______________________________________________
> karp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/karp

---

From: Russ Housley <[email-masked]>
Date: Mon, 5 Nov 2012 19:09:29 -0500

> SendNotBefore, SendNotAfter, RecvNotBefore and RcvNotAfter - There are already several implementations that use the term SendLifetimeStart, SendLifeTimeEnd, AcceptLifeTimeStart, and AcceptLifeTimeE…

I have not seen support for this change.  I have no problem making these changes if there is consensus on this set of terms.

Russ

---

From: John William Atwood <[email-masked]>
Date: Tue, 06 Nov 2012 11:01:45 -0500

"several implementations"

Perhaps the consensus (or not) would come if the implementations (or the
rfc/standards document) were to be listed.  Then WG members could make a
more informed decision.  This change could be particularly helpful if
code-sharing between the database and the named implementations would be
likely.

  Bill

-- 
Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email:[email-masked]
1455 de Maisonneuve Blvd. West    http://users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: Acee Lindem <[email-masked]>
Date: Tue, 6 Nov 2012 14:38:51 -0500

Hi John,
I'm sure those who have deployed routing protocol security will be familiar with these terms. The terminology was introduced for Cisco IOS keychains. Here is a link for IOS XR:

http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.7/security/command/reference/sr37kcm.html

This terminology has been carried over to several implementations including my own, Ericsson IPOS (previously Redback SEOS) and IPInfusion routing stack offering. 

Thanks,
Acee