Subject: [KEYPROV] [issue10] Do we need to provide SOAP binding and where if so?

From: Andrea Doherty <[email-masked]>
Date: Thu, 15 Nov 2007 16:26:21 +0000

Andrea Doherty <[email-masked]> added the comment:

The question of expressing DSKPP using WSDL 2.0, and thereby including SOAP 
binding in the core DSKPP document, was raised with the Apps AD. Hannes 
summarized their comment, which was based on RFC 3205 (BCP 56) as follows:

WSDL Usage: Lisa and Chris do not see WSDL as something being 
useful. In fact, I haven't found a person who argued in favor of WSDL. 
Hence, I believe we should avoid it.

While the value of WSDL usage is controversial, e.g., BCP 56 is probably out-of-
date, the decision is to continue expressing DSKPP using XML, and keep the SOAP 
binding description in a separate document (see draft-doherty-keyprov-ct-kip-ws-
00).

----------
status: chatting -> done-cbb

_________________________________________________________
KEYPROV Roundup Issue Tracker <[email-masked]>
<http://www.tschofenig.priv.at:8080/keyprov/issue10>
_________________________________________________________

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/keyprov

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 15 Nov 2007 11:04:50 -0600

So why is WSDL not useful, it describes a interface and why wouldn't a SOAP
binding be useful  to implement that interface ?

Anthony Nadalin | Work 512.838.0085 | Cell 512.289.4122

|------------>
| From:      |
|------------>
  >----------------------------------------------------------------------------------------------------------------------------------------|
  |Andrea Doherty <[email-masked]>                                                                                              |
  >----------------------------------------------------------------------------------------------------------------------------------------|
|------------>
| To:        |
|------------>
  >----------------------------------------------------------------------------------------------------------------------------------------|
  [email-masked], [email-masked]                                                                                                     |
  >----------------------------------------------------------------------------------------------------------------------------------------|
|------------>
| Date:      |
|------------>
  >----------------------------------------------------------------------------------------------------------------------------------------|
  |11/15/2007 10:58 AM                                                                                                                     |
  >----------------------------------------------------------------------------------------------------------------------------------------|
|------------>
| Subject:   |
|------------>
  >----------------------------------------------------------------------------------------------------------------------------------------|
  |[KEYPROV] [issue10] Do we need to provide SOAP binding and where if     so?                                                             |
  >----------------------------------------------------------------------------------------------------------------------------------------|

While the value of WSDL usage is controversial, e.g., BCP 56 is probably
out-of-
date, the decision is to continue expressing DSKPP using XML, and keep the
SOAP
binding description in a separate document (see
draft-doherty-keyprov-ct-kip-ws-
00).

----------

_________________________________________________________
KEYPROV Roundup Issue Tracker <[email-masked]>
<?http://www.tschofenig.priv.at:8080/keyprov/issue10>
_________________________________________________________

---

From: "Doherty, Andrea" <[email-masked]>
Date: Thu, 15 Nov 2007 12:47:05 -0500

I think it is useful.  That said, the issue is a bit complicated, esp.
as it stems from BCP 56.  Although you may have seen it already, check
out the email exchange on the KEYPROV mailing list on this issue (dated
9/30/07 - 10/9/07).  For example, here are two excerpts from the
exchange;

Chris Newman said,

I largely support BCP 56 and as an IESG member I consider it my duty and
within 
my authority to enforce that BCP using my best judgment. However, some
of the 
advice it gives could be updated to make it better and it could use
advice in 
additional areas -- I would support an effort to revise it, although the

present HTTP WG proposal may not be the right place to do that work. I'm

uncomfortable when my best technical judgment disagrees with common
practice 
and am unlikely to use my IESG authority to permanently block forward
progress 
on a document in that case. However, when I'm aware of a BCP rule and
agree 
with it, I consider it my duty at a minimum to verify the community
considered 
the rule and had explicit community rough consensus to violate it.

Phillip Hallam-Baker:

Web Services is a standards based architecture with broad industry-wide
support. Keith's RFC was written in 2002 before the Web Services
architecture was developed. There is clearly a conflict between the
views being advance here and established practice for the design and
implementation of Web Services based specifications.

It is not helpful here if the IETF is going to insist on a separate
definition of Web Services specifications that is not in sync with where
the Web Services world is.

Either the BCP56 view is right in which case we need the proponents of
this view to be talking to the wider Web Services world (OASIS, W3C) and
arriving at a consensus position or the BCP56 view is obsolete and needs
to be updated.

In either case this is an issue that the IAB needs to address. BCP56 is
their work product, I believe. They need to be maintaining it.

In particular the idea that WSDL is somehow dispensible as a component
in the Web Services architecture is not a widely held position within
the Web Services world. 

-- Andrea

________________________________

From: Anthony Nadalin [mailto:[email-masked]] 
Sent: Thursday, November 15, 2007 12:05 PM
To: KEYPROV Roundup Issue Tracker
Cc: [email-masked]
Subject: Re: [KEYPROV] [issue10] Do we need to provide SOAP binding and
whereif so?

So why is WSDL not useful, it describes a interface and why wouldn't a
SOAP binding be useful to implement that interface ?

 Andrea Doherty ---11/15/2007 10:58:23 AM---Andrea Doherty
<[email-masked]> added the comment:

From:	 
Andrea Doherty <[email-masked]>	

To:	 
[email-masked], [email-masked]	

Date:	 
11/15/2007 10:58 AM	

Subject:	 
[KEYPROV] [issue10] Do we need to provide SOAP binding and where if so?	
________________________________

The question of expressing DSKPP using WSDL 2.0, and thereby including
SOAP 
binding in the core DSKPP document, was raised with the Apps AD. Hannes 
summarized their comment, which was based on RFC 3205 (BCP 56) as
follows:

While the value of WSDL usage is controversial, e.g., BCP 56 is probably
out-of-
date, the decision is to continue expressing DSKPP using XML, and keep
the SOAP 
binding description in a separate document (see
draft-doherty-keyprov-ct-kip-ws-
00).

----------