Subject: [KEYPROV] Key Container Attributes

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 06 Dec 2007 22:37:34 +0100

During Ming's presentation we also discussed the alignment between the 
XML and the ASN.1 key container.

I see at least the following options:

* Put the attributes/elements in both documents
This would require to duplicate the description of the semantic, 
essentially.

* Create one document that contains the attributes/elements.
This document would be used by the XML-based and the ASN.1 based key 
container.

Both approaches have pros and cons. Nevertheless we need to make a 
decision. NOW.

PLEASE EXPRESS YOUR OPINION.

Deadline: 17th December 2007

In any case, we need to describe the semantic of the attributes and 
elements better.

Ciao
Hannes

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/keyprov

---

From: "Philip Hoyer" <[email-masked]>
Date: Sat, 8 Dec 2007 00:07:58 +0100

What about my proposal?

Put the definition in a clearly referenceable section of the MANDATORY
container (PSKC). ASN.1 spec can then reference that section.

Philip

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Thursday, December 06, 2007 9:38 PM
To: [email-masked]
Subject: [KEYPROV] Key Container Attributes

Ciao
Hannes

---

From: "Pei, Mingliang" <[email-masked]>
Date: Fri, 7 Dec 2007 15:25:20 -0800

I like this proposal better. It is still shared and common to both but
save to have two docs per spec.

- Ming 

> From: Philip Hoyer [mailto:[email-masked]] 
> Sent: Friday, December 07, 2007 3:08 PM
> To: Hannes Tschofenig; [email-masked]
> Subject: RE: [KEYPROV] Key Container Attributes
> 
> What about my proposal?
> 
> Put the definition in a clearly referenceable section of the 
> MANDATORY container (PSKC). ASN.1 spec can then reference 
> that section.
> 
> Philip
> 
> During Ming's presentation we also discussed the alignment 
> between the XML and the ASN.1 key container.
> 
> * Put the attributes/elements in both documents This would 
> require to duplicate the description of the semantic, essentially.
> 
> This document would be used by the XML-based and the ASN.1 
> based key container.
> 
> Both approaches have pros and cons. Nevertheless we need to 
> make a decision. NOW.
> 
> In any case, we need to describe the semantic of the 
> attributes and elements better.
> 
> Ciao
> Hannes
> 
>